MyCloud EX2 setup issues

Hi there

I’m having real trouble setting up my EX2 and I was hoping someone could help. First of all, I’m using Windows 7 with a Virgin internet connection.

When I first turn on the EX2, the blue disk LEDs go solid blue and the power LED starts flashing blue. This happens for a few minutes, but it then starts flashing orange.

If I check my router, usually the EX2 is recognised (although sometimes it’s not). However, it never shows up in the Network section of Windows Explorer.

The setup installer can find the EX2, but is unable to format the drives. It just sits at 0% for ever (I’ve tried leaving it to format overnight and it never moves past 0%, even though the installer says the whole thing should take 10 minutes). I know the drives are fine because I have formatted them myself and checked them by hooking them up to my laptop.

The MyCloud dashboard indicates that there is new firmware to download, but trying to update via the dashboard has a similar problem to the installer - it can’t do it. It just says “importing firmware” for ever and never gets past that. The WD firmware download page doesn’t seem to load, so I don’t know how else I can get the firmware.

I’ve also tried setting up a RAID configuration via the dashboard, but strangely doing that causes the EX2 to think that the drives in the box are corrupt, when they aren’t (they’re WD Reds by the way).

I’m at my wit’s end here. The NAS just refuses to work. It was advertised as being easy to set up and use, but I’ve found it to be exactly the opposite.

This is actually the second time this has happened - I sent back the original EX2 I bought for the same reason. I find it hard to believe that I was given two EX2s that were faulty in exactly the same way, so there must be some sort of solution to this. I just can’t for the life of me work out what it is.

Any help you can give would be gratefully received.



Please try resetting the unit using the reset button on the back of the unit.

Also, check your firewall settings on your router to see if that is not allowing the unit to get the new firmware.