No WD My Cloud EX2 found

I have spent the last few hours unsuccessfully trying to install a brand new My Cloud EX2 10 TB. I connected it to power and via ethernet to the same Apple Airport Extreme router my PC is on. I downloaded the setup software, and per the instructions, waited until all LEDs were solid blue. The setup software said “no wd my cloud ex2 found”, so I checked the leds again, rescanned, got the same error. I restarted the NAS by disconnecting it from power for 30 seconds, no change. Moved it to another port on the router, no change.

I downloaded “WD Discovery” software and ran it, it won’t see the NAS, Then I downloaded “My Net View”, also doesn’t see it. In my PC (Win 10 Pro), under “Network” there is nothing for the EX2. I connected my laptop to the network, it doesn’t see the EX2 either.

I am running a My Cloud Mirror 2TB on the same network, and it was a no-brainer to set up. It’s still running great after over a year. My new EX2, otoh, just refuses to play nice. Before I return it, as a last resort, I wanted to ask here if anyone has successfully solved a similar problem. Any suggestions? Thanks!!


If you have the option for returning it, I advise you to change it for a brand new WD Mycloud EX2 Ultra, because it’s cheaper and much better than WD Mycloud EX2.


Either I have the option of returning it or I wasted a lot of money, unless someone here can help me sort this out. Unfortunately, I bought it in November, for an HTPC that became a case study in Murphy’s law. I finally finished the pc a couple of days ago, and them it was time to set up the nas, populate it with media, and start using it. That turned out as right as every other aspect of this build. Anyway, the return window on the ex2 passed several weeks ago, so I’m at the mercy of the good or ill will of the vendor.

So, no luck. “Computer Brain” on Amazon will not take the EX2 back - their return window was 20 days, and it has been almost 120 since my purchase, so they suggested I RMA it. I went ahead and did just that, and, much to my surprise, found that, on the pulldown menu where you select the reason for returning it, one of the options is “not seen by network”.
Anyway, “the brick” will be on its way to WD tomorrow, and hopefully I will have a functioning unit in a few days.