Took the plunge with firmware 4.00.01-62​3

Last night I updated the firmware of the My Cloud 3TB drive from 4.00.00-607  to 4.00.01-623 using a Windows desktop. I had not installed any other 3rd party applications or modified system files on this drive. So far, so good. The speed of copying a 1GB file from an Ethernet connected (wired) desktop went from 30-33 Mb/s to 44-47 Mb/s. The dashboard is also performing a lot better. It’s only been about 12 hours, but  I have yet to experience any connection issues. Below are the steps that I took to update the firmware. Not all the steps are necessary, but out of an over abundance of caution these are the steps I usually follow when flashing firmware on a LAN attached device. Btw, I update directly from a wired Windows desktop/laptop to avoid Internet traffic and wireless interference issues while updating. Some of these steps are mentioned in the release notes and others I learned elsewhere, so I take no credit for them. I’m just posting them here as a reference for those that also want to update from their desktop. I’m not responsible for any issues that might come up while using this process or if you brick your drive. I have no relation to WD.

  1. Download the firmware to a folder in your desktop, unzip to get a file named  sq-040001-623-20140904.deb.(DO NOT rename this file)

  2. Disconnect any external drives attached to the USB port (Use the WD Dashboard to remove them safely and wait until the number of shares is reduced by one) 

  3. To update try using a browser with just the one tab with the Dashboard open

  4. Open the WD My Cloud Dashboard UI. Go to Settings >> Firmware Update. Under the Manual Update section, click the Update From File button. A pop up file explorer window will open. Browse to the folder where you saved the ssq-040001-623-20140904.deb file and select it. You will see an Install Firmware Pop Up - Select Install and Reboot

  5. NOTE - Once the updating process starts Do Not interrupt the process as it might brick your device.

5.You should see another Pop Up window with a blue progress bar (While installing the process pauses at 10% for a while then jumps to 60% for a couple minutes, then 70% for a few moments and  to 90% for about 1 minute then another pop up comes up telling you that the drive is rebooting… be patient)

  1. After it finishes updating perform a full Shutdown via the Dashboard. Then unplug My Cloud drive and plug it again. When it comes back up  re-connect any USB external drive(s). You might get a USB connection error. click OK to ignore it. I don’t know why this error happens, but my external drive appears to work fine.

I hope this helps someone.

Edit: I do not use the DLNA Server or iTunes (Both disabled)  If you use these your mileage might vary.


I tried the new firmware on 4T.

I can say its been better. But ton enough. We got away from the last brick and now we are in a smaller.

Everything goes fine up until you plug the external USB.After a couple of hours the drive goes mad… with reported loads of 135. at some point twonky stops responding. you try to shutdown and it never shuts down.

I have an extrenal USB of the same size for safepoint. Also have media streaming on. Total data 2,8 TB. This configuration was from the very first time with version 3 so its not something new or has to do with the usb drive.

after unpluging the usb and a hard cycle, the brick booted… left it on and everything is ok… streaming etc and better performance than the previous but still not as good as the last version of major v 3.

So after 24 hours… I disabled the twonky via dashboard… shutdown… pluged the usb… boot… everything ok… left it for 4 hours… OK… enabled twonky and the driver started to slow down after 3 hours… loads reported via top command 145. and 3 zombies… all twonky. And again no shutdown… cannot kill the zombies even after the service is shutdown… a lot of handles open in /proc/fs

So for the time being… no streaming to co-op with this mess. Why WD cant you get it right?

anyone else? im hesitant up try the update again. Like many others I reverted to version v03.04.01-230 : Core F/W

ok i dove in (crosses fingers)

how long does the update take? I waited 30min with zero progress.

Just took the plunge and upgraded here are my initial thoughts

Download and reboot took about 15 mins and was pain free but I was worried it would die !!

Initially seemed a bit slow so did another reboot that seemed to take longer than normal but I just waited.

Dashboard seems to be a bit quicker than the older firmware

Tested a 1.2 GB download and it took about 11 second but the speed varied between 40 - 90 Mbs but overall is a few seconds quicker that I used to get.

No issues found so far but I have only been using it a hour or so.

My Dashboard-initiated f/w update has been going for almost 20 hours.  It’s been stuck at 62% for the last 12 hours.  What to do … ;-(

The Good News:  this is a brand new, just out of the box unit, so if a factory reset is required, I’ll only lose my user definitions, etc.

Being careful is always a good idea and I never upgrade it I am satisfied with the current version

that said I upgraded mine from work with the android mycloud app, no issues. i don’t have any external drives attached.

I now have the wdm* services enabled, it is definitely a load on the system but not really noticeable from a usage standpoint