Thunderbolt 3-Interface not reacting, USB works

  1. iMac with Thunderbolt 2 (via Thunderbolt2/-3 Adapter): This is the normal setup, which worked for nearly 2 years. It is not reacting now.

  2. MacBook Pro with Thunderbolt 3: Also not reacting.

  3. MacBook Pro, via USB-C-Port of G-Drive: Working normally. No corruption of data, hard disc seems to be ok. With this setup i saved all data from the G-Drive to another drive.

  4. Windows-PC with USB 2.0 (showing up in hardware, but not mounts (which is normal, since the drive is in the original condition, formatted for mac).

I have rebooted and reconnected all hardware, this brought no changes.

In order to reset the drive, i downloaded “G-Technology_Firmware_Update_Utility0614” for mac, but with “macOS Catalina Version 10.15.4” it was not possible to use (“This package is not compatible with this macOS version.”). I tried it on both macs (Setup 1. and 2.).

So i tried to do the firmware-update on the Windows-PC. It was possible to launch the tool, but it didn’t found the drive (connected via cable USB-C to USB-A, see Setup 4.).

Since the G-Drive is still under warranty, i can send it back.

Before i do that, i would ask the forum. Maybe someone has an idea, how to reset the Drive or fix the problem on another way?