There is no media in the current folder


#1

Hello all,

i just got my WDTV Live and updated it to the most recent firmware when prompted (1.02.21).  I am running an XP machine and trying to share folders off it, but all I get is “There is no media in the current folder”.  I have done some research and tried some things, they have been:

  • changing my home workgroup all to “WORKGROUP”

  • Added “everyone” to the shared folder

  • turned off and on and back off simple file sharing

  • created numerous accounts with varying degree’s of permissions

  • tried sharing whole drives and individual folders with different permissions

Can anyone else think of anything I have not tried yet?


#2

Welcome to the forums.

After you update the firmware you need to reset your Live unit back to factory conditions (and then, of course, redo your network and shares).  After this you should be okay.


#3

I should have mentioned that I have done that as well numerous times, I have done the soft hardware reset and the hard hardware reset as well.  And after these resets I went and re did the shares on the WDTV as well as on my computer.  I think I am looking for something I maybe missed on my computer side…


#4

You don’t have WIndows Live ID assistant installed, do you?

And I assume you’ve turned off the passwords on the shared folders, correct?  So walk me through this – you choose, say, “video” and then “Net Shares” (not media server) and you see your shares, right?  It’s only when you select one or more that you get the “No Media” message?  And, I assume, you DO have videos in those folders?


#5

Maybe you should check the login password first.

switch OFF the 'auto login network…'option in Network Menu then log in to the network.  you will be asked for username and password, just type administrator for username, blank for password and it will work (or will not I’m not sure).That was my case, hope it will fix


#6

No I checked and I do not have Windows Live ID assistant installed.  I recently reformatted this computer to be mainly a downloader and media storage PC so it is very bare bones, I run AVG for anti virus, and ad aware and windows defender for other security.

As for a walk through, yes I go to Video on the WDTV, then choose network shares, I see my NAS (which works) and my PC, I choose the PC and then it gives me the message “There is no media in the current folder”

Also when experimenting with the shares I put a couple mkv’s just in the Hard drive when sharing the entire drive, not in sub folders in case it was having trouble searching the sub folders.  As well I tried sharing a folder with mkv’s in it.

I have been trying only one share at a time while doing this troubleshooting to just keep it simple, either the entire drive or a folder on the drive.


#7

I have been trying varying combinations of the auto login on the WDTV, I try it on at first, but now that I have created and deleted a few accounts (just a note everytime I try a new account I do a soft reset to factory on the WDTV).  I have also tried loggin in as administrator with the admin password and still the same message.


#8

Oh and how do you turn password share off in XP?  I was looking around for it and could not find it, I found it in 7, but not in XP


#9

grog1975 wrote:

No I checked and I do not have Windows Live ID assistant installed.  I recently reformatted this computer to be mainly a downloader and media storage PC so it is very bare bones, I run AVG for anti virus, and ad aware and windows defender for other security.

 

As for a walk through, yes I go to Video on the WDTV, then choose network shares, I see my NAS (which works) and my PC, I choose the PC and then it gives me the message “There is no media in the current folder”

 

Also when experimenting with the shares I put a couple mkv’s just in the Hard drive when sharing the entire drive, not in sub folders in case it was having trouble searching the sub folders.  As well I tried sharing a folder with mkv’s in it.

 

I have been trying only one share at a time while doing this troubleshooting to just keep it simple, either the entire drive or a folder on the drive.

Turn off auto logon to the shares and then connect to your PC manually.

You should see at least a folder or drive before it gives you that  message.

With network shares there is no searching sub-folders, you have to select the folders manually.


#10

Do you mean auto login on the WDTV?  If so I get the same message if it is on or off.   Also I see nothing after loggin into the computer through the WDTV, I just get that message.


#11

Do you a have a user name / password on the shares?


#12

The only user name password on the shares is my accounts on the PC, there are no individual user names or passwords for shares.  For example I created an login on my PC called “wdtv” made it a regular user (no admin) and it has a pasword of “1234”.  Under sharing on the folder I am trying to share I added this user under sharing of the folder and gave it full control.  I also added it under security with full control.  Also under security everyone has full control as well.


#13

So your NAS works but your XP shares don’t, right?  Can you see those shares with another computer (and access them correctly)?

And I’m sorry, I’m old, so I don’t remember: you did rename the workgroup to “WORKGROUP”, correct?


#14

Yeah my NAS works fine, I use it for pictures and Music (it’s only 200 GB), I can see the NAS shares from my XP machine and from the WDTV.  I can also see the shares on my XP machine from my wifes laptop (she runs windows 7) and I put a test share folder on her laptop with an mkv in it and the WDTV saw it and played it no problem.  Also I can’t remember if I mentioned it or not, just for **bleep**s and giggles I turned on the media sharing in my Windows Media player and the WDTV seen it fine from the Video --> Media Player menu, I was able to see all my AVI and music, but none of my mkv’s.  I turned it off after I got it to work to continue troubleshooting this folder share issue.


#15

Hmmm, curiouser and curiouser (as Alice would say).  So the Live works with your NAS AND with your wife’s laptop shares?  And it works with Media sharing?  So it’s obviously not the Live but something with that XP machine.  And what about “WORKGROUP”?  Did you rename your XP workgroup to that?

It HAS to be something to do with your AV or perhaps some other program (I know, you said you weren’t running much on that machine but it’s pretty clear there’s something wonky with it).  Try turning off the AV just temporarily. 

There’s a thread somewhere here where someone had UAC turned on – I think this is in XP as well, so you might check it and make sure it’s off on your XP machine.  Other than that I’m running out of ideas (but perhaps Rich will jump back in here).


#16

Sorry I forgot to address that, yes I renamed the workgroup to “Workgroup”.  Yeah when I get home tonight I am going to try and unistall my AV, ad-aware, and Windows defender to see what happens, I will be mad if it is that thou.  Also by UAC do you mean User Account Control?  If so I will check that out as well.

Thanks for all the help everyone whos commented.


#17

Try to add a new user account on the xp with the same name like wd (WDTVLIVE by defaut). And then, add this account to propriete of the share folder and security with full control


#18

grog1975 wrote:

Yeah my NAS works fine, I use it for pictures and Music (it’s only 200 GB), I can see the NAS shares from my XP machine and from the WDTV.  I can also see the shares on my XP machine from my wifes laptop (she runs windows 7) and I put a test share folder on her laptop with an mkv in it and the WDTV saw it and played it no problem.  Also I can’t remember if I mentioned it or not, just for **bleep**s and giggles I turned on the media sharing in my Windows Media player and the WDTV seen it fine from the Video --> Media Player menu, I was able to see all my AVI and music, but none of my mkv’s.  I turned it off after I got it to work to continue troubleshooting this folder share issue.

Just for info I don’t believe that Windows media server supports .mkv files.


#19

grog1975 wrote:

Sorry I forgot to address that, yes I renamed the workgroup to “Workgroup”.  Yeah when I get home tonight I am going to try and unistall my AV, ad-aware, and Windows defender to see what happens, I will be mad if it is that thou.  Also by UAC do you mean User Account Control?  If so I will check that out as well.

 

Thanks for all the help everyone whos commented.

If you have problems its best to turn off all security while you are troubleshooting. If you are worried you can disconnect your network from the internet. You should also turn off any firewalls and anti-virus progs. No passwords on shares and simple sharing on the XP. To share on my XP machines I simply right click on the folder, click ‘sharing and security’, then click the box ‘share this folder on the network’. Once it is working you can turn things back on one at a time.


#20

You are correct Windows Media Player does not support MKV’s, I was just using the media server to see if I could get it to work.