Looking for help - "There is no media in the current folder", but there is!


#1

I cannot believe this is so hard to figure out.  I’ve been at this issue for several hours now and I’m out of ideas.

I am running a Win 7 PC and so far everything works and I love my WDTV.  The only issue I have is that the main location for my video media does not appear to be sharing properly.  To clarify, the device works and plays everything fine , it’s just the folder I use is not being shared properly and I think I’ve made it just about as “share-able” as humanly possible.  So this is where I need help.  I would like to set up my PC so that my WDTV can see whatever I want it to.

When I select the folder in question - which has a wide variety of digital media in it and is called Video Media - there is a message on screen that says “There is no media in the current folder”.

A couple of things worth mentioning.

First, there were also some music (MP3) files in this same folder that were visible and played with no problem.  So for some reason this folder will share MP3 files , since I have moved them out of that folder I get the “no media” message.

Second, these same video files are visible and can be played when I copy them to another folder, those being User, Default, and Public.  I have right-clicked on the folder and set all the sharing options to include everyone and pretty much everything else I can think of, but still, no video files in that folder.  So I can play the full variety of video media, just not the ones in this folder.

Any assistance offered would be greatly appreciated.  Thank you.

Update -  I was able to create/add a shared folder in the Advanced Sharing properties menu for my Video Media folder.  That new folder is visible to the WDTV, and files in that folder can be seen and played.  However, files that are in this new directory that are in Folders cannot.  I just want to make the Video Media folder and everything in it visible, whether it’s in a folder or not.  Again, thanks for any help offered.


#2

Welcome to the forums.

Right cilck on your Video media folder and make sure you add “Everyone” to your share (in advanced tab).


#3

To add to what mkelley just suggested, if that doesn’t catch it all, try this:

Right click the folder, select PROPERTIES.

Click the SHARING tab.

Click ADVANCED SHARING.

Click the PERMISSIONS button.

Under “Group or user names”  the user “Everyone” should be listed.

When you single-click Everyone, on the lower pane, at least “Read” should be checked under “Allow.”

If that doesn’t change the behavior, then:

Go to a folder that contains a file that is not showing up.

Right click the FILE, select PROPERTIES.

Click the SECURITY Tab.

Click “Everyone”

Click the Advanced button.

You should see a line that says "Allow / Everyone / Full Control … " and under Inherited From, it should indicate the folder that you shared above.


#4

Actually, if you just Right-Click and Add Guest to the list of shared it seems to work fine.  Thank you for the responses, a lot of people seem to ask this question.


#5

I am getting the same “There is no media in the current folder” message

I am running xp pro sp3

i am use zonealarm firewall (i added wdtv live to a zone so that is not the issue)

i am behind a linksys router/ not wireless

i have my network set up and it does work.

I did not have this problem until a recent firmware update, it used to work fine.

i have searched for hours to try to fix this issue.  i even formated my main drive an reinstalled everything/ setup network to make sure it wasnt on my end.

i thought it was the unit so i requested an RMA mailed back my old unit and received the new one.  I am still having the same issue.

can anyone help please

thanks


#6

Welcome to the forums.

Did you check to make sure you don’t have Microsoft Live ID assistant installed anywhere on your system?  This will cause issues – in fact, even if your system just updated the Live setup you will have issues.

Check to make sure and uninstall it if it did – while I don’t *think* it affected XP systems in the same way it did for Win 7 users it may have (and it’s even more insidious if it works the same way, because in the newer updates even uninstalling it won’t fix things and you need to roll back before the MS updates).

Even reinstalling things on your computer won’t help if the MS updates it automatically – that’s why I recommend turning auto updates off (I don’t allow MS to “fix” something which isn’t broken).

If that doesn’t help, describe for us your network (how many PCs, what OS if other than the XP box, what other devices you might have attached, etc.)


#7

Mike “ex-genius” Kelley

I did have various ms live items installed. i uninstalled them using revo uninstaller (digs in registry).

I have autoupdates turned off, i only dl ms updates if i am having an issue

before i go any further you recommend that i roll back to when i installed the ms live updates?

I only have this one pc created for my network, my other pcs i dont use and are not on the network

I am running xp pro sp3

zonealarm firewall (already added wdtv live to the safe zone)

im running avg free antivirus

behind a linksys router (hardwired not wireless)

i have Pogoplug set up and running on my network

After i uninstalled the windows live features i rebooted.  i fired up wdtv live and still get the same error.

at this point should i format if i cant roll back?

thanks


#8

We know now that the Windows Live latest install breaks WDTV even if you uninstall it (apparently there are some hidden updates that don’t get removed).  So restoring to a date previous to its installation is necessary.

Now, if you *are* in a position to reformat that will also do it, but you shouldn’t have to reformat your whole PC (actually, you really shouldn’t have to get rid of Live but currently it’s an issue.  WD is aware of it and hopefully at some point they will fix whatever havoc it’s wrecking.  While it’s not a HUGE deal, the Live stuff is going to be required for the Win Phone and I suspect just about anything else Gates and Co. have in mind down the road).


#9

In GENERAL, the Windows Live ■■■■ makes the error “Invalid User ID or Password” when logging on.  If you’re getting BEYOND that, it’s probably not a Live issue, but I won’t say it’s impossible.

In general, a “No Media” issue is a sharing permissions issue.

Here’s what some people have tried that supports that idea:

Create a NEW FOLDER.

Copy a file over to that new folder (which should inherit the permissions of the folder itself.)

Many times when folks do that, lo and behold, those files work.

From what I’ve read XP PRO REQUIRES file-level authentication; the equivalent of “Share with Everyone” or “Anonymous” stuff doesn’t exist in XP PRO.   But the only place I use PRO is at work, so I don’t get to monkey with all the settings because they’re locked out.  :)


#10

Thanks for getting back with me i appreciate the help.

I tried creating a new folder and moving items over to the folder but it did not work.

On Friday after work i will format and start over.  What Windows xp updates should i not install?

thanks


#11

I had a similar problem. Mine wasn’t even asking for login info before declaring there was no media. So I restored it to factory defaults and it all works fine now.


#12

Mike “ex-genius” Kelley
Tony 'Propeller Head’12345

Thanks so much for your help.  I formated my hdd and started over.  I updated my windows (windows xp pro/sp3) and grabbed all updates except the WINDOWS LIVE.  I am happy to say that my WDTV Live now sees my networked hd.  I no longer get the “there is no media in the current folder” error.  My gf is so happy.  Now she can bore the hell out of me with her crappy sex in the city  and grey’s episodes that she watches non-stop.  Thanks again for your help.  i really apprecaite it.

I had also called WD’s tech support.  They had me try a beta firmware update.  It didn’t work.  I  wrote back to them notifying them that it was the Windows LIve update that jacked up the WDTV Live network issue.  Hopefully they will be able to fix this issue for others. 

thanks again

tbm


#13

Glad you got it working – hey, it *could* be worse, your gf could be a “Twilight” fan (yesterday my wife wanted to watch the first two again so we loaded up the Rifftrax versions and even with the funny comments I found it excruciating to get through.  I just want to punch Bella in the face over and over again sooooooo much… and I’m a non violent sort would would *never* hit a woman, although in her case she’s the exception that proves the rule :>)