The local device name is already in use

Mapping the drive in Windows 10 can be done using either drive name or IP address. However, when the computer is rebooted can not access the drive (mapped drive shows with red X)

An Error occurred while reconnecting Z: to \MYCLOUDEX2ULTRA\Public
Microsoft Windows Network: The local device name is already in use.

Tried mapping using command prompt and command is accepted but the mapping does not show in File Explorer. ex How to map network drive using Command Prompt on Windows 10 • Pureinfotech net use Z: \vm-beta\ShareOne password /user:admin /persistent:yes

The fix in Share Access Failure - Multiple Connections To a Server or Shared Resource by the Same User Not Allowed was tried.

Hi @techcoor,

I appreciate that you have performed the troubleshooting steps.

For more information please contact the WD Technical Support team for best assistance and troubleshooting:
https://support-en.wd.com/app/ask

Have talked to three different WD Technical Support and made no progress. Even selected Escalate which got me nothing.