The Backup disk image could not be created

Hi, I just started to use the WD My Cloud product for my personal backup. I am trying to use Time Machine tool from my MAC (MacOS Sierra 10.22), firstly it can detect my WD storage, start the backup from time machine, but after some time it shows an error saying ‘The Backup disk image could not be created’. I am sharing the picture here. Please suggest me to the way forward.

Regards/ M Kabir

Hello,

Are you creating the backup to a private share?

Please try resetting the unit and test that again.

Dear Morel,

Thanks for reprly.

Ya, I am trying to do into private share.
Are you suggesting to default reset or WD format?

Just a 4 seconds reset.

Press and hold the reset button for 4 seconds and let the unit restart and test that again.

Hello, I am having the same issue I have rest, rebooted, renamed the backup folder, turned on and off the time machine backup and still am receiving this exact error. I am running Mac Os 10.12.3 and my WD my cloud is firmware version 2.30.165.

Please help!

Thanks!

Hi guys !!

Anyone found the solution ?

Anyone find a solution to this as I am now also getting this error?

Thanks

Anyone?

I also have the same issue here.

Have tried all resets including full factory reset.

Drive works fine to transfer data via drag and dropping of files from all devices

Cannot create a Time Machine backup disk image on either of my MacBooks and has the same error as the image above

Has anyone any idea on how to solve this?

I am having similar issues and created the following thread but had no response as of yet: