Super-slow transfer (1-2 MB/s) - please advice

So I just installed my WD My Cloud 3 TB, and started transferring files from my computer. The transfer is going extremely slowly - between 1 and 2 MB/s. I am aware that phsyically connecting the computer to the My Cloud would help, but I don’t want to have to do that everytime I transfer large files. If someone has any suggestions to speed transfers up, please share.

My gear:

  • A brand new Lenovo X1 Carbon (computer)
  • A brand new WD My Cloud 3 TB with mirror
  • Netgear N300 router

I am using the ethernet cable that came with the My Cloud (Cat 5e) to connect it to the router. When checking the port lights on the back of the My Cloud, they are orange/flashing green. I have come to understand that this means that the connection is 100 Mbit/s. I am not sure why this is - the Netgear N300 has Gigabit capability, just like the cable, and obviously the My Cloud.

Regardless, even if I for some reason am limited to 100 Mbit/s, I still don’t see why I only get 1-2 MB/s, and not closer to 10 MB/s.

I would greatly appreciate any help. Thank you.

approximately how many files? and average size?

what type of files are being uploaded? Pictures …

Per the Amazon listing there are 2 versions of the N300. Which do you have?

If you actually do have the Gb version it is strange it is not using it. maybe try a different cable. if both ends are Gb it is have some issues and can’t really predict the impact.

in reality you will rarely see full speed and at 100Mbps a transfer rate of 5-7MBps is a lot more typical. many small files will be much slower.

A lot of images will also have a big impact.

1 Like

Mostly movies (.avi). File sizes between 500 MB and 10 GB.

Funnily enough, I have a third version the Netgear N300 WNR 2200. But it seems to have only 100 Mbit/s capability. Thank you for highlighting this!

Still a bit disappointed by the 1-2 MB/s transfer speed, but maybe that’s just the way it is…

since the router is 100Mbps the cable is probably fine

For larger files I would expect better.

How long have you had the drive up?

Are the movies the 1st thing you are transfering?

The drive has been up for a few days. I have tranferred some other stuff, also at low speeds. Those transfers were smaller though (a few GB containing mostly pictures) so I didn’t really care then.

I have now grown tired of the 1-2 MB/s and connected the computer directly (i.e. physically) to the My Cloud via the ethernet cable / ethernet to USB converter (my computer does not have an ethernet port). Now I am getting speeds of 5-6 MB/s, which also seems low to me (although I am by no means an expert on this matter). Maybe the ethernet to USB converter is a bottle neck?

do you have firmaware 4? Welcome to the club of satisfied users WD brand hardware…

coldmejl wrote:

 Maybe the ethernet to USB converter is a bottle neck?

Quite possibly – What kind is it?  

the pictures are probably the main issue. If you are at all comfortable using SSH I would disable the photo process with the command below. If you change your mind later just change stop to start and disable to enable. These kill system performance.

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

Firmware: Yes, firmware 4.something

USB-ethernet cable: It says USB 2.0 Ethernet Adapter on it.

Photos: I don’t think it’s the photos - the problematic transfer concerned movies only.

Thanks guys!

but part of the issue is the background load from the images. how many images did you load? the more images the bigger the issue. those 2 services can really cripple the mycloud

I would also remove the USB Ethernet from this until you get reasonable throughput on the Ethernet connection, which for your video files should be at least 5Mbps

have you setup smartware or any other backups yet?

do you have any other PC or device on your network? since you computer is wifi I would like to check the actual throughput from it to another device as there are a lot of things that can impact the throughput.

Just received MyCloud yesterday and set up went fine. But when I tried my first  backup through wired ethernet (Gbit) using the Smart Ware program it was running painfully slow. Right at 1.5 Mbit/s. I waited a half hour only to be about 70 MB into a 500+GB backp. So I cancelled and went through WIn 7 backup and restore and it only took 40 min for the 500GB+. Have you tried that?

All settings are pretty much as is out of the box. To use the Smart Ware you DO NOT use categories as that will bring the speed down to Kb/s. switch to FILE BACKUP and check individual folders or files. With the app I just did 3 GB in less than 10 minutes. And repeated for all my files over WiFi and its running just as fast (ASUS AC68U router)

Try turning off media sharing in Windows see if that helps. Depending on your router’s firmware see if you can adjust the QoS settings to the higest for file transfers, also try turing off WMM. I beleive the WAN cloud features on this device is causing the file transfer issues using WD’s applications. When I map the drive \WDMyCloud\myfolder files transfer as they should, fast. But as soon as I disconnect and use their program to tranfer files there seems to be a bottleneck somewhere.

You have another option by using FTP. Download a FTP client like Filezilla and turn on FTP in settings. You will have to get you IP user and pass plus the port. I haven’t tried but it should work.

Try turning off your real time scanning for any anti-malware or virus program. They can interfere. Don’t forget to turn of all media sharing in WIndows.

For now,  would just use it as a regular NAS and connect through Windows Explorer. If it asks for a password it is either the onefor the shared folder if set up or your router’s password. I don’t understand why but it worked for me.

I hope this helps. Every set up is different. And get rid of the ethernet to USB. Just connect to your router. It will be just as fast since you have a 2.0 USB adapter.

Can you please give me some advise regarding slow upload speed as I find this very slow speed very frustrating in deed and surprised to see so many issues regarding a well branded producd on here, I starting to wish I brought a nother 4TB drive provided by others.

Anyway hopefully we can resolve the problem.

I have been trying to upload my smart ware file on the drive to my new Dropbox account and it is very slow, I have about 700Gb of data to upload and so far it has uploaded about 100Gb in three weeks, poor really. I have the latest firmware installed on the drive and have ran any tests which report that the drive is running correctly. The drive is connected direct to the router as recommended in the manual.
Any help or support would be greatly appreciated.