Sudden New Problems with NAS


I have started having a problem streaming from my NAS. I have a WDTV Live G 3 running the latest available firmware. My WDTV LIve is cabled, not WIFI. I am running an unRAID box from an HP miniserver.

Until around a week ago it was working fine, I was able to fully access all my files on my NAS as a network share and stream them without issue. Suddenly my box will not readily access the NAS. When it finds it - which it does most of the time - access is sluggish and unresponsive with scrolling through folders taking an age and freezing on the menu, before suddenly catching up and jumping on through multiple folders.

When I try and play files that a week ago played fine the start up is very slow and then after a very brief period - usually 10 seconds to a minute the files stops playing and I get booted back out to the library. This happens with every file.

So a couple of things seem to have happened around the time this fault appeared:

  1. I had a power cut and the NAS (and all my electrical kit) had a sudden power down. Subsequent parity checks on the NAS found no fault.

  2. I updated the Plex docker on my NAS - I use Plex for other streaming devices in the house.

I have tried the following to see if I can identify the problem:

  1. I can access the NAS from elsewhere on the network fine using SMB and Plex and all files play fine on other devices

  2. I can access the same files on the NAS using Plex as media server on WDTV Live

  3. I can play any file connected to WDTV Live on a local HDD

  4. A full factory reset of the WD TV Live hasn’t solved the issue

Can anyone help? This is driving me mad.

Thanks and Merry Christmas everybody!

EDIT with more information - It looks like I was premature to think Plex was working because tonight I am getting the same problem with Plex too - after about 30s the video stops and I get kicked back out to the library.

Hi, you can try to rollback the firmware and then manually update the firmware and see if that helps. here is the link to explain how to rollback the firmware on the media player.

Thanks for your suggestion - been away so it’s taken me a while to try this. Unfortunately it hasn’t helped. After rollback, factory reset then upgrade followed by factory reset the problem remains. This is a really frustrating issue. Do you think this might be a hardware issue rather than software?

What I realised in all this is that I actually have a Gen 4 not a Gen 3. I originally bought a Gen 3, but it packed up within warranty and when I returned it to WD in November they replaced it with a refurbished Gen 4. I’ve been in touch with them since I realised citing the loss of Netflix as a major issue (I don’t use Netflix but have just been bought a subscription as a gift). Maybe they’ll replace the unit with a Gen 3 which would be my preference anyway.