NAS Problem solved by factory reset but

My WDTV Live 3rd Gen had been updated to when it came out and I quite liked the new iPlayer (though no radio anymore. WD, where is the iPlayer Radio, PLEASE?).

But I could not now play any video files from my NAS. The arrow just went round for ever. So I read here that a Factory Reset might cure this. So I tried it.

When the WDTV had rebooted (do others find that their box seems to boot up twice before it’s ready?) to my horror, I found the old familiar menu system had gone. Where were all the options along the bottom:- “Files, Music, Video, Pictures” etc? All I seemed to have was a screen full of big icons from what used to be “Services”. How could I play my videos and browse my files? Then I noticed Videos and Music was embedded within the other icons for iPlayer, YouTube etc.

The coloured buttons no longer seem to work (eg Red to bring up explore options).

I am mystified why this screen did not change when I updated the firmware when it came out? I much prefer the old menus system. Can I get back to the old one, somehow?

Anyway, I can now play videos from my NAS, but at what cost!

if you’re having theme issues

why not of all places, check the settings menu under appearance and choose the theme you like

1 Like

Well, I never knew that! Had never spotted themes before. When did they appear? Thank you. My box to as it was AND working properly… at the moment.

Thanks again.

there were available when WD original released the box, now going on 2 - 3 years ago

and also the prior device the Live Hub had them as well

Well I solved the issue of the GUI(?). But not the one I thought I had solved by doing a factory reset.

Some of my fles play and others start to play but then grind almost to a halt after about 30 seconds of playing perfectly. The video becomes jerky and the sound disappears. This occurs on my NAS and on my network PC. However, the same files on USB stick plugged into the WDTV play OK. So it seems to be a network issue.

My WDTV is connected to router via TP Link network mains adapters and have had no issue with those before. Indeed iPlayer plays HD content direct from the Internet without a problem. Ironically the files I am trying to play are BBC iPlayer HD programmes downloaded to my PC using Reply Media Catcher (they appear as FLV files).

Of course I can copy these to my memory stick to play them but it would be nice to play them from my NAS which is one reason for installing it.

Perhaps I could convert these files to something more amenable to WDTV Live?

I have wound back to firmware 1.16.14 (via 2.01.86) but the result is the same.

From Media info, I have this file information, below.

Would be extremely grateful for some guidance on this.

Format                                   : Flash Video
File size                                : 387 MiB

Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : Main@L3.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 2 frames
Codec ID                                 : 7
Bit rate mode                            : Constant
Bit rate                                 : 1 404 Kbps
Width                                    : 832 pixels
Height                                   : 468 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Variable
Frame rate                               : 25.000 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.144

Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : 10
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Compression mode                         : Lossy

Well I think I fixed this particular problem by converting files using a template within Replay Media Catcher. The first MP4 format I tried did not work and the videos continued to go jerky and lose sound after about 30 seconds.

With these settings, it is playing all the way through without a hitch, though the files are bigger. I chose this one at random, looking through those with a higher resolution (the originals are “HD”).

“MP4; Playstation 3, XVID 29.97fps, 1280x720:MP3”.

I can now select this setting so that videos are automatically converted once downloaded.


Can you upload this flv file to sendspace? Would like to see this stop after 30 seconds in action when playing from my NAS.

I’ll try and upload it asap.

Having thought I’d solved this problem, today even the converted files stopped playing correctly, displaying the same symptoms as the flv oroginals.

I have reverted to the previous Firmware (,-wd-tv-live)) and now the converted files play OK again.

Given that I have also got radio programmes back on BBC iPlayer I think I will now stick with this firmware version. The flv files still stutter after 30 seconds, though, so I will have to continue to convert my files, as necessary.

I’m confused about this 30 seconds, never seen anything like this.

It may not be as much as 30 seconds. The videos play for a while (let’s say up to 30 seconds) then the video goes jerky and the sound is lost. It looks like a memory thing.

Well, maybe you’ll find the time to upload it…