Plays one file but then needs a restart


I have recently installed my WD live  (excellent piece of kit by the way) - but have an issue when playing a movie from my NAS box.

I can browse the “Media Server” (which is installed on the NAS box) and play a movie - but if I want to play another file (either music, video or photo) I can still browse the media server ok, but select a file to play and the box just sits there with the blue busy circle icon. I can only play the file if I take our the power lead and reset it, just turning it off and on again doesn’t solve the issue.

This doesn’t seem to happen if I use a USB drive though, so I think it’s a networking issue.

Has anyone else had this problem?



Have you tried resetting via the side button using a paperclip. Press for about 1 second and then release with the unit fully booted up.

I haven’t tried that… but I was kind of hoping not to have to restart it at all after every movie!

Doing the side reset may help you permanently.

Unfortunatly that hasn’t helped.