Issue playing files sometimes


#1

Hey guys, I have a strange problem with my WD Live player. Its been less than a year since I bought it (although it says lim war expired).  If I have had it off for a few days and put it on, a file from the same source will play fine. But if I back out of it within a few minutes or after it ends and try to click another file or even the same file I just watched, it gets stuck on the loading screen. Once that happens, I’ve tried to turn it off and try again but still get that loading problem. It happens all the time, and im never really able to use my WD player. Haven’t used it in months, sort of got sick of it because its not consisently working - just sometimes. I did a firmware update a while back also, but I don’t think it has to do with that because this problem sort of always existed but it was just never this bad.

Any advice would be greatly appreciated…


#2

I have had the same problem. When this happens, I found that if I go into the setup menu, go to network settings and select ‘check network connection’, then back out and try to play the file again, it almost always works. There is really no reason why that should fix the problem, but for me it works. Maybe it will work for you too.


#3

Cool, ill try that. Thanks!