Struggling to Set up PR4100 In Any Way At All

Hi All,

Sorry if this is the wrong section. I picked up a used PR4100 today. It came with the original power cord, but 0 drives. Overall it looks to be in great physical shape, though a little dusty on the inside.

When I plug it the power, and ethernet cord the light blinks blue, and then eventually changes to blinking red with the message: Firmware Update Failed

I have tried pressing the reset button, I have tried holding down the reset button (for 30+ seconds) and it doesn’t seem to do anything.

Because I’ve never had one before I don’t have a mycloud account, and I cant seem to sign up for one…without the device being on a solid blue light. Currently I have not put any drives in, but I assume it does not need drives in to set up? I have two WD red 2 tb drives I want to put in it, but would rather leave them sealed until I am sure I am actually keeping the PR4100- which is seeming less likely by the minute, hah.

I logged into my router. The PR4100 shows up, sometimes as online, sometimes as offline (seemingly regardless of whether the PR4100 is actually on or not).

Is there a way to manually update the firmware? Any other suggestions or advice would be greatly appreciated!

Edit: I tried doing a hard reset following these instructions, but it doesn’t seem to register that I’m doing anything at all: How to Reset a My Cloud PR4100 Device

I thought before it just kept timing out, but I decided to try it one more time before responding and it now let me upload a new firmware, and is apparently letting me set it up now! It’s now asking me to insert my drives.

Welcome to the world of the PR4100! It’s one of those if at first you don’t succeed, try, try again. They are super quirky, however once you do get it set up it’s quite reliable. They are what they are, many times you have absolutely what’s going on in it’s little RAM and as you will gather from the forums here and elsewhere no one does. I have tried many home cooked NAS solutions and the PR4100 beats them all out for my needs.