Strange... local access only with WDMyCloud software, not with Finder (Mac OS)

I just set up MyCloud 3TB for use in local network (only). Copied over two folders containing photos in Shared Pictures.

For one computer all is fine, we can access both folders using the Mac Finder. On the other computer, we can access one folder in the Finder no problem. The other folder, however, shows up but it is grayed out, and when you click on it the contents do not appear.

Here’s the weird bit: I can access this folder using the WD My Cloud software.

But I would MUCH rather use the Finder. Does anyone have any tips/ideas?

Thanks!

1 Like

I’m wondering if maybe this has something to do with permissions, even though the folder that works fine seems to have the same permissions.

Both folders show a group called “dialout” with read/write and “everyone” with read only permissions. That “dialout” group seems weird to me.

Still can’t access the one folder via the Finder.

Does anyone know what a grayed out folder means? Any help is much appreciated, thanks.

Do you encounter the same display/permissions issue after manually mapping said share in your Mac using AFP?

2 Likes

Woohoo! Thank you Trancer. I followed the link and did the manual mapping, and now I have access via the Finder. Happy happy.

My steps were slightly different than those listed on the support page, so I’ll write them here in case someone else can be helped with them…

1 In Finder, click Go and point to Connect to Server.

2 Enter smb://wdmycloud and click Connect. (I hadn’t changed the name of the drive so left it as wdmycloud.)

3 Choose the radio button “Connect as Guest”. (“Connect as Registered User” didn’t work for me with any names I tried, so I connected as Guest.)

4 Choose a share on the drive. (I chose the Public share.)

5 Click the “OK” button.

The Public share mounted and I could get to the files in a subfolder of that share. Yeah!

Thanks again. You made my day.

1 Like

If it’s anything like Windows, the user name has to be prefixed with the name of your MyCloud device, so, for the default name:

wdmycloud\user

I’ve never had to prefix the user name with the name of the NAS on Windows.

@P_M, I wonder if your other Mac has signed on to the MyCloud with a user-name and password that’s not defined on the MyCloud, so the NAS logs the second computer in as guest and then when the Mac tries to authenticate as a second user while authenticated as guest, the second attempt to authenticate using correct credentials is rejected by the NAS?

It’s also a common issue with Windows. The GUI gives a generic and mis-leading message. The command line utility actually shows the true reason for authentication failure.

You might be having the same issue.

I’m not unhappy connecting as Guest, since so far we’re only using the share on the local network, and don’t need to restrict access to either computer on that network.

@Myron Thanks for your thoughts on this, I appreciate it. On the other Mac we don’t sign on at all, the shares and folders in them are accessible through the Finder directly. Plus, this grayed out folder happened with the one computer whether or not the other computer has accessed the NAS. And it’s just one folder under the Public share, the other is accessible without manually mapping.

An update… Connect to Server works fine, though it appears that I have to do that for each time I turn on my computer. Afterwards I have access, until I turn it off and then on again. (We turn off computers and routers and modems every day.)
Is this normal? I can live with it, but I’d rather that I had “automatic” access to both folders, and not have to map manually to get into the one that is grayed out.

Thanks again.

Okay, let me clarify that. On my Windows XP SP3 machine, I have to add a ‘computer system’ prefix to the username I use to map the MyCloud to a network drive. If I don’t, it will not connect. I assumed this was because, without the ‘computer system’ prefix, it tried to use a Windows user account name, and there’s no Windows user account name matching my MyCloud user account name.

Later versions of Windows may have tidied this up.

I know what you mean, but I also have an XP SP3 machine and, again, never had to put the NAS’s name, followed by \ and finally followed by user-name. I’ve only used a user-name.

I love consistent behaviour in software…

1 Like