Storage BAD recovering DX4000 with new hard drives

I managed to find from a store two fully compatible Sentinel drives (WD2000F9MZ-76NVPL0 - original from WD) which are identical to the ones pre-installed on our two DX4000 NAS. I wanted to create a new install from scratch but for reasons I cannot understand it fails with error STORAGE BAD.

Sequence I made is the following:

  • Wiped (diskpart clean) the disks
  • Created USB recovery key from DX4000 ISO CD rom
  • Installed two WD2000F9MZ hard drives in the Sentinel
  • Started recovery with USB installed pushing the rear recovery button (confirmed from LCD)

But after one or two minutes from “recovery initializing” I get the message STORAGE BAD. What the hell I am doing wrong?

You need to do the middle step first, recreate I think
When done look at the log file in the wd folder of the thumb drive at the end of it. Make sure it says what you expect, Raid 1, 2 drives etc

Then do the recovery

Hi Gramps, that was correct. thank you - next step is to try with the currently sold enterprise hard drives (SE - differing only for the last number in the MDL) modifying the whitelist files

Only as future reference I add a small bit of information to this old post. I tried to recreate the archive on a WD DX4000 using an USB key created with 1.7.6.21 virtual DVD. The hard drives were the WD4000F9YZ-09N20L1 drives, the 4Tb ones which have been added by WD to 1.7.6.21 in the compatibility lists (as the ones with s/n 0 as last digit instead of 1 were not available anymore - actually also these ones are starting to be rare).

The raid recreate did not work with the USB key in their original state (“recovery invalid config” was shown). I tried to diskpart clean the two hard disks on another machine and I still got the smae error. I managed to create the RAID only after

diskpart clean
converting the drives into GPT drives without formatting.

Also this was done on another machine. Following these steps the RAID was created and then I managed to start and complete the recovery with the second USB key (16Gb) plus virtual DVD

Davide - DTM

Good info
Thanks !

Thank you Gramps, thank you.
I have successfully installed two 4 TB Red NAS and two 4TB WD Blue drives.
The trick as you stated, do RE-CREAT to create the raid and then do the recovery.
Cheersssssss

Another happy camper :slight_smile:

1 Like

Hello, im looking on this forums, i have DX4000 and trying to instal two HDDs ( 2x1TB Blue WD )
but display show " bad drive " i have read this tread, but i dont know where i should " recreate " i dont have system installed on NAS yet… than You for suggestions

Hi,

the blue WD drives are not officially supported by the original DX4000 DVD installation. The only way to start with a fresh install is to modify the allowed list of hard drives both in the DVD file as well as on the USB sticks you will use for re-create and recovery introducing the s/n of the WD blue drives.

Otherwise the only way is to start with allowed drives, once the install is complete install the WD patch which allows you to use “not allowed” drives, and than replace one by one the drives which would be anyway quite long process as you each time the RAID shall be re-created

kind regards

Davide DTM

@Gramps you mentioned in the bootable USB i need to change something? So i followed your advice from scratch when my DX4000 failed 4 years ago… for the life of me i cannot find the thread. BUT i found my original USB i made and it all worked like you wrote out… But now i want to format the drives and blow away all the data and like a dumb ass i did a bad sector scan on a raid 5 and f’d it all up. No biggie i was going to blow that data away regardless. BUT i have all good 3TB drives (4 of them) all with the correct numbers i just think i need to tweak this USB Stick files… just dont know where? Please help… or if i find that thread you wrote up a full disc i will start from scratch creating the iso usb and formatting drives manually…etc. but i think i am close.

You should not have to change anything on either of the 2 thumb drives if your drives are on the whitelist?
Try this link, has some notes as well as a link to the official doc