Sentinel WD DX4000 recovery issue


#1

Hi!

I have a Sentinel DX4000 that had it’s drives removed a while ago. I recently installed two new 3TB WD3000F9YZ drives (they’re supported) into the device. I created my USB recovery drive from the ISO and plugged it in. loaded up recovery by holding the button until it said loading recovery. After Initializing REcovery, it immidiately stops and i get Storage Bad.

The log file on the USB key ends with these lines:

> 2017.01.30 16:47:30 - INFO - RaidCfg64 detected 2 drives
> 2017.01.30 16:47:30 - INFO - RaidCfg64 drive WD-WCC5D0046466: port=3
> 2017.01.30 16:47:30 - INFO - RaidCfg64 drive WD-WMC1F0E4VP4F: port=2
> 2017.01.30 16:47:30 - WARN - No RAID volume detected!
> 2017.01.30 16:47:30 - INFO - Checking RAID status (2): Volume Missing
> 2017.01.30 16:47:31 - ERROR - Volume is not in good state, please re-create it
> 2017.01.30 16:47:32 - INFO - =========== Recovery app END (5) ===========

Is there any different procedure considering I’m starting with fresh drives? At this point I also have the drives initialized. Should i be undoing that to allow the NAS to do it’s own partition table and whatnot?

Earlier in the log, the first few lines also include this error:

Mon 01/30/2017 16:47:23.68 Using platform STARGATE configuration 
2017.01.30 16:47:24 - DEBUG - Reading resource file 'E:\wdrecovery\Locale\en_US.xml'
2017.01.30 16:47:24 - INFO - =========== Recovery app START ===========
2017.01.30 16:47:24 - INFO - Version: 1.7.5.17
2017.01.30 16:47:24 - INFO - Loading configuration
2017.01.30 16:47:24 - DEBUG - Reading recovery configuration 'E:\wdrecovery\recoverycfg.xml'
2017.01.30 16:47:24 - ERROR - Unable to open file E:\wdrecovery\recoverycfg.xml
2017.01.30 16:47:24 - ERROR - Failed to load recovery configuration: 1
2017.01.30 16:47:24 - DEBUG - Parsing whitelist 'E:\wdrecovery\whitelist.xml'
2017.01.30 16:47:24 - DEBUG - Element: 'WhiteList' line 5
2017.01.30 16:47:24 - DEBUG - Element: 'Model' line 7
2017.01.30 16:47:24 - DEBUG - End element 'Model'

Not sure if that would indicate it’s using defaults, or if i need to create a config beforehand.

Thanks you all your help, I had been reading a similar thread over here: https://community.wd.com/t/storage-bad-recovering-dx4000-with-new-hard-drives/146260 but had been unsuccessful from resolving there.

Thanks!


#2

Okay, I tried using “recreate Storage” rather than “Recover storage” to create another USB drive. That would’ve made more sense in the first place. However, again, after booting to the USB drive again, I got a notification that the number of drives was invalid. The recovery.log shows at one point the drives are found, but then the physical drives stop being listed? I’ve attached the whole log below.

> Mon 01/30/2017 17:07:58.05 Using platform STARGATE configuration 
> 2017.01.30 17:07:58 - DEBUG - Reading resource file 'E:\wdrecovery\Locale\en_US.xml'
> 2017.01.30 17:07:58 - INFO - =========== Recovery app START ===========
> 2017.01.30 17:07:58 - INFO - Version: 1.7.5.17
> 2017.01.30 17:07:58 - INFO - Loading configuration
> 2017.01.30 17:07:58 - DEBUG - Reading recovery configuration 'E:\wdrecovery\recoverycfg.xml'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Recovery' line 2
> 2017.01.30 17:07:58 - DEBUG - Element: 'RecreateRaid' line 3
> 2017.01.30 17:07:58 - DEBUG - End element 'Recovery'
> 2017.01.30 17:07:58 - INFO - UnlockDrive: 0
> 2017.01.30 17:07:58 - INFO - PasswordValid: 0
> 2017.01.30 17:07:58 - INFO - RecreateRaid: 1
> 2017.01.30 17:07:58 - INFO - MSRecovery: 0
> 2017.01.30 17:07:58 - INFO - Locale is en_US
> 2017.01.30 17:07:58 - DEBUG - Reading resource file 'E:\wdrecovery\Locale\en_US.xml'
> 2017.01.30 17:07:58 - DEBUG - Parsing whitelist 'E:\wdrecovery\whitelist.xml'
> 2017.01.30 17:07:58 - DEBUG - Element: 'WhiteList' line 5
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 7
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 8
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 9
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 10
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 13
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 14
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 17
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 18
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 19
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 20
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 21
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 22
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 23
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 24
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Model' line 25
> 2017.01.30 17:07:58 - DEBUG - End element 'Model'
> 2017.01.30 17:07:58 - DEBUG - End element 'WhiteList'
> 2017.01.30 17:07:58 - DEBUG - Reading enclosure map 'E:\wdrecovery\encmap.xml'
> 2017.01.30 17:07:58 - DEBUG - Element: 'EnclosureMap' line 7
> 2017.01.30 17:07:58 - DEBUG - Element: 'DriveMap' line 9
> 2017.01.30 17:07:58 - DEBUG - Element: 'DriveMapEntry' line 10
> 2017.01.30 17:07:58 - DEBUG - Element: 'DriveMapEntry' line 11
> 2017.01.30 17:07:58 - DEBUG - Element: 'DriveMapEntry' line 12
> 2017.01.30 17:07:58 - DEBUG - Element: 'DriveMapEntry' line 13
> 2017.01.30 17:07:58 - DEBUG - End element 'DriveMap'
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanThrottle' line 16
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanSpeed' line 17
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanSpeed' line 18
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanSpeed' line 19
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanSpeed' line 20
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanSpeed' line 21
> 2017.01.30 17:07:58 - DEBUG - End element 'FanThrottle'
> 2017.01.30 17:07:58 - DEBUG - Element: 'EthernetPorts' line 24
> 2017.01.30 17:07:58 - DEBUG - Element: 'Port' line 25
> 2017.01.30 17:07:58 - DEBUG - Element: 'Port' line 26
> 2017.01.30 17:07:58 - DEBUG - End element 'EthernetPorts'
> 2017.01.30 17:07:58 - DEBUG - Element: 'TemperatureStatus' line 29
> 2017.01.30 17:07:58 - DEBUG - Element: 'CPUTemp' line 31
> 2017.01.30 17:07:58 - DEBUG - Element: 'DriveTemp' line 32
> 2017.01.30 17:07:58 - DEBUG - End element 'TemperatureStatus'
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanSetting' line 38
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanPWM' line 39
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanPWM' line 40
> 2017.01.30 17:07:58 - DEBUG - Element: 'FanPWM' line 41
> 2017.01.30 17:07:58 - DEBUG - End element 'FanSetting'
> 2017.01.30 17:07:58 - DEBUG - Element: 'Polling' line 44
> 2017.01.30 17:07:58 - DEBUG - Element: 'PowerSupply' line 45
> 2017.01.30 17:07:58 - DEBUG - End element 'Polling'
> 2017.01.30 17:07:58 - DEBUG - Element: 'PowerSupplyMap' line 48
> 2017.01.30 17:07:58 - DEBUG - Element: 'PowerSupply' line 49
> 2017.01.30 17:07:58 - DEBUG - Element: 'PowerSupply' line 50
> 2017.01.30 17:07:58 - DEBUG - End element 'PowerSupplyMap'
> 2017.01.30 17:07:58 - DEBUG - End element 'EnclosureMap'
> 2017.01.30 17:08:06 - INFO - Detected drive 0 serial=WD-WMC1F0E4VP4F model=WDC WD3000F9YZ-09N20L1 SATA=2 led=0
> 2017.01.30 17:08:06 - INFO -   Security: SUPPORTED
> 2017.01.30 17:08:06 - INFO -     Enabled: 0
> 2017.01.30 17:08:06 - INFO -     Locked: 0
> 2017.01.30 17:08:06 - INFO -     Frozen: 0
> 2017.01.30 17:08:06 - INFO -     Master Password Id supported: 1
> 2017.01.30 17:08:06 - INFO -     Master Password Id: 0xFFFE
> 2017.01.30 17:08:06 - INFO -     Master Password Capability: None
> 2017.01.30 17:08:06 - INFO -     Unlock Attempt Counter Exceeded: 0
> 2017.01.30 17:08:06 - INFO -     Enhanced Erase: 1
> 2017.01.30 17:08:06 - INFO -     Erase Time: Normal (raw 168; 20160 sec)
> 2017.01.30 17:08:06 - INFO -     Erase Time: Enhanced (raw 168; 20160 sec)
> 2017.01.30 17:08:06 - INFO - Detected drive 1 serial=WD-WCC5D0046466 model=WDC WD3000F9YZ-09N20L1 SATA=3 led=1
> 2017.01.30 17:08:06 - INFO -   Security: SUPPORTED
> 2017.01.30 17:08:06 - INFO -     Enabled: 0
> 2017.01.30 17:08:06 - INFO -     Locked: 0
> 2017.01.30 17:08:06 - INFO -     Frozen: 0
> 2017.01.30 17:08:06 - INFO -     Master Password Id supported: 1
> 2017.01.30 17:08:06 - INFO -     Master Password Id: 0xFFFE
> 2017.01.30 17:08:06 - INFO -     Master Password Capability: None
> 2017.01.30 17:08:06 - INFO -     Unlock Attempt Counter Exceeded: 0
> 2017.01.30 17:08:06 - INFO -     Enhanced Erase: 1
> 2017.01.30 17:08:06 - INFO -     Erase Time: Normal (raw 162; 19440 sec)
> 2017.01.30 17:08:06 - INFO -     Erase Time: Enhanced (raw 162; 19440 sec)
> 2017.01.30 17:08:06 - INFO - E:\wdrecovery\raidcfg64.exe /i
> 2017.01.30 17:08:06 - INFO - raidcfg64.exe /i Output:
> Version Tables:
> Driver Version: 10.8.0.1003
> OROM   Version: 10.5.5.1050
> App    Version: 10.5.6.1002


>   ********************    Driver Version Check DISABLED    ********************  

> Physical Disks Controlled by RAID S/W
> ================================================================================
>  Disk 01 / 02
>  Disk:        WDC WD3000F9YZ-09N20     SerialNo:WD-WMC1F0E4VP4F 
>  Description:00F9YZ-09N20   	Summary:Pass-thru 
>  Rev:01.01A0  Summary:Pass-thru       
>  FreeBlks:0x15D50A3B0        TotalBlks:0x15D50A3B0       
>  BusId:0x00000002 TargetId:0x00000000 LUN:0x00000000 Array:0xFF
>  Partitions:01 CheckBox:0x00000000 CfgStatus:(00) Ok
>  Action:00 SMARTEvt:0x00000001 WriteCache:ON
>  State:(0x40000458)
>  	USABLE_DISK
> 	DETECTED_DISK
> 	PASSTHRU_DISK
> 	DISK_SMART_EVENT_SUPPORTED
> --------------------------------------------------------------------------------
>  Disk 02 / 02
>  Disk:        WDC WD3000F9YZ-09N20     SerialNo:WD-WCC5D0046466 
>  Description:00F9YZ-09N20   	Summary:Pass-thru 
>  Rev:01.01A0  Summary:Pass-thru       
>  FreeBlks:0x15D50A3B0        TotalBlks:0x15D50A3B0       
>  BusId:0x00000003 TargetId:0x00000000 LUN:0x00000000 Array:0xFF
>  Partitions:01 CheckBox:0x00000000 CfgStatus:(00) Ok
>  Action:00 SMARTEvt:0x00000001 WriteCache:ON
>  State:(0x40000458)
>  	USABLE_DISK
> 	DETECTED_DISK
> 	PASSTHRU_DISK
> 	DISK_SMART_EVENT_SUPPORTED
> --------------------------------------------------------------------------------
>  Total Physical Disks = 2
> ================================================================================

> RAID Volumes
> ================================================================================
>  Total Volumes = 0
> ================================================================================

> RAID Arrays
> ================================================================================
>  Total Arrays = 0
> ================================================================================

> 2017.01.30 17:08:06 - INFO - E:\wdrecovery\raidcfg64.exe /std
> 2017.01.30 17:08:06 - INFO - raidcfg64.exe /std Output:


>   ********************    Driver Version Check DISABLED    ********************  
> ;Port,Model,SerialNumber,FirmwareVersion,Array,Status,Size,Free,Type
> 2,"WDC WD3000F9YZ-09N20","WD-WMC1F0E4VP4F","01.01A0",-1,"Normal",5860533168,5860533168,"Passthrough"
> 3,"WDC WD3000F9YZ-09N20","WD-WCC5D0046466","01.01A0",-1,"Normal",5860533168,5860533168,"Passthrough"

> 2017.01.30 17:08:06 - INFO - RaidCfg64 detected 2 drives
> 2017.01.30 17:08:06 - INFO - RaidCfg64 drive WD-WCC5D0046466: port=3
> 2017.01.30 17:08:06 - INFO - RaidCfg64 drive WD-WMC1F0E4VP4F: port=2
> 2017.01.30 17:08:06 - WARN - Drive 1 serial WD-WCC5D0046466 model WDC WD3000F9YZ-09N20L1 does not match any in white list
> 2017.01.30 17:08:06 - WARN - Powering drive 1964120 off
> 2017.01.30 17:08:06 - WARN - Drive 0 serial WD-WMC1F0E4VP4F model WDC WD3000F9YZ-09N20L1 does not match any in white list
> 2017.01.30 17:08:06 - WARN - Powering drive 1964120 off
> 2017.01.30 17:08:06 - INFO - Detected drive 0 serial=WD-WMC1F0E4VP4F model=WDC WD3000F9YZ-09N20L1 SATA=2 led=0
> 2017.01.30 17:08:06 - INFO -   Security: SUPPORTED
> 2017.01.30 17:08:06 - INFO -     Enabled: 0
> 2017.01.30 17:08:06 - INFO -     Locked: 0
> 2017.01.30 17:08:06 - INFO -     Frozen: 0
> 2017.01.30 17:08:06 - INFO -     Master Password Id supported: 1
> 2017.01.30 17:08:06 - INFO -     Master Password Id: 0xFFFE
> 2017.01.30 17:08:06 - INFO -     Master Password Capability: None
> 2017.01.30 17:08:06 - INFO -     Unlock Attempt Counter Exceeded: 0
> 2017.01.30 17:08:06 - INFO -     Enhanced Erase: 1
> 2017.01.30 17:08:06 - INFO -     Erase Time: Normal (raw 168; 20160 sec)
> 2017.01.30 17:08:06 - INFO -     Erase Time: Enhanced (raw 168; 20160 sec)
> 2017.01.30 17:08:06 - INFO - Detected drive 1 serial=WD-WCC5D0046466 model=WDC WD3000F9YZ-09N20L1 SATA=3 led=1
> 2017.01.30 17:08:06 - INFO -   Security: SUPPORTED
> 2017.01.30 17:08:06 - INFO -     Enabled: 0
> 2017.01.30 17:08:06 - INFO -     Locked: 0
> 2017.01.30 17:08:06 - INFO -     Frozen: 0
> 2017.01.30 17:08:06 - INFO -     Master Password Id supported: 1
> 2017.01.30 17:08:06 - INFO -     Master Password Id: 0xFFFE
> 2017.01.30 17:08:06 - INFO -     Master Password Capability: None
> 2017.01.30 17:08:06 - INFO -     Unlock Attempt Counter Exceeded: 0
> 2017.01.30 17:08:06 - INFO -     Enhanced Erase: 1
> 2017.01.30 17:08:06 - INFO -     Erase Time: Normal (raw 162; 19440 sec)
> 2017.01.30 17:08:06 - INFO -     Erase Time: Enhanced (raw 162; 19440 sec)
> 2017.01.30 17:08:06 - INFO - E:\wdrecovery\raidcfg64.exe /i
> 2017.01.30 17:08:06 - INFO - raidcfg64.exe /i Output:
> Version Tables:
> Driver Version: 10.8.0.1003
> OROM   Version: 10.5.5.1050
> App    Version: 10.5.6.1002


>   ********************    Driver Version Check DISABLED    ********************  

> Physical Disks Controlled by RAID S/W
> ================================================================================
>  Total Physical Disks = 0
> ================================================================================

> RAID Volumes
> ================================================================================
>  Total Volumes = 0
> ================================================================================

> RAID Arrays
> ================================================================================
>  Total Arrays = 0
> ================================================================================

> 2017.01.30 17:08:06 - INFO - E:\wdrecovery\raidcfg64.exe /std
> 2017.01.30 17:08:06 - INFO - raidcfg64.exe /std Output:


>   ********************    Driver Version Check DISABLED    ********************  
> ;Port,Model,SerialNumber,FirmwareVersion,Array,Status,Size,Free,Type

> 2017.01.30 17:08:06 - INFO - RaidCfg64 detected 0 drives
> 2017.01.30 17:08:06 - WARN - No RAID volume detected!
> 2017.01.30 17:08:06 - INFO - Checking RAID status (1): Volume Missing
> 2017.01.30 17:08:07 - INFO - Detected drive 0 serial=WD-WMC1F0E4VP4F model=WDC WD3000F9YZ-09N20L1 SATA=2 led=0
> 2017.01.30 17:08:07 - INFO -   Security: SUPPORTED
> 2017.01.30 17:08:07 - INFO -     Enabled: 0
> 2017.01.30 17:08:07 - INFO -     Locked: 0
> 2017.01.30 17:08:07 - INFO -     Frozen: 0
> 2017.01.30 17:08:07 - INFO -     Master Password Id supported: 1
> 2017.01.30 17:08:07 - INFO -     Master Password Id: 0xFFFE
> 2017.01.30 17:08:07 - INFO -     Master Password Capability: None
> 2017.01.30 17:08:07 - INFO -     Unlock Attempt Counter Exceeded: 0
> 2017.01.30 17:08:07 - INFO -     Enhanced Erase: 1
> 2017.01.30 17:08:07 - INFO -     Erase Time: Normal (raw 168; 20160 sec)
> 2017.01.30 17:08:07 - INFO -     Erase Time: Enhanced (raw 168; 20160 sec)
> 2017.01.30 17:08:07 - INFO - Detected drive 1 serial=WD-WCC5D0046466 model=WDC WD3000F9YZ-09N20L1 SATA=3 led=1
> 2017.01.30 17:08:07 - INFO -   Security: SUPPORTED
> 2017.01.30 17:08:07 - INFO -     Enabled: 0
> 2017.01.30 17:08:07 - INFO -     Locked: 0
> 2017.01.30 17:08:07 - INFO -     Frozen: 0
> 2017.01.30 17:08:07 - INFO -     Master Password Id supported: 1
> 2017.01.30 17:08:07 - INFO -     Master Password Id: 0xFFFE
> 2017.01.30 17:08:07 - INFO -     Master Password Capability: None
> 2017.01.30 17:08:07 - INFO -     Unlock Attempt Counter Exceeded: 0
> 2017.01.30 17:08:07 - INFO -     Enhanced Erase: 1
> 2017.01.30 17:08:07 - INFO -     Erase Time: Normal (raw 162; 19440 sec)
> 2017.01.30 17:08:07 - INFO -     Erase Time: Enhanced (raw 162; 19440 sec)
> 2017.01.30 17:08:07 - INFO - E:\wdrecovery\raidcfg64.exe /i
> 2017.01.30 17:08:07 - INFO - raidcfg64.exe /i Output:
> Version Tables:
> Driver Version: 10.8.0.1003
> OROM   Version: 10.5.5.1050
> App    Version: 10.5.6.1002


>   ********************    Driver Version Check DISABLED    ********************  

> Physical Disks Controlled by RAID S/W
> ================================================================================
>  Total Physical Disks = 0
> ================================================================================

> RAID Volumes
> ================================================================================
>  Total Volumes = 0
> ================================================================================

> RAID Arrays
> ================================================================================
>  Total Arrays = 0
> ================================================================================

> 2017.01.30 17:08:07 - INFO - E:\wdrecovery\raidcfg64.exe /std
> 2017.01.30 17:08:07 - INFO - raidcfg64.exe /std Output:


>   ********************    Driver Version Check DISABLED    ********************  
> ;Port,Model,SerialNumber,FirmwareVersion,Array,Status,Size,Free,Type

> 2017.01.30 17:08:07 - INFO - RaidCfg64 detected 0 drives
> 2017.01.30 17:08:07 - WARN - No RAID volume detected!
> 2017.01.30 17:08:07 - INFO - Checking RAID status (2): Volume Missing
> 2017.01.30 17:08:08 - WARN - RAID volume status is bad or volume is missing, need to re-create the RAID volume: Volume Missing
> 2017.01.30 17:08:09 - INFO - Deleting all RAID volumes
> 2017.01.30 17:08:13 - INFO - Re-creating RAID volume
> 2017.01.30 17:08:13 - ERROR - Invalid number of drives for RAID volume create: 0
> 2017.01.30 17:08:14 - INFO - =========== Recovery app END (4) ===========

After running a second time, I got the “RECOVERY INVALID CONFIG.” But to be fair, there is no recoverycfg.xml in that wdrecovery directory and this is only if I reuse the USB drive without recreating it. If i do recreate it, it ends in “INVALID DRIVE COUNT”.

Thanks again for the help.


#3

Hard to see but there is an asterisk by your drive that says you have to use 1.7.6.21
you are using 1.7.5.17

that is why (I suppose) it says does not match any in the white list and no raid is created

Yes you have to get recreate to work before you can recover and you have to make a new thumb each time you try on recreate. You can reuse the thumb on the next step recover


#4

Thank you for the fast reply, do you know where I can download that firmware?


#5