Static IP not working

I’ve always used a static IP with my MYCLOUD and haven’t had issues until Last week. As stated, last week is when the issue started, before it started I performed a system only factory restore via the Dashboard.

The problem I’m facing is that when I set a Static IP the MyCloud will change to my specified address, subnet, and dns servers. But, after a day or so it will go back into my DCHP adress pool range. It will on the dashboard say its set to a static address but its actually operating under another. 

For instance I am and always have set it my STATIC address to 10.0.0.3 and it keeps reverting to 10.0.0.102. My routers DCHP address range is 10.0.0.100 - 10.0.0.120. I have a Linksys WRT1900AC

I’ve already done a second System only factory reset and it didn’t fix the problem.

Can someone please explain to me what might be going on and how I can fix it?

MyCloud 2TB

Current Version WDMyCloud v04.01.04-422 : Core F/W

Have you told your router that your MyCloud should use a static address?

It certainly looks like it’s negotiated a DHCP address, doesn’t it…?

I’ve never ever had to do that in the past, but yes I tired reserving an address for it and the router only let reserve an address that was in the address pool so I didn’t I have all my servers, nases, etc all in the low 10 and 20’s. The issue started after I did a system only factory restore.

If you SSH into the MY Cloud cd /etc/network.  then type cat interfaces.  This file should look like this. 

Configure Loopback

auto lo
iface lo inet loopback

auto eth0
iface eth0  inet static
  address 192.168.1.218
  netmask 255.255.255.0
  gateway 192.168.1.1
allow-hotplug eth0

Notice it says static and shows the static address.  What does yours show?

RAC

This is the file your talking about: 

CLOUD9:~# cd /etc/network

CLOUD9:/etc/network# cat interfaces

Configure Loopback

auto lo

iface lo inet loopback

auto eth0

iface eth0  inet static

  address 10.0.0.3

  netmask 255.255.224.0

  gateway 10.0.0.1

allow-hotplug eth0

CLOUD9:/etc/network#

That said heres me pinging it:

Agustins-MacBook-Pro:~ aescoto$ ping Cloud9 

ping: cannot resolve Cloud9: Unknown host

Agustins-MacBook-Pro:~ aescoto$ ping 10.0.0.3

PING 10.0.0.3 (10.0.0.3): 56 data bytes

Request timeout for icmp_seq 0

Request timeout for icmp_seq 1

Agustins-MacBook-Pro:~ aescoto$ ping 10.0.0.102

PING 10.0.0.102 (10.0.0.102): 56 data bytes

64 bytes from 10.0.0.102: icmp_seq=0 ttl=64 time=5.157 ms

64 bytes from 10.0.0.102: icmp_seq=1 ttl=64 time=1.235 ms

Heres the arp map:

7 packets transmitted, 0 packets received, 100.0% packet loss

Agustins-MacBook-Pro:~ aescoto$ arp -a

? (10.0.0.1) at REMOVED on en0 ifscope [ethernet]

? (10.0.0.3) at (incomplete) on en0 ifscope [ethernet]

? (10.0.0.4) at REMOVED on en0 ifscope [ethernet]

? (10.0.0.100) at REMOVED on en0 ifscope [ethernet]

? (10.0.0.102) at 0:90:a9:40:22:e3 on en0 ifscope [ethernet]

? (10.0.31.255) at ff:ff:ff:ff:ff:ff on en0 ifscope [ethernet]

? (169.254.8.154) at 0:90:a9:40:22:e3 on en0 [ethernet]  <- This was internesting on top of 10.0.0.102 it also has a 169 address

Agustins-MacBook-Pro:~ aescoto$

And finally I’m going to use the nbtstat -a 10.0.0.102 command to comfim its that Mycloud

Microsoft Windows [Version 6.1.7600]
Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\Users\Test>nbtstat -a 10.0.0.102

Local Area Connection:
Node IpAddress: [10.0.0.115] Scope Id:

NetBIOS Remote Machine Name Table

Name Type Status

CLOUD9 <00> UNIQUE Registered
CLOUD9 <03> UNIQUE Registered
CLOUD9 <20> UNIQUE Registered
…__MSBROWSE__.<01> GROUP Registered
BATTLESTAR <00> GROUP Registered
BATTLESTAR <1D> UNIQUE Registered
BATTLESTAR <1E> GROUP Registered

MAC Address = 00:90:A9:40:22:E3

I can fully accsses the device using 10.0.0.102.  If i redefine the static addres it will move itself to 10.0.0.3 but like a day later sometime even hours later it always reverts back to 10.0.0.102? So what the **bleep** is going on??? I know 169 addresses are only assigned if theres a problem but I’m completely lost. And it all started after that system only factory restore.

I performed the restore becuase I noticed the device was a bit slugsh and rebooting it didn’t work. Its no longer slugsh but now I’m dealing with a very confusing addressing issue.

 Heres a shapshot of the dashboard:

any thoughts? And I tried doing a second system only factory restore to try and make the issue go away but it didn’t. 

I’ll venture that a flag is set wrongly… 

try toggling it to dhcp… reboot the cloud… and let it run as dhcp…

then toggling to static and set it the number, I guess reboot… afterwards

my only guess so far

The next step is to run the ifconfig command.  This is my output.  I noticed your netmask is 255.255.224.0.  Not sure what that would cause.

RAC

AbbottandCostello:/etc/network# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:90:a9:d1:22:4c
          inet addr:192.168.1.218  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::290:a9ff:fed1:224c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:624061 errors:0 dropped:0 overruns:0 frame:0
          TX packets:409859 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:147268294 (140.4 MiB)  TX bytes:113258913 (108.0 MiB)

CLOUD9:~# ifconfig                              

eth0      Link encap:Ethernet  HWaddr 00:90:a9:40:22:e3 

          inet addr:10.0.0.102  Bcast:10.0.31.255  Mask:255.255.224.0

          inet6 addr: fe80::290:a9ff:fe40:22e3/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:32149411 errors:0 dropped:0 overruns:0 frame:0

          TX packets:52004908 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:728295168 (694.5 MiB)  TX bytes:3719671992 (3.4 GiB)

lo        Link encap:Local Loopback 

          inet addr:127.0.0.1  Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:234176 errors:0 dropped:0 overruns:0 frame:0

          TX packets:234176 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:24173801 (23.0 MiB)  TX bytes:24173801 (23.0 MiB)

CLOUD9:~#

My router automatically moved that subnet when I setup to a 10.0.0.0 network. I’ve had this router for about a year but thats been my network scheme for the last 6 years never had issues. MyBookLive never complained, nor has the MyCloud until that restore

From what I’ve see.  If you were to reboot the Cloud.  It should allow you to ping 10.0.0.3 for some period of time.  If not

then something is running after the device sets up the ip address to 10.0.0.3 and changes it to 10.0.0.102.   When the system boots it will use the interface file to set the ip address.  So just after boot it should be set to 10.0.0.3.  At some point later it apears to change to 10.0.0.102. 

I don’t know of a way for an outside device or app to make the Cloud change its IP address.  To me it is being done by

some sript on the Cloud.  I also have the WRT1900AC router.  I have no problem with my IP address.

I won’t be able to respond for a few hours.  I did google why does my static IP address change.  There was some information at this site.  http://www.dyncommunity.com/questions/6438/why-does-my-ip-address-change-when-i-have-a-static.html

RAC

1 Like

Rapheal

The interface file is set to the correct state static.  It also has the correct IP address.  Something is changing it after the Cloud starts the network.

RAC

1 Like

Yeah as far as scripts or tampering are concerned I don’t mess with the Mycloud in that fashion. I upload and download files from and to me established shares. I very rarely ever ssh to it for troubleshooting so it would have to be a built in script or service causing the issue. I might try a full factory restore but was hoping that I wouldn’t have to.

I’ll look into your link and wait till you ger back before doing anything big. Thanks

I included a picture of the dashboard not sure if you seen it, on the dashboard its address is 10.0.0.3, everywhere else its 10.0.0.102

Don’t do a full factory reset.  After loookig at the web site you may find out that its a setting in your router.

RAC

PS a full factory reset is what the support people tell you to do when they don’t have an answer.

1 Like

yeah I know but at this point i don’t have an answer either and have been tackling this for a about a week. But I’ll just wait for your reply later and research in the mean time.

No apparently I’m an ■■■■■, I think this is the problem. It has a reservation on the DCHP server end but I didn’t set it. I’m going to delete it and see what happens

Device Name             
Assign IP 
To: MAC Address     
Galactica
10.0.0.100
REMOVED Edit / Delete
AgustinsMacBookPro
10.0.0.101
REMOVED Edit / Delete
CLOUD9
10.0.0.102
00:90:A9:40:22:E3 Edit / Delete

Manually add device reservation

1 Like

rac8006 wrote:

Rapheal

 

The interface file is set to the correct state static.  It also has the correct IP address.  Something is changing it after the Cloud starts the network.

 

RAC

  1. perhaps the interface says static, but internally your cloud may say otherwise :stuck_out_tongue:

If the internal state says dhcp somewhere, it will then do a dhcp request when it notices that it is suppose to do so thus changing your static ip.

  1. I’ll venture another guess… remember the time when a bunch of folks made changes to the static ip but made it incorrectly thus bricking their cloud. A reset didn’t work… so it might be possible that if anything that is set on your static ip that is dissimilar to the local ip like the netmask, it might revert back to dhcp internally?

So when setting a static, only change the IP

Theagustin wrote:

No apparently I’m an ■■■■■, I think this is the problem. It has a reservation on the DCHP server end but I didn’t set it. I’m going to delete it and see what happens

 

 

Device Name             
Assign IP 
To: MAC Address     
Galactica
10.0.0.100
REMOVED Edit / Delete
AgustinsMacBookPro
10.0.0.101
REMOVED Edit / Delete
CLOUD9
10.0.0.102
00:90:A9:40:22:E3 Edit / Delete

Manually add device reservation

that would have been my 3rd guess :stuck_out_tongue:

Raphael

I just did a test on my system. I set the device to DHCP.  I then looked at the interfaces file.  It now had dhcp in the file with no ip address or submask or gateway.  I then set it back to static.  Now the interface file has static.  It has the ip address that I set.  It had a submask and gateway also in the file. 

So I don’t think that the Cloud was setting his ip address to 10.0.0.102.  I think he found his problem in the router.

RAC

2 Likes

rac8006 wrote:

Raphael

 

I just did a test on my system. I set the device to DHCP.  I then looked at the interfaces file.  It now had dhcp in the file with no ip address or submask or gateway.  I then set it back to static.  Now the interface file has static.  It has the ip address that I set.  It had a submask and gateway also in the file. 

So I don’t think that the Cloud was setting his ip address to 10.0.0.102.  I think he found his problem in the router.

 

RAC

good job rac8006!! yeah has to be his router…  I like my second guess though