Cannot connect to WD MyCloud after change DHCP to Static

I recently change the network configuration from DHCP to Static. The IP was and Subnet Mask was That is the only I configure then I saved it. After that, I can still connect to the cloud but after several hours, I can’t connect to cloud? Is there any other reason why I can’t connect again to the cloud? I still pinging it’s IP address. Thanks for your help guys!

Hi Joshua,

If your current configuration already worked, the issue might be that the DHCP server on your CPE, to which your MyCloud is connected, assigned your static IP ( to another device. (caused by IDLE of the MyCloud or maybe a reset of the CPE itself)

I would recommend to check your CPE’s user interface to get further information if the IP you configured on your MyCloud is already assigned to another device.

PS: this is purely speculative. There is a need for better information of the CPE’s configuration to help you further.

1 Like

So you mean I need to place to another device (ex. PC) right? Then open the MyCloud Web?

No. The problem might be the device your MyCloud is attached to. I assume that your MyCloud is attached to a router (CPE) running DHCP. In your case the IP range which your router (CPE) can use to assign devices would be between and

If the IP you configured on your MyCloud is assigned to another device in your network (PC, Smartphone etc.) it can’t be assigned to your MyCloud because it is already in use.

Like i said before: without further information it will be hard to help. Also I ruled out problems with your router configuration, because you said your MyCloud has been running with static IP. I would recommend to set your MyCloud configuration back to DHCP if you are not familiar with IP adressing and subnetting and if there’s no specific reason why you need a static IP on your MyCloud.

PS: If im allowed to ask; why do you want to use a static adress?

Because the Cloud’s IP always change. The management said that they want to have a permanent IP for the Cloud. I try to connect the LAN cable of the Cloud directly to my PC but still I can’t connect to it

No; once a DHCP IP was assigned to a device, this IP will resist until the DHCP-Server will reboot - and its DHCP cache is cleared. So, as long as you don’t reboot the router (or CPE), no DHCP assignment will change.

Other way round: take a look into your router’s DHCP server and check, if you can assign an IP address to a MAC address; this is called Static Lease. If so, bind the MAC address of your My Cloud to the assigned DHCP-IP. So your My Cloud will always get the same address from the DHCP server.

Or set the Static IP address within the My Cloud network settings OUTSIDE of the DHCP range of your router - but also add the Gateway and the Primary DNS server (in general both are the same IP as the router) into the Static IP settings of your My Cloud. You has to stay OUTSIDE the DHCP range to avoid so called IP address conflicts (which @Oompalumpa tried you to explain).

DHCP requests will be send if a device starts and asks the router for an IP address. In your setup, the router does not know that the IP address .34 is used by your My Cloud as its Static IP because the My Cloud didn’t told this to the router (as normal if using Static IPs). Therefore you have to chose a Static IP which is outside of the DHCP range.

Did you gave the PC another Static IP address (let’s say to enable the PC to talk to the My Cloud on I assume, your PC will jump to APIPA IP as soon as you disconnect the PC from your network as it runs on DHCP IP too.

BTW: playing around with Static IPs without knowning the basics of IP address assignement always ends up like this :sunglasses:


That’s why I’d always suggest leaving the MyCloud set to DHCP, and using the device control page of your router to set an infinite DHCP lease time (‘always use this address’, etc.)

Joerg: You might provide feedback to your manual writers to get them to add explanation to the page on the setup of DHCP/Static IP in the manual; it gives absolutely no clues to a naive user on what to enter, should they elect to set a Static IP.

1 Like

Indeed, you are right. But are we responsible for even explaining the basic basics? I suppose, we should add a line in the manual or better an on-screen-dialogue like “be aware of unwanted behaviour unless you know, what you are doing” :wink:

Last question, Can I configure MyCloud even I didn’t connect to a router? I will connect it directly to the PC to configure? Or can I use the WD MyCloud Desktop / Setup for Windows to configure it when the MyCloud still connected to the PC?

PS: Thank you for saying I’m playing around with static ip’s and naive user (truly does :yum:). Actually it’s not my profession though :stuck_out_tongue_winking_eye:

Hi @Joshua_Merino

of course you can connect any My Cloud direct to your PC but here you have to keep an order of configuration steps.

  1. Connect My Cloud to your normal network with DHCP server to access the My Cloud device normally, via web browser by its hostname; example http://wdmycloud or http://wdmycloudmirror or by its DHCP IP address

  2. configure a Static IP within the My Cloud but use an IP address outside the DHCP server’s range:

Example config if your router has
My Cloud IP:
Subnet Mask
Standard Gateway - needed for the way to the Internet if connected to a switch or router
Primary DNS-Server: - needed for the name resolution for Cloud service and App Center

Save this config and connect the My Cloud direct to your PC

  1. Now you have to set another Static IP for the network port of ypur PC, where the My Cloud is connected to!

Open the properties of your network card, open “Internet Protocol Version 4 (TCP/IPv4)” settings, and switch to “Use the following IP address:”

IP Address: - has to be individual for each device in the network
Subnet Mask:

If you connected to the My Cloud directly but having only this one network interface, you don’t need to fill in Standard Gateway and Preferred DNS server as both are not present. Otherwise it would be the IP of your router.

NOW you can access the My Cloud Dashboard by typing in the IP address - my example above

Be aware that the My Cloud, direct connected to your PC, has no access to the Internet, therefore Cloud and App Center will not work!

You are most welcome! Any FAIL is at least the First Attempt In Learning :smile:
That’s why we are here in the forum!

Hello All,

Thanks for interesting discussion. I get the same issue, after assigning static IP, I cannot reconnect to cloud. (And I also dont have any knowledge about network / IP).

My solution for this case:

  • For instance, the cloud was connected to the main modem A (where the internet went into my house, IP provided as After assigned the static IP (for instance, I cannot connect the cloud after several times restarting computer .
  • I followed the guideline of Joerg above, assigned static IP for computer and reconnect to cloud, then try to change static to DHCP. It seemed not work, even I had tried 2-3 times, the button still in Static Mode.
  • I used another sub access point (called B, IP provided as and connect B to modem A. Then, connect the cloud to B. The IP assigned to the cloud was (for instance,, and the IP was changed from static to DHCP. I can access the cloud again, by Windows + R, then, \\

I cannot explain the mechanism. But you can try.

My problem now is the IP of cloud keeps changing. I mapped them as network drives in the MyComputer window. After several days, I have to map again. Could you pls advise me how to fix IP of the cloud and it would not change after mapping.

Thanks a lot.