Startup problem

#1

When I start up my Elements Play, the WD logo appears, but after that the screen just goes black again and the signal is dropped. What can I do to fix this, or is this a defective unit?

#2

Hello,

Have you tried resetting the media player? Also make sure the unit is connected directly to the wall outlet.

Check the link below

http://wdc.custhelp.com/app/answers/detail/a_id/3646/session/L3RpbWUvMTM2MzQ2NDY5OC9zaWQvX3p4X2lrbGw%3D

#3

Hy there,

first of all scuse my english.

I have a problem with my WD elements play WDBACC0010HBK-00.

I removed the 1tb hdd from the player and reentered it in the player.

Since then it isnt recognized nether the HDMI on the tv.

I tried to reset from the back buton but no change, i put an external hdd thru the player but nothing.

Please give me an advise how can i fix this problem.

Should i reinstal or copy on the players hdd some kind of internel soft? is there an internal memory except the internal hdd that i should reset or somthing like that?

Thanks for your help.

#4

Hy there,

Please do me favor and help me out with the soft from your elements drive.

When you connect it to the pc and the windows recognise it, it is a folder on it named something like “WD” or somthing like that.

Please archive it and send it to me to  to see maybe is working with it.

Thank you in advance.

#5

The firmware is not stored on the disk.  It’s stored in flash memory.

Sounds to me like you damaged the system hardware.