WD Elements Play don't start on TV

Hello dear readers,

I bought for 2 weeks a Western Digital 2 TB Elements Play Multimedia Player.

I transferred videos and pics with my PC to the box.

With a HDMI Cable, I connected it to my HD-LCD TV (Philipps). All was OK, for the next days, I could watch videos (.avi, etc.) and pictures (.jpeg).

But on one time, and I didn’t remember how it happened, the box would’nt start.

No changing of connections to the TV, nothing.

I tried with the remote control but nothing; I tried with the hdmi cable on another player (blu-ray) but the cable worked.

I tried to disconnect and connect it electrically but it changed nothing.

The blue LED ist working (continuously lightenning) but it don’t react.

Pushing the reset button doesn’t help.

I precise that the box is recognized on my PC via USB-Cable.

My videos, pictures and the Backup of my PC appear on the windows explorer.

It seems the autorun.exe doesn’t work.

I d’on’t know what to do.

Please help me!!

Thanks a lot!


Sounds like a faulty box - take it back to the shop.

Hello all,

I have the same problem with exactly same symptoms. The player is not showing any thing on TV, blue light is continuous and it works fine as external HDD on my computer. Can you please tell if there is any fix to this problem?


As suggested, it can be a defective unit.

However, you could try contacting WD’s Technical Support about this either by phone or email in order to get a second opinion.

To Contact WD for Technical Support


unfortunately i have the exactly the same problem. How do you repair it ? 


I dont know but … I have the same problem and I found the solution. Is very simple!

1 - Turn OFF the WD
2 - turn on TV and put the channel in the HDMI number (where the cable is connect to the WD)
3 - turn ON the WD

If I have the WD turn ON and then choose the TV channel HDMI number. It will not work!! The trick is to only turn ON the WD when you are already in the TV HDMI number channel.

I hope this steps will help you.


 i tried these steps but no result.

is the original post creator got the problem solved?

please tell me how?

Hi all…

same problem here… anybody find a solution? 

i work in a country that the shop i bought has to send it 15-20 days to another country to fix it. so i dont want to do that…

Hello all,

I have exactly the same problem here in France. I tried everything I could but I found no solution. I will be bringing back the product in the shop today :frowning:


Has anyone found an answer to this question? Other than returning the unit?

I have the same problem. Only 6 months ago I bought. I think I'll switch to Lacie HD Cinema

Hi from Italy.

Same problem…

Anyone have solved it without take the unit back to the seller?

Hope this isnt too obvious an answer but have you got the WD box connected to your computer/laptop when trying to use it via the TV?

I didn’t realise it won’t show up on the TV when connected via usb to a computer at first.

Hi to all

Pissed off first time using wd elements play media player. Worked for few hours, pressed power off and can’t get it working on T.V since! Can anyone help. Live in Ireland and bought it last week on holiday in England. Continuous blue light can’t seem to put it on standby. Tried it on laptop all looks ok. It took hours and hours to copy files over, my last resort has to be to bring back to shop!!! Help please?? 40 miles to nearest branch!!


I have the same some problem, please help me !!!

I have the same problem and I have bought my WD in France. 

Its works just for some ours.

And the worst is because i leave in Brazil.

Its ridiculous.

I presume you have tried the reset button?

That same problem happen to my EP today! I have it for a few months without any problem but now even that it’s recognized in PC through USB the HDMI or composite connection doesn’t work. It happen just after a search result gave no results in File Management… Tried disconnect, restart without any change.

Reported the problem to WDC but I had no  feedback yet.

Does anyone had this problem and got it solved without a replacement unit?

I have the very same issue!
Anyone tried to replace the storage or call customer support?


Mine wont work on my TV at all! Its a piece of dog turd!!