WD Elements Play 2 TB does not work after accidental switch off with remote during video playback

Hi Everyone,

I bought for the first ( and probably the last ) time a WD product : WD Element Play 2 TB in France to bring it back in my country of expatriation which is China.

one month after purchase, I was watching a video with the device when my toddler son playfully grabbed the remote and pressed the red button thus switching off the whole system.

When i tried to restart everything, i was dismayed to notice that the remote did not control the device any more and that the TV screen remained black without any sound or image.

I’ve tried whatever possibility to restart this ( all kinds of switch on / switch off + reset ) to no avail and today, when I contacted Support in French for the first time ( I am in paris for a vacation ), I was taken charge by pretty incompetent and rather snooty persons who were more interested in ducking for cover rather than trying to solve my problem.

They proposed RMA procedure to change my device but without informing me about the limitations in each RMA formula : I can’t use the Standard one because I first need to get the new device, transfer the content from the old device and then, only then, ship back the old device., all this from the place where i currently live which is China.

As I am still this week in France, the other option was to send me FIRST the new WD and then send back the faulty one but they told me it may take at least 5 working days so I risked leaving Paris before getting my replacement box.

As far as it goes, their “Technical” Support side was abysmal **bleep** and since my problem is not yet listed in the usual Troubleshooting and FAQ columns, I need help from the community to restart my WD box if this is still possible.

Thanks in advance,

I think the fact that it stopped working after being shut down is purely coincidental.  I’ve done that hundreds of times without issue.

Have you tried connecting the drive to your PC (via USB) to see if there might be disk errors that’s preventing it from booting?

Actually, I have also noted that the “storage” function of my WD is still working : I can connect with my PC and open up the HD folder and activate / play files from there with my computer but its the Multimedia software that must have a bug.

maybe I must connect the device to my PC and conduct a “checkdisk” on the WD drive like I would do for any external drive

Try the reset button?  Try hooking it up via Composite video instead of HDMI (or vice versa)?

If you still can access the files from the PC:

  • get a 2 TB harddisk and temp. install in the PC

  • copy all the files from WEP to the new HD

  • take out the HD from the WEP and recyle its remains

  • take both HD to CN

  • in CN: get a new HDD player where the HD can be easily plugged in (see here for an example)

be happy

Thanks for this advice,

Actually I am planning to purchase a 3TB Storage HDD here ( can get it Tax Free if I go outside the EU ) and bring it back to CN. As for the WDEP, I’ll see what I do with it once there.

But one thing is sure : I am not planning to purchase any WD stuff in any case. I’ve got older Korean Multimedia Players ( DVICO ) and they are excellent although too small now ( only 1 TB ) and they don’t play all video files I have.