SSH "connection refused" - My Cloud gen2 (2.31.149)

#1

Hello,
I updated my cloud gen2 to latest firmware 2.31.149, and after that I cannot connect over SSH. The option is enabled, I also tried to change the passowrd many time. On previos firmware the connection working smoothly.

Any idea or hint what to do? Or just return back to previous firmware?

New MyCloud firmware ...and SSH issues?
#2

@RomanC have you tried disable SSH, wait a few minutes and enable SSH?

#3

same, I also restarted box but without success

#4

@RomanC
I just tested

  • My Cloud on 2.30.196
  • Enable SSH
  • Login via Putty and WinSCP = OK
  • Update to 2.31.149
  • Login via Putty and WinSCP = OK
#5

This looks like an issue with the latest firmware in which openSSH was updated.

I reset all settings and had the same issue.

I downgraded the firmware to 2.30.196 and it now works perfectly again, going to sit on this version for a while as I see no advantage in upgrading especially with a bug that makes my drive unusable

#6

I may need to get around to properly refitting the HDD in my Gen2 and then updating it, so that I can diagnose this issue.

My guess is that WD finally decided to replace those broken Diffie Helman based keys with actual EC based keys, and now you need to update your key— but that is a supposition.

Obvious questions:

  1. How are you using SSH to talk to the mycloud? (Native Linux SSH client, Native MacOSX SSH client, PuTTY, “other”, etc.)
  2. If using native SSH, what is the EXACT error message?
#7

We’re enable to reproduce this issue.
QUESTION: what OS and apps are you using to connect to the MC via SSH ?

#8

I used a variety of OS to try and connect and apps.

  • Mac OSX Mojave: Filezilla and terminal
  • Manjaro Linux: filezilla and terminal
  • Windows 10: filezilla and cmd and putty

I am very experienced with SSH both as a server and connecting as a client, the issue is with the firmware, completely blocking it for some reason on some configs, perhaps stuck keys. The downgrade fixed it and I will stay on that version for now.

#9

I just upgraded to 2.31.149. SSH is working on my system using putty.

#10

I have the same issue here. It has nothing to do with the ssh client. I think it’s something wrong with the new firmware.

#11

Just upgraded my other My cloud to 2.31.149. SSH also works on this system.

#12

try… on a mac on terminal

ssh -oHostKeyAlgorithms=+ssh-dss root@.local

replacing with your cloud name of course. mine is mediaserver so I would type

ssh -oHostKeyAlgorithms=+ssh-dss root@mediaserver.local

or optionally

ssh -oHostKeyAlgorithms=+ssh-dss root@192.168.0.xxx <=== ip of your cloud

should work also.

Good Luck…

#13

same issue (192.168.0.1 - PC, 192.168.0.100 - wdmycloud):
192.168.0.1.52119 > 192.168.0.100.22: Flags [S], seq 744887861, win 8192, options [mss 1460,nop,wscale 2,nop,nop,sackOK], length 0
192.168.0.100.22 > 192.168.0.1.52119: Flags [R.], seq 0, ack 744887862, win 0, length 0
192.168.0.1.52119 > 192.168.0.100.22: Flags [S], seq 744887861, win 8192, options [mss 1460,nop,wscale 2,nop,nop,sackOK], length 0
192.168.0.100.22 > 192.168.0.1.52119: Flags [R.], seq 0, ack 1, win 0, length 0
192.168.0.1.52119 > 192.168.0.100.22: Flags [S], seq 744887861, win 8192, options [mss 1460,nop,nop,sackOK], length 0
192.168.0.100.22 > 192.168.0.1.52119: Flags [R.], seq 0, ack 1, win 0, length 0

#14

Hello, I have the same issue (connectivity before update, “connection refused” after 2.31.149 update)… Tried your suggestion it (also) returns exact same message;

ssh: connect to host 192.168.2.222 port 22: Connection refused

any other suggestions?

#15

Hi there.
I have the same problem and reset all settings also and the issue persist. How you did to downgrade to 2.30.196 firmware?
Thanks in advance.

#16

Downgrade directions and past firmware links can be found in the following discussion.

#17

same problem on 2.31.174
I think they don’t care about ssh!!!
BTW I imagine SSH service not start correctly after upgrade.