SOLVED: Unable to use My Cloud with ES File Explorer for Android

Hello guys. I just bought My Cloud and I am having problems using it with ES File Explorer on my Android phone.

In my Dashboard page, I clicked “Shares” and I clicked on my folder that I wanted to view on ES File Explorer and here are the settings I chose. I set “Public” and “Media Serving” to OFF. I am the only user and hence I chose to “Read/Write” tab under the “User Access”. I am able to view the files in the WD App for Android as well as an app called “Total Commander” but not on ES FIle Explorer. I can actually see my folder but when I click it, nothing happens.

Funny thing is if I change “Public” and “Media Serving” to ON, only then I can view files on my ES File Explorer. I am not comfortable to keep “Public” and “Media Serving” to ON because I do not want my family members to view them. I am just wondering is this the way actually ES FIle Explorer works? Or am I missing something here? Any help will be appreciated. Thanks.

I have no problems using ES File Explorer on several Android devices. In my case I have created an entry on the ES File Explorer Network page under LAN. I use a User name and password created via the My Cloud Dashboard (administrator account in my case) rather than leave Anonymous checked.

1 Like

Same settings as in Cheetah Mobile’s File Manager. Connect with user credentials.

Thank you for your reply. What do you mean when you say you have created an entry on the ES File Explorer Network page under LAN? Is there a manual creation you need to do? If yes, please do let me know.

Here’s what I did. I actually went to LAN on ES File Explorer and scanned it and I got my device “My cloud” to pop up. After clicking My CLoud, I get My folder, Public folder etc. When I click on my folder, IT DOES NOT ASK FOR ANY CREDENTIALS LIKE THE PICTURE YOU HAVE SHOWN. I just click my folder and nothing happens really. It just clicks but the folder does not open. I updated my app as well but still the same result. AM I doing something wrong here?

And finally, have you set your “Public” and “Media Serving” to ON when you are viewing your files on ES File Explorer?

Thanks again

After doing the scan, if the My Cloud is found and listed under Search Results, select the My Cloud which should put a check in the box on the right of the name, then select the Pencil icon from the menu bar to Edit the My Cloud entry.

Here are some generic screen shots showing the process of selecting the found scan entry then after clicking the pencil icon the edit Server screen.

1 Like

Thanks for the app name. U know what, I installed the app and behaves exactly the same as ES File Explorer in my case. Lol. That is only when if I set “Public” and “Media Serving” to ON, only then I can view files on this app. Same case with ES File Explorer as well. Which is my primary concern.

Wondering if all ES File Explorer users use this app when their setting is ON for “Public” and “Media Serving” under Dashboard.

In my case it did not ask for User Credentials or anything like that when my “Public” and “Media Serving” was OFF. . :frowning:

In my case it did not ask for User Credentials or anything like that

In CM File Manager, select the Network drive, and press and hold. It will open a menu pop-up. Select ‘Edit’, and then disable ‘Anonymous’ and enter your MyCloud username and password.

Credentials ARE REQUIRED to access a Private share. So you will have to enter them in a file browser, be it CM or ES, (or File Explorer, or Finder). This has nothing to do with Media Serving or Public access. You need to log in the the MyCloud as a User to access the file accessible to that User.

Connecting as ‘Anonymous’ will let you see the contents of the Public folder, and will let you see the Private folders, but will not let you look at their contents.

1 Like

Oh wow :grinning:. Perfect Explanation. Thanks a ton. “LONG PRESS” was the key. Now successfully able to login in ES File Explorer and Cheetah.

Really thanks so much again man :slight_smile:

Generally to select something in Android that doesn’t have a check box it’s a long press.

Yeah. I will keep that in mind. Lol. I feel like an fool for spending hours together for a simple issue. Thanks again Bennor. You have been very helpful :slight_smile: Cheers :slight_smile:

Hi,
I got an android box a few days back n I have the same problem and i did follow your instructions but when i did it usin ES file explorer i was asked to unlock the folder and that can be only done with a premium acc i think, any other methods to make this work.
Thank you

The free version of ES File Explorer will work with a My Cloud to access the Shares. Either run a Scan or select New while on the LAN page in ES File Explorer. Input the Server Name or IP address (I use IP address). Uncheck Anonymous if checked and input a User Name and Password that you have created in the My Cloud Dashboard to access Shares. Then save the changes. So long as your Android device is connected (via WiFi or Ethernet) to the same local network as the My Cloud one should be able to use ES File Explorer to access the My Cloud once properly set up.

Thank you for your response.

The thing is in my cloud home when i go into the directory and pc there is no folder named public but a folder called family which can be shared through the added users, if i am using the tv box ther is a public folder not a family folder, please advice me to find the public folder in the cloud
Regards

Do you have a My Cloud Home or a My Cloud device? They are not the same. The My Cloud Home has different features/options than the single bay My Cloud line (the subject of this subforum) has.

Your “TV box” may be using DLNA to access the My Cloud. If so the folder names and layout might be different, especially if using the My Cloud Home device.

On my Android Phone using ES File Explorer this is how the Shares look when I access a first gen v4.x firmware My Cloud.

How do i transfer files from “my cloud home” private space to public space

No idea as I’ve never used a My Cloud Home device. On the single bay My Cloud one can use Windows File Manager or Mac Finder or file managers like ES File Explorer on Android mobile devices to copy/move files between Shares (public and private) on the My Cloud.

If you have a My Cloud Home, see the dedicated subforum for that device where users more familiar with that device may be able to assist.

https://community.wd.com/c/home-cloud-storage/my-cloud-home

Also see the User Manual for the My Cloud Home for more information on how to use that device.

https://support-en.wd.com/app/products/product-detail/p/1369

The thing is i cannot access the public folder through the WD my cloud app and everytime i want to add somethin to the public folder i jav to get it done through a pc or laptop connected through the same network n thats ridiculous u know, i never had this problem with the WD mybook live
Regards