SOLVED: My Cloud EX2100 Recycle Bin Not Working

Followed these steps to configure Recycle Bin:

Web browser: Log into control panel via:

Shares: Pick a share to add a Recycle Bin to:
Under Share Profile: Active share: Recycle Bin ON.

Now under your Network Places the Recycle Bin should show up.

However, deleted files were not going to the Recycle Bin.

I rebooted the EX2100 and now deleted files show up in the Recycle Bin.

I hope this helps someone else. I could not find an answer anywhere so had to invent my own,


A kudo was clicked for this post.  This topic was brought up in another post and there was no resolution.  Looks like WD neglected to discuss this in the user manual, although now that I know where to look, I see the Recycle Bin is clearly shown in OFF position on the page where it’s control is pictured in the Shares section of manual.

Anyway, I followed your clear steps and now I have a recycle bin  in the Public folder for my DL2100.  I did notice in my tests that when I deleted a file, I was asked if I wanted to permanent delete it (and not if I wanted to place it in the recycle bin), so I did respond with yes, and the file ended up in the recycle bin, where I could again, permanently delete it – for good.  It works a little differently than the Windows recycle bin in this regard.  Thanks for the tip!

1 Like

Thanks for the Kudos. :catvery-happy:

There is another thing to mention. On my computer, deleting files off the share would send the files to the WD recycle bin in THREE ways:

Highlighting the file, hit delete key then confirm

Highlighting the file, right mouse, delete option then confirm

Dragging file to the desktop Recycle Bin then confirm (pleased that this worked!)

I suggest trying all options on your computer to make sure they work the same as for me.

One other thing: I recall reading somewhere that Shift/Delete would permanently delete a file and not send it to the share’s Recycle Bin. Did not get this to work, but could work on your system.

Yes, shift-delet is a Windows command to permanently delete and bypass the recycle bin.  As I mentioned, I do not believe the NAS recycle bin is exactly like the Windows one.  I think it is more of a holding tank (folder) where stuff we want to delete is sent, and from there we can permanently delete.  Nice feature to have so we don’t completely delete something accidently. we have a chance to notice our mistake if need be.

Correct, under Shares (menu option via the GUI), there is an option to turn off/on the “Recycle Bin”. A NAS recycle-bin is a hidden folder on the admin share while the recycle bin W7 recycle-bin of your PC is only for locally connected HDDs (SATA. USB etc). In my case the recycle-bin did not appear until I enabled Network Discovery (Control Panel > Network and Sharing Center > In the left pane, click on the Change advanced sharing settings link).

Sorry to know you still cannot get this solution to work for you.  It is still working for me.  I did reboot the NAS after turning ON the recycle bin in the Shares tab.  It took quite a while for the NAS to complete boot up after saving this change.

Followed the steps and solved my frustration with my EX4. There’s an easy-to-find button to turn it on and an easy-to-find way to clear the recycle bin, but the documentation leaves the details of how to recycle a file as “an exercise for the reader.”

Now that I have the recycle bin working, I haven’t found any way to Restore accidentally deleted files other than dragging them from the Network recycle bin back to the folder they were deleted from (in other words, left or right clicking doesn’t bring up a “Restore” option).