Solution for Formatting WD Smartware Drive

I’m writing this post in the hopes that it will help someone wanting to salvage their WD Smartware Drive. I’ve had a Smartware Drive that hasn’t worked for years because every time I plug it in to a computer it shows up as a CD drive with 600 or so mb of storage. It would not function like an external HD. I tried to format it from within Windows 10 and XP and neither worked. Here is what worked. I don’t know if both of these steps are necessary, but these are the two steps that I took.

First I formatted the drive by booting into the G Parted Live CD. It managed to format the whole drive except for 1mb. When I booted back into Windows the same problem was still there. Windows was seeing it as a CD drive and it was useless.

Next I booted into Linux Mint. I have Linux Mint installed as a dual boot with Windows 10, but you can probably just boot into a Linux Mint Live DVD and get the same functionality. Linux Mint did not see the drive at all, but I opened up the “Disks” utility and it was able to see the drive. Crucially, it was also able to format the drive. Again, I don’t know if my previous actions in G Parted made this possible or not, but in any case, I was able to do it. It’s a 1 TB drive so I had to let it work overnight (about 7 hours). When I woke up the next morning I had a functional 1 TB external HD with no WD Smartware software on it that was usable in both Linux and Windows.

1 Like

Hi,

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/18331