WD MyBook formatted drive and now smartware wont work on it

I formatted the MyBook drive and smartware would not see the drive.  It says there are no writable partitions even though I can copy and paste files manually to the drive itself.  So, I went into disk manager and it has a primary partition.  I then set the partition to active to see if it works and now the smartware sees the drive.  So I tried to setup a backup of one of my internal drives and the software organizes all the files and then does nothing after.  It wont even perform a backup.  Tried to setup backup times and hit backup now and it does not work.  Very frustrating.  Need to get the drive back to where it was so I can use the smartware.  Help please.

Have you tried uninstalling WD Smartware and cleaning the registry?

I have uninstalled and reinstalled several version and they all dont work.  I get get smartware to see the drive now and when i setup everything to backup the drive just sits there and does nothing.  Smartware organizes the files into categories and it stops there.  No backup process start.