Smartware and multiple drives

3 weeks ago I purchased a 3 TB My Cloud and a 4 TB My Book Studio to be a single point bakup system in my home. So far I have been successful in:

  • Using Time Machine on a Mac Book Pro
  • Using SmartWare on a Dell Studio
  • Backing up Linux using Deja Dup on 3 computers
  • Setting up and automatically updating a safepoint on the always connected My Book

What I’ve not been able to accomplish is using Smartware on my HP desktop. I believe due to a non-standard drive and boot configuration:

  • drive 0 Buffalo External HDD SCSI disk device formatted NTFS shared data with Linux
    drive 1 is Intel SSDSA2M160G2HP (150 GB) NTFS Windows loaded
    drive 2 ST31000538AS (1 TB) formatted ext4;  grub loaded here - set to boot 1st from bios

I’ve set Smartware to file type backup on a schedule where MC is inactive. Thus far on 2 different attempts it’s taken 12+ hours on the first and 6+ hours on the second (I had the external drive powered down). I didn’t let either attempt procede to completion because this is WAY TO LONG. I know the slowness isn’t caused by faulty hardwar because this is the exact hardware that Linux resides on and the Deja Dup backup took arounf 1.5 hours. One caveat I performed the Linux backup with My Book as a target:

          Computer >>> My Cloud >>> My Book

Any advice about using smartware in the above configuration? Or possibly using Windows backup?

Hello there, does the Smartware software show progress or does it not backup any data at all?

Thanks for the reply Armak,

There’s progress, but the log file show many errors. there is data in WD SmartWare.swstor /PETE-HP

78,556 Files , 8567 Folders totalling 18,235,622,202 bytes

        used space on my “c:” drive is 102,622,351,360 bytes

There’s a bunch missing. Here’s the beginning of the log for the most recent backup note the errors started 5 sec after the backup started and continued until I stopped smartware 3/24/2015 6:42:38 AM >>> ERROR

  • 3/24/2015 12:30:06 AM >>> INFO     BackupSourceToDestination.PerformIncrementalBackup    \?\Volume{b7f0d64c-7ea0-11e0-9b0c-806e6f6e6963}\ => uuid:73656761-7465-7375-636b-0090a93a2c8b\SmartWare\ KincaidPeters\SmartWare
  • 3/24/2015 12:30:08 AM >>> INFO     RetryErrors    \?\Volume{b7f0d64c-7ea0-11e0-9b0c-806e6f6e6963}\ => uuid:73656761-7465-7375-636b-0090a93a2c8b\SmartWare\ KincaidPeters\SmartWare
  • 3/24/2015 12:30:11 AM >>> ERROR     BackupSourceToDestination.CheckForMissingFiles    System.AggregateException: One or more errors occurred. —> System.IO.FileLoadException: The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

  

This is doing the backup to an external drive on the My Cloud or directly to the My cloud? If it is to an external drive, try to do the backup directly to the My cloud to see if the same thing happens.  

1 Like

Thanks for your reply ArMak!

This is doing the backup to an external drive on the My Cloud or directly to the My cloud?

This was performing the backup to the always connected My Book. I choose this because I was getting errors using My Cloud’s smartware repository. Additionally I think that making backups of backups is a bit redundant.

I’m not certain that other folks will benefit from this solution, but I’m posting the details in any case!

I have solved this by:

  • adjusting bios to disable the linux boot drive
  • used a linux utility to repair MBR on the “c:” drive
  • adjusted bios to choose c drive as primary boot
  • booted directly to windows
  • created an system image using wind 7 backup
  • backup to a firewire drive
  • use smartware to backup to My Book

This is only a troubleshooting solution as I primarily use Linux. I am able to backup my Linux installation to My Book daily by using the built into Linux utility for backup. Since I use Win 7 for tax prep, iPhone, and Photoshop, I’ll have to perform manual steps for my HP Windows 7 backup.

This is somewhat disappointing since I wanted a single point, hands off backup solution for all the devices in my home!  Maybe a future FW update to My Cloud or release of Smartware will address the bios issue outlined. Perhaps, ArMak, you can forward these findings to WD software development fo future enhancements.

I feel that my WD solution will work for me because I’ve been successful with:
    * Dell Studio Laptop both Windows 7 and Linux
    * Mac Book Pro Time Machine
    * HP Desktop Linux
    * Dell Inspiron Laptop Linux