Solid yellow, then red light after failed firmware update, can't access dashboard

So I’ve recently made an attempt to update the firmware on my My Cloud device (Gen 1 4TB) and it failed halfway through. I think this sort of messed up the software as now I’m unable to access the dashboard to even try to do a manual update.

When I turn it off and on again, it goes a solid yellow light for a couple of seconds, then it blinks once, and goes solid yellow for a good minute or two. After a while, it will become solid red and the color never changes.

I’ve tried the 4 second and 40 second restart but it didn’t work. I swapped ethernet cables, didn’t work as well. I tried connecting the ethernet cable to my laptop to find anything useful but still nothing :frowning:.

I couldn’t find any useful information on the forums nor the support section as well so that’s why I’m posting here. Please do help me out :frowning: I’ve got a lot of data which I desperately need to regain access to.

You probably have two choices:

  1. attempt to get the firmware upgrade to complete
  2. recover the data & ‘unbrick’ the device.

You might be able to do 1. if you have SSH access, and can invoke the firmware updater. I can’t remember exactly where it is; searching the forums might find it - ah: scroll down in the first post of this thread:

Recovery of you user data is relatively straightforward, but does involve opening the unit, putting the HDD in a machine running Linux (a LiveCD would do), or running an extfs driver on a PC. e.g.

Unbricking requires a bit more Linux skill, but it’s a pretty well documented process, e.g.

Once you’ve got your data back, and maybe got the MyCloud working again, start doing backups. Any HDD can fail, catastrophically, at any time. A backup regime protects you from that. Despite the name, the MyCloud is simply a NAS, and the basic MyCloud has no data redundancy; if it goes down, and your data is not held independently anywhere else, your data is lost.