Solid Yellow Light on Gen 1 WD My Cloud

Hello world,

I have a problem with my Gen 1 2TB My Cloud drive. It’s broken.

I think what did it was trying to update my Gen 1 device with a firmware version meant for Gen 2 devices only, and so now when I turn the device on all it does is flash yellow, turn solid (yellow), and then the LED turns off completely.

I’m running Mac OS Sierra 10.12.2 on an early-2015 12’’ MacBook and I don’t mind losing the data that might be on the drive. Does anyone know what to do?


It is NOT possible to update an older first generation v4.x My Cloud with the newer second generation v2.x firmware, nor is is possible to update a newer generation 2.x version My Cloud with the older first generation v4.x firmware.

Have you tried performing a 40 second reset?

Hold on, let me try that.

It didn’t work.

Does anyone else have any ideas? Do I send it in for repairs?

try removing the hard disk and hook it up to a desktop and see if the hard disk is still working

if the disk is toast then you need to spend some pesos and get more hard disks

Thanks Vegan. Let me give that a shot.

Did removing the drive and hooking it up to a PC ever solve the problem? I know this is an old thread, but last Saturday I updated the firmware on my Gen 1 2TB, then Sunday we had the breaker trip. I’ve tried both the 4 and 40 second solutions (article 24022) and nothing. The light flashes yellow for a while then shuts off altogether.

I don’t think so. But I used the Disk Utility utility on my Mac to reformat the drive as per another thread and it’s working now.

Did you lose all the data on the drive?

Paul Amador