Flashing Yellow Light. HELP!

I have a 4TB My Cloud NAS that I’ve had for about two years. I use it as a backup disk for Time Machine Backups. Every so often, I was encountering a problem where my or my partner’s Mac would say that the backup disc could not be found. It was easily resolved with a quick reset of the My Cloud. Tonight, I was having the same issue but when I went to reset the drive, I suddenly got a flashing yellow (or orange) light. I tried a 4 second reset and the device didn’t even react. I tried a 40 second reset and the device didn’t react. I tried pulling the plug and powering the drive back up and I’m still getting the same flashing yellow light. I’ve tried different ports on my Arris router as well as different ethernet cords and nothing has changed. On the ethernet port, the link light is on solid and the data light is flashing, which would imply that it’s not an issue with the ethernet port. When I try connecting the drive directly to my laptop, the WD My Cloud software can’t find the device.

Strangely, I hear the drive doing a read-write and it sounds like the exact same read-write over and over again, which would seem to me to mean that the drive itself is dead.

Anybody have any ideas? I really don’t want to have to replace this rather expensive drive as this will be the second WD product that has died on me.

First, do you know which generation of My Cloud you have, 1st generation has firmware 04.xx.xx and 2nd generation has 02.xx.xx. Have you read the User Manual for your My Cloud? See more information by using the link below. Be sure to read about LEDs in the User Manual.

Did you guys get this resolved? I am having the same issue with my My Cloud 2TB. Was working fine but now it will not connect to router. I did find that i can get it to connect to the lan port on my mac and access it that way -as well as go through it’s self test, etc. It was relieving to see that the NIC was still good - since i believed it had failed and i was going to scrap the drive. I have verified and tested the cables and ports on the router and they test good with a laptop, so really perplexed as to how to get this to reconnect to my network. Thinking of connecting it back up to my Mac and giving it a static IP, and then maybe, just maybe it will work. Anyone that has solved this issue, please reply.

As a troubleshooting step try putting a switch between the My Cloud and the router. There is a known issue with the My Cloud and certain routers.

1 Like

Thanks Bennor! Sounds like my issue exactly, so gonna grab one and let you know. MUCH Appreciated!

This was the solution i needed. Back up and running!