Solid white light, no access

I have a 2tb my cloud that has worked fine for some time but now for some reason I have a solid white light and obvioulsy NO access.
Of course the info on this drive is THEE most important data my business has (all my customer files) and as my luck would have it, this happens right when I’m without backup. (last few months I’ve been cleaning things up and was getting another network drive prepared for backups but was too busy to finish it before this happened). I’ve searched and searched the internet and tried MANY things listed…reset on back of unit etc etc. I’m past my warranty period and could care less about the warranty anyway as I just REALLY need the files so i’ve even dismantled the box and hooked up the HD direct to a computer and tried several methods suggested at retrieving the files but I’ve had no luck at all…Still pretty sure they are on there, just cant access them :frowning:
I’m really hoping someone on here has some further suggestions. I’ve gone into the router settings and it does not recognize the drive so it has no IP address for it…however, not sure if it means anything or not but the lights on the BACK of the drive at the Ethernet cable are still blinking as if its still doing something and some kind of data transfer, but the light on the front remains solid white. Grasping at straws but is it at all possible that it is still doing its disk check or whatever even after well over 24 hours untouched and back into the enclosure?
I’ve gone so far as to buy another exact same 2TB my cloud drive as either way I’ll be needing somewhere to save future files to…is there ANY way to access the files on the old one by way of direct hook up to computer (even though I’ve yet to find ANY programs like diskinternals linux reader or ext-fs for windows that can actually see the files…and transfer them to the new my cloud device so that they are now readable again?
This is soooooo frustrating…I’d really appreciate some help :frowning:

Some more detail of what you’ve tried might help.

I’m assuming that, since it’s out of warranty, you have a Gen1 model, running v3 or v4 firmware. Can you remember what firmware it’s running? (the LED status varies with f/w version).

4 second, or 40 second?

Which methods?

What did you find?
Did you see any data structure on the HDD at all?
Did you see any disk partitions?
Did you do something unfortunate like let Windows format the HDD?

If you can’t see any partitions at all, and none of the usual disk access tools (whether running as native Linux, or as driver s/w on Windows) can see the drive, then it sounds rather like the disk is dead.

It’s possible that the flashing white is it doing a very prolonged fsck. Only time will tell if it will recover if that’s the case…

Did you have SSH enabled before it died? You might be able to access the embedded linux via SSH, and have a poke around.

Couple of troubleshooting steps. Perform a 40 second reset via the reset button on the back of the My Cloud. Try putting a switch or hub in between the My Cloud and the router. Use a different Ethernet cable.

Sometimes a disk check can take a long time (hours). So leaving the My Cloud alone for several hours may be enough to let the issue resolve itself.

If the data is important and must be recovered one could remove (violating the My Cloud warrenty) the interal hard drive from the My Cloud enclosure and attach it either by a spare SATA port on their computer or via a USB enclosure/docking station and then use a Linux boot disc or if using Windows install the EXTFS driver from Paragon ( to access the My Cloud hard drive.

Ubuntu is one popular Linux OS that can be burned to a DVD or USB drive and used to boot a computer so one can access the drive once its been removed from the My Cloud enclosure.


Have you been able to resolve this yet?

Thank you for the replies. In my particular case the white light didn’t seem to go away no matter how long I left it alone to do its thing…unless doing its thing should take longer than 24 hours.
So as not to waste your time, let me start by saying I tried everything… Everything that is, within my comfort zone to no avail. Luckily I was able to find a young hot shot computer tech willing to retrieve my data for a very reasonable price and so that’s what I did. I now only have the daunting task of sifting through the recovery results to determine if indeed I have gotten EVERYTHING back or not, and then to organize the files back into folders and sub folders as currently it’s just a jumbled up mess of files…but at least it appears I have my files back.
For purpose of perhaps helping others in this same unfortunate situation…and it appears to be many according to what I’ve read, I’d be happy to reply with more details as to what I did and didn’t do and the results of it all which led to simply turning it over to someone else. I trust you all would let me know if you feel that would be beneficial?
Meanwhile, present situation is this… I now have a brand new my cloud device…again another 2TB and I need to start rebuilding my alphabetical list of folders and sub folders for my customer files. My question to you now is this. My primary purpose for the drive is merely as a local networked drive to access all my customer files, fonts, clip-art, colour pallets etc etc from any of 3 workstations. I never did figure out how to properly set up the ‘cloud’ feature of this drive nor did I know much about the ‘safe point’ backup feature until investigating my recent problems. So, before I go setting this up, is truly LOVE to have some advice and step by step to set this system up more properly this time…willing to help? And if any takers, should it be continued in this thread or a new one?