MY CLOUD Solid White Light

I have WD MY CLOUD 4TB HDD and recently its started showing solid white light and I am not able to access my disk. I have also tried 4 sec and 40 sec reset but there is no activity in white light also left for over 24hrs but no effect on light. Please help.

Found a definitive solution thanks to tidbits of internet advice and a little troubleshooting (no thanks to WD). Let me preface this by saying I practically never write reviews, but felt compelled to given the lack of insight or assistance from WD that I had with this issue, and the gratefulness to individual users on the internet with pieces of the ultimate solution I utilized and to which I can’t give enough credit. Proof that do-it-yourself is possible these days. If you are motivated and/or desperate and/or technologically inclined, this is for you.

Disclaimer: this depends on whether you value your data more vs. the value of your device hardware more. I had data I really wanted back, even at the expense of the device itself if possible so was determined to get my data back. This solution involved taking apart the device to access the HDD (though not destroying or breaking anything!), which voids your warranty and therefore I cannot recommend that you do so. Again, however, I wanted my data and WD was no help.

If there’s one rule of life that this experience underlined, it’s that if you want something done in life, you almost always have to do it yourself. I run into this again and again these days with companies that have no clue how to troubleshoot their own products. There have been a few posts on this topic, without complete analysis of the issue, so my hope is that if this helps even one person recover their data like I did - my job is complete :slight_smile: [apologize for the long post]

  1. Firstly, the background (the problem) - After about 9 months of blissfully enjoying my MyCloud (my plan was always to attach a backup external HDD via USB, but just hadn’t got around to it yet), I came home after a weekend trip to find my My Cloud with a  solid white light  on the front. Inaccessible on the network. Like a brick. I started to regret buying this ethernet-attached drive instead of a USB one that I could hook up directly to my computer…However, I could feel the drive spinning in there, and just generally had a feeling that this WD drive was not a brick (even though their support has been a letdown, I do believe in the quality of WD drives which have served me well over years. This device has a WD Red drive, which are very dependable). So I did all the basic stuff that tech support annoyingly asks if you did, assuming you’re born under a rock:
  • Unplugged the power and plugged it back in, aka “the universal solution to electronics problems” - no dice.
  • Cycled both the modem and router. Clearly not an issue though, everything else on my network working fine
  • Tried connecting directly to the modem instead of the router. No difference
  • Tried a different ethernet cable. No difference. Used that ethernet cable on a different device, was working fine.
  • Tried holding down the reset button on the back for the 4 sec and 40 sec resets, didn’t do anything.
  • Tried unplugging the device, holding down the reset button on the back, and starting it up holding in the button for both 4 and 40 seconds. Again, no difference.
  • Tried connecting the device directly via ethernet - couldn’t recognize on either a mac or PC. BTW, I should mention that although I love my Macbook (better than my HP), this solution required good ol’ Windows. Even in 2015, Macs are still just a toy sometimes, though they have come far since the joke that MacOS was for its entire history until OS X Yosemite came out and let me switch. But I digress…
  • Tried with futility to connect another drive to the USB in back to see if that could be read…no dice.
  1. Called tech support. Asked me if I checked the ethernet cable (sigh…), etc. etc. Explained all the above, they had no clue what was going on and wanted me to send my device in since it was under warranty. If I wanted to try a data recovery place, they gave me a number (the wrong number, of course. Found the right one on Google). People yelling in the background on the phone, couldn’t hear the support person so was happy to end the call at that point. As you may know, data recovery places give you a shot by taking the HDD physically apart, but costs you an arm and a leg (said $500-$2000) and again, I didn’t think the drive was physically broken.

3.  The Takedown  - no insight from WD and data recovery was too pricey (I wanted my data, but didn’t value it at $2k if there was a chance to get it myself) --> time to get that drive out and see if I can access it myself. You can find search for videos online showing how to slide the case off the chasis (without breaking the snappy adaptor things on the inside), and from there it’s pretty easy/self explanatory to unscrew a 3 screws to get the chipset off of the hard drive, and there you go - you have your WD Red HDD. If all else fails with all of this and you have a working drive that just can’t be read, at minimum you can reformat and have a functional hard disk. But here’s to hoping you get your data back.

4. Plan #1 to assess the health and read the disk: bought a Diskless My Cloud EX2 (double-bay empty NAS)

  • Inserted the HDD into one of the bays, sure enough it spun up and the My Cloud EX2 was able to be found on the Network. My thinking was that whatever format it is in, it should be able to be read by another My Cloud. Stated the drive was healthy. So at least my drive is functionally intact, not a brick. Problem was that it showed 0 TB on the disk - bummer. The data apparently couldn’t be read by the EX2, without reformatting (i.e. forfeiting the data that I just KNOW is on there!)

5.  Plan #2: buy another My Cloud and do the same surgery on it to extract its board and chipset. Performing a root cause analysis at this point, because I know WD wouldn’t spend the time to figure out what the actual problem is.

  • Tried attaching the fresh chipset to my HDD and reloading, booting up --> no dice.
  • Tried attaching my old chipset to the new HDD and it booted up --> surprisingly, I thought the problem was something to do with the chipset since I thought the HDD was fine, but it boots up as normal with a new HDD. At least my old chipset was fine, but now what’s the story on the disk that I just found out was healthy in Plan #1 above and clearly spins up without issue??

6.  Plan #3:  buy a USB adapter and directly connect the drive to a computer. Getting warmer…

  • Tried a Mac first (lol) - simply said it can’t recognize drive
  • Tried a PC - recognized all the partitions and noted the drive connected, size of the partitions/data etc. The problem was that it couldn’t read the data and was asking me to format each partition (which would again defeat ther purpose).

7.  The Hail Mary Touchdown:  thoroughly depressed at this point that my data is in there on a working drive, just corrupted by WD’s questionable firmware (that I thought was a nice feature of this whole thing, but guessing it just irreperably corrupted in the middle of a failed update or something). Like a stuffed animal that I can’t pick out of the crane machine arcade game.

  • Went back to the internet for some sleuthing to see if there were any more awesome users out there. I found a mention in some review (PC Mag?) that the device uses an “EXT4” format. I’m sure there are a bunch of Linux users out there (EXT2/3) that are familiar with this, but it’s a My Cloud for god sakes. This thing isn’t some advanced configured device, not rocket science. It’s supposed to be a stupid-easy personal cloud solution. I’m already delving way to far into this consumer plug-n-play unit than it deserves but again…I want that data.
  • Found a (risky) driver that a few reviewers said worked for them in reading EXT4 partitions ( http://superuser.com/questions/37512/how-to-read-ext4-partitions-on-windows)..) I was desperate, so downloaded, launched and…
  • IT WORKED. Copied over everything to my computer and alas, had all my stuff.

So in short, if it is the data above all else you want back - and are willing to forgo your warranty - if you have the patience to extract the drive out of the unit, you can:

  • Find a way to connect the disk to your (preferably windows) computer. ~$20-25
  • Have some software or driver to read EXT4-formatted partitions. I used that driver, but there may be some software (and maybe some for Mac’s) in a more user-friendly wizard that allows for this. When I finally got an email back from WD days later, they noted one called Ontrack ( http://www.krollontrack.com/data-recovery/recovery-software/)) that might work. It says EXT2/3, does not explicitly say “EXT4,” but that might work. Not free though, and the basic version costs 80 bucks. I’d still rather start with that if you wanted a pretty software bundle vs. the predatory data recovery services, however.
  • Transfer things over, and you’re good!

In the meantime I will give the device another try - but only with another external drive attached via USB that will continuously back up the My Cloud that I now do not trust from a firmware standpoint. I will also be turning off the auto-update feature.

I hope that WD addresses the instability in these upgrades, as this seems to have left a lot of people out to dry and fend for ourselves on the forums.

Hope that gives you some kind of chance, even if slim!

3 Likes

Good Evening,

Solid white light means the My Cloud is initializing during the boot up process.

A solid white for a prolonged period of time indicates a file system check may be occuring.

IE: If you could connect a monitor to the My Cloud, you would see the process called “fsck” checking

and repairing the EXT4 file system.  If the unit is powered off, rebooted ora reset it done, the  file system

check will still run when the unit is powered on.

I suggest to let the file system check run without interruption.

Time to completion depends on many factors such as (but not limited to) data amounts and file system structure.

Interesting that you use the term ‘brick’. If you search on these forums for ‘debrick’ or ‘unbrick’, you’ll find a number of guides to dealing with damaged file systems. There are also guides to recovering data using Linux systems, or standalone Linux images running on windows PCs.

Glad to hear you recovered your data; well done!

Hi,
I am having exactly the same problem as you had and I am also willing to dismantle the device and connect it to a PC. But can you please tell me which software you have used to read EXT4? there are couple of them in the link you mentioned and I would like to try the one which worked for you as well?
and one more question, if I boot up my PC with an Ubuntu bootable CD, is it possible to access the partitions directly from Ubuntu? I have no knowledge about Linux OS and Ubuntu and I am bit afraid of messing things up and loosing my data. Please help me.
thanks,
Amir