My Cloud bricked- Solid White Led

Last week, after using WD My Cloud for seven months without any problems, I tried to access the device (blue led, at this particular time) and nothing …
Then I just did the reboot, pulling it from the outlet and putting it back - same with network cable.
Since then, I can not reboot or access the device (stuck in the white light LED).
I followed all great tutorials in this forum, in particular this one:
And though I was able to follow the tutorials, this situation has not changed.
I restored the 2 RAID partitions, using the last two firmwares, and even all 8 partitions, using the disk image of 2TB and 3TB MyCloud.
But no joy: the infamous white light still´s there …
As I live in Brazil, I definitely do not have the possibility of using the RMA.
Someone please have any suggestions?
The HD 3TB of my MyCloud device is working perfectly when plugged into a computer.
Thank you all!

It’s possible the My Cloud is doing an “fdisk” – which can take a LONG TIME  (hours and hours.)

Have you tried leaving it undisturbed for several hours?

Hello Tony,

Thanks for your quick reply!

Yes, I left the device plugged into the power outlet and also on the network for about 18 hours, without disturbing it.

Unfortunately, there was no change …


I am a new user but, have read about everthing about the My Cloud and did some root drive testing and restores.

I am not an expert but, I suggest powering down the Drive for 1 minute and using a paper clip hold the rest button  in. Keep holding the reset button and plug in the power to the My CLoud and continue to hold the reset button for more than 45 seconds (45-60 secs.)

I say this as it help me get my drive back when it failed to properly boot after I installed the most recent firmware xx.230

First try this reset and let us know what the results are ?  Check to see if your My Cloud shows in your network and just not accessable.


Hi YooCloud,

This was the first thing I tried to do.

Then I left my MyCloud on for about 12 hours, but nothing happened.

From there, I tried all the other solutions.

I managed to recover all my data (for which I also had a current backup) mounting data partition (ext4), using Lubuntu.

Thank you for your valuable suggestion, but in my particular case, it did not work.

While the white LED is on take a look at the Dashboard and see what it shows. See if it shows this, see image below.

Posted by,
cat0w (USA)

1 Like

Hi xcobar,

Since you were able to get your data form your My Cloud by mounting the partion that some what rules out data corruption. There are methods to restore the factory image but, it will void your My Cloud warranty because the internal drive must be removed and connected to a computer to image the drive.

Other option if your warranty is still valid you can contact WDC for an RMA to unbrick your drive (or replace it per WDC).

I personally perform a reimage on my drive should I brick it just for the experience as others have done it too. I would only recommend this approach if you fully understand the linux re-imaging process.

Again, drive removal & re-imaging your My CLoud  will void its WDC Warrant.

Here is the thread to re-image your drive:

Here is the image for a 2TB system:  (Note to Modierator - feel free to strip this link if not in line with WDC TOS)!PElwgSyJ!Aicrq1FKKojLVjJgBAz37Sa-9F1KaPeeyMhZ3lN2vpg

I personally have not done a Drive Image Restore as of yet but, I will do one for anyone I meet locally in So. Calif that desires one.

Hey, cat0w!

Thank you for your nice response.
Unfortunately I have no access to the dashboard!


Yoocloud Hi, thanks for the nice offer and suggestion.

Unfortunately, I also had this procedure done (re-image), restoring the images 2TB and 3TB, without any success (except for the files that I could recover the ext4 partition).

I can not do the RMA, considering that  WD does not officially sell MyCloud in Brazil (I bought mine directly in the United States) and shipping costs would not be advantageous for me, almost surpassing the value of the product.

Thanks anyway :slight_smile:

Reply to: xcobar

I thought that looking at the Dashboard would show you what was going on. I captured the image of mine while restarting it after a thunderstorm last week and while the LED was solid white.

I have a shortcut on my desktop for the Dashboard plus I can get to it by using Quick View. See image below for Quick View.


I hope you find a solution and get your My Cloud to work.

Posted by,
cat0w (USA)

Had the same problem with my drive and is now on RMA (warranty).

As I see, your only option is to avoid your warranty to recover your data and restablish manually the NAS drive. Google it and you will find the tutorials.

I don’t know where did you get the idea that WD wouldn’t cover your warranty because they are not selling the product on your country, but I’m living in Mexico and they don’t sell it on here too but they do have authorized repair centers that can receive my drive. You should check more thoroughly about your warranty matter. Unless you don’t have any purchase evidence to support your case.

Any way, you have those two options my friend. Hope you solve ASAP, cuz in my case, the waiting is killing me! :stuck_out_tongue:

I also live in Brazil, bought my WD MyCloud in Canada and after 4 months it bricked, solid white led…

There IS RMA in Brazil, if you registered your WD MyCloud you are able to get it replaced just like I did in less than a week.

good luck