Smartware Upgrade now don't show Cloud device

I may be missing something and have tried 2 days now. It seems before upgrading the Smartware software I was able to see both Mybook and My Cloud along with dropbox. Now all I can get to display is the Dropbox and Mybook. My 4TB Cloud is not showing up.
I used to be able to select the my cloud for my backup now can’t.
Tried mapping the drives even rebooting computer and my cloud.
Any suggestions is appreciated.


Are you able to access the unit manually?

Have you tried resetting the My Cloud? This will help the software and the unit to be discovered on the network.

Yes I was able to connect by network ip address. What I did was reboot the modem and router then it showed in the smartware. Now I am in the process of factory restore because it was so slooooow it seemed and when I first installed it seemed to be much faster to access via network. So just going to restore to factory which is taking forever also and start fresh. I may of did a setting wrong somewhere to make it drag. But to anyone else, rebooting the entire network seemed to make the Cloud display again in the Smartware software.