SmartWare suddenly cant see My Cloud

#1

I am using SmartWare Pro together with a My Cloud hard drive. I have suddenly found out that it has not back up for 6 weeks because my SmartWare program cant see my Cloud. I can though access My Cloud from the dashborard and browser on my laptop, ipad, iphone without any problems. I have also a Mac who uses the My Cloud for backing up through Time Machine. This also works fine.
The only change I have made in my set up is that I have changed my router, but I am quite sure the SmartWare has worked fine after I changed router.
I have tried uninstalling the SmartWare program and reinstalled it. Still, It does not see the external hard drive, and therefore only gives me Dropbox as an back up drive.
What can be wrong?

#2

Hello, check your firewall rules on the computer to see if its being blocked by it. Also, are you connected wireless or wired?

#3

In the Dashboard, >Settings, >Network if SMB is set to SMB2 or SMB3 change it to SMB1. Solved the same issue for me.

#4

Note that the older first generation single bay My Cloud’s using the v4.x firmware do not have that option. Users with the v4.x firmware can change the SMB setting on their PC or they can use SSH and try to change the setting within the v4.x firmware. How to do both are explained in Windows 10 Specific Method 6 in the following post:
https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576