Sharing My cloud across two Lans


need your help regarding port forward settings to be able to access my cloud locally from PC & TV
It sounds easy when reading about port forwarding but tricky for me when trying to apply
The second router is introduced to isolate my home network from my brother’s next door, we need to share only My Cloud

You need to set appropriate routes between the modem-router, and the 2nd router.

Exactly how to do that, is router specific. I need the exact model numbers and makers of both routers.

The Modem-router is Huawei HG532n
This is the routing page:

The 2nd router is “WD MyNet N750” RouterFirmware Version 1.04.16

Disable DHCP and other options on Router#2, connect Router#1 to LAN interface of Router#2. Its allow you to connect all devices in one network.

But if your routers uses different network - you don’t need do anything - All routes already sett in both routers.
But Samba (Windows shares) not work with NAT. FTP and WEB-UI will work.

Does this setup (Access point) will serve my network isolation concern ?
in other words, Will i be able to control access to my network behind router#2 ?

Not really.

If you disable DHCP on Router #2, you effectively have turned that router into a network switch.
All computers will see each other, and everything will be easy-peasy.

BUT. . . if you want to be a network nerd, then you will run a LAN cable from Router #1 into the WAN port of Router #2, and allow DHCP to do it’s thing on Router #2

For the love of sanity - - - use a separate DHCP subnet for the two routers. (it looks like you are planning to do this from your sketch) (I have no earthly idea what happens if you try to use the same IP addresses on the two networks.)

You should be able to access anything on Network 1 from Network 2 by using the correct Network 1 IP address. (I don’t think using a “friendly name” will work. . .use the IP address directly). So if you want to see files. . . type in a file explorer address bar.

I “believe” the visibility is one-way. . . . Network 2 will see Network 1, but computers on Network 2 will be shielded from Network 1. . .which is what I think you are trying to achieve.

If your brother wants his own privacy, he needs to install a Router #3, wired into Router #1. Again, anything on Router #3 will be invisible to users on Router #1 and Router #2.

You really don’t have to worry about port forwarding unless you are access from OUTSIDE of Router #1 (i.e. from a coffee shop down the road). The DHCP addressing from Router #1 should take care of all that.

Words of cautions:
This is not as easy as I make it sound. :slight_smile:
There probably a few other options and settings you need to understand to make it all work in the end. . .but what you are trying to do should be readily doable.

First “gotcha”: My MyCloud device has a setting called “Dashboard Cloud Access”. It is off. With this being off, it will not allow access to the dashboard from a different subnet. In otherwords, the PC trying to access the dashboard of a NAS on Network #1, MUST be Network #1, not Network #2.

Hopefully, the two routers are physically close to each other, to make trouble shooting easier. When playing with this stuff, I take a laptop and jump to different wifi connections to test things. When I have to test connectivity from OUTSIDE the router, I use a phone hotspot to provide the outside-of-network access point

Thanks NAS_user for your effort and time and as you said

this is the first promising answer to my question, I believe its doable but have no clue

I can ping every device on the outer network (, and can open the dashboard for both the first router and MyCloud, but can not open it as a storage or ftb server (did’t try ftb client prog)

i don’t really care about remote access as it slow down MyCloud DLNA Media Server which is its main function in my network

I discovered that some time ago …:grin:
I will keep digging, i feel it is just tricky but applicable

Not familiar with ftb - but if you can get to the dashboard, you are 1/2 way there.
Do you mean FTP? In which case, you probably need to verify port assignments.

Question: you are using it as a media server? Do devices access it properly from network 2?

Step 1: if you put your pc on network 1, does it work right? That’s usually the first skirmish in the battle.

This sounds like a permissions issue when I have done stuff like this in the past, I simply used windows file explorer for file access.

Sorry, yes meant FTP, tried FTP:// from file explorer

Yes, no issue from network#1, just switching my WIFI to network #1 and every thing is fine
From both networks, typing in file explorer will open MyCloud dashboard in internet browser
To open it as NAS, have to type \WDMYCLOUD which only works in network #1
Attempt to do the same from network #2, got that error message
Fox_exe was right:

I could access FTP from both networks via internet browser :rofl::smiley:
i think there is some windows features to configure to allow FTP from file explorer, still working on it
FTP is a big step forward, But still the main function “DLNA Media Server”
Note: May be this is normal, but i can’t ping my 2nd router from the network #1
can you confirm if this is normal router behavior or some thing is wrong

Don’t have much time right now

From file explorer; do double forward slash “\” (basically use IP address instead of the word “mycloud”.). That should open a file explorer window for the my cloud. This assumes you have admin privilidges to the drive.

It worked, thanks man NAS_user
typed " \\"
I appreciate your efforts, but i will leave my next step here for record, you are welcome to help when you have time:
Now the only thing lift is to forward the NAS drive broadcasting packets to inside Network#2 (in selective/controlled way) so that devices like TV can detect the presence of the NAS drive

Glad I could help.

Now. . . for your next step -if I understand correctly- you are trying to get a smart TV on Network #2 to access your NAS drive.

My view: Now you are pushing it :slight_smile:
This is where things become VERY, VERY software dependent.

My wisdom is that fundamentally smart TV’s and such are very dumb. Their behavior will vary not just Model to Model, but will vary based upon software revision levels. Accessing DLNA across different Subnets from a TV? Yeah. . . good luck with that.

Over the last few years, I have concluded that the best way for my TV to access media is through a Chromecast or Roku stick (or something of that ilk). In my house, I have no TV’s. I only have monitors; and ALL these monitors are attached to Home Theater receivers which have cable boxes, or a ROKU stick as input devices. That way, I don’t need to figure out solutions for each TV. . . I only need to have a solution for a ROKU stick. :slight_smile:

My solution for the Roku stick is PLEX. Plex can figure out the network BS, and read data from a remote NAS box. I have “successfully” connected and streamed media from my NAS using plex from different timezones. You should be able to make PLEX work from a different subnet in a GB network. For situations where PLEX doesn’t exactly work. . . .then I punt and plug a computer into the hometheater. I generally have a laptop with me for other reasons. . . .so no big deal. Let’s be honest. . . at some point there is simply no substitute for media server PC.

((full disclosure; while I did get plex to “work”, I found that my ISP was not allowing enough upload bandwidth to allow 1080p streaming. . . I verified that I don’t care what speedtest and the advertising says, I could not reliably transfer at the necessary MB rate to support streaming))

I also had this issue and the solution @NAS_user provided worked great. THANKS!

HOWEVER, from Router 2, I can only access the public folders I have on the NAS. When I try to access a folder which requires login it says my login credentials are wrong. Needless to say, when I connect to the NAS on Router 1 I don’t have access issues.

Any advice? Is there any setting I can change in the admin panel?

I suspect an issue may be with the WIndows Credentials manager. It may be getting confused if you are access the same device from two different network subnets.

@NAS_user you were right. I just needed to add a new Windows Credential Manager with the direct IP and it works perfect. No other setting changes needed in WD admin nor Windows Network settings.

Many thanks for you help.