Shares not showing in WD link and unable to map drive to shares

Hi guys, none of my share links work and I’m unable to map my shares to a drive as none of my shares show up in the WD link tool. This seems to have happened since I moved house and changed Internet Service Providers although I can’t say whether that is really the cause. Please help as it is driving me insane as I can’t access any of my data.

Thanks in advance,


Hi, have you tried connecting the MBL directly to the PC and then use WDlink?

Hi  Alucardx23 thanks for replying.

Please forgive me lack of experience but how do I connect the MBL to the PC. I currently have the MBL connected via a network cable to my router but can’t see where I connect it to my PC that way as the only network connection that is available is the one that connect from my PC to the router.


I tried this and MBL comes up but is the same i.e unable to map to shares. When I attempt to map it comes up with the error path not found etc.

I found a solution.

Upgrade to Windows 7 or 8 and you’ll see all the shares and be able to access them no dramas. I think windows xp is now way past it’s prime.



I have the same exact issue only its with a recently upgraded Windows 8 PC. My Windows 7 laptop and Windows XP desktop access just fine.