Mapping MyBookLive Shares

Since the last firmware update, my computer recognises MyBookLive exists - for example WD Link identifies it - but when I try to map any of the shares shown by Link I always get the message Failed to map drive and when I try using Explorer (Windows 7) I get "Windows cannot access [IP address]\Public (or any other share).

I have tried to reset the drive but nothing seems to happen: the front LED stopped working some time ago but the rear one flashes away and the drive seems to be spinning.

As you can imagine I would really like to at least access the data on the drive, if only to back up to another.

Your help very much appreciated.

If you can see the MBL in Windows Explorer under Networks, right click on it and choose Properties. See what the IP address is shown as.

Also, try "ping"ing it from a command prompt.

Open a command prompt (start, programs, accessories, command prompt) and type “ping mybooklive”, without the “”. If you have changed the name of the MBL then ping whatever the name is you have set.

Have you enabled SSH on the drive?

Post what your results are and hopefully something can be figured out.

Thank you for responding.

My Computer has a red X for MyBookLive where it was formerly mapped but does see it in Network Locations. Right clicking gives no Properties but when I expand I get the different shares, including Public and my own name. Right clicking on these gives Location \MYBOOKLIVE but with zero size.

Pinging MyBookLive resolves to a URL (94.225…) and shows no errors.

In the past I’m pretty sure I enabled SSH becaue I have set it up to work with a Logitech Squeezebox. But trying the same command now gives an error (Web page not available) and if I try to mount any of the shares - that I can see in explorer - I’m asked if I have misspelled the location.

Curiously (or not) the Squeezebox still gets radio and lists my iTunes songs from the MBLbut can’t open the files.

Given that something seems to exist (and the rear LED flashes busily) I’m hopeful I can get the data out without having to go through the ‘unbrick’ routine. But I need more help than I’ve found so far, so I’m grateful for your interest.

Thank you for your interest: I’m willing to try pretty much anything.


Thanks for the detailed response.

Let me make sure this is correct.

  • Some programs can still see the MBL, like SqueezeBox.

  • You can “ping” the MBL with no errors.

Hopefully you have enabled SSH, because that will give us a way into the MBL.

Try downloading a console client, like PuTTY (no install required). When you run it, choose SSH and then put in mybooklive for hostname. This should bring you to the shell, if it is enabled.

User Name: root

Password: welc0me

Chaos. thank you very much for your interest.

I’m away from my computer for two or three days but will reopen this thread when I get back and try the PuTTY - which I know I used when setting up the Squeezebox server.

More in a couple of days.

OK: so far so good: I logged in to mybooklive using ssh and got a prompt after entering username and password.

There were so many strict warnings on launching PuTTY that I didn’t dare experiment further at that point but logout seemed to get me out quickly.

Your guidance on next steps eagerly awaited.

You know, I got excited about ssh and overlooked some common troubleshooting steps.

Perhaps you have tried some of this already, but lets see.

Click Start, then in the search box type


See if that brings up your data.

Can you access the web UI? http://mybooklive

If neither of these work, then SSH into the drive. Don’t worry, we will not make any changes that can effect your data.

From SSH, after login type

  cd /etc/init.d

  ./samba status

Post what status report you get.

Thank you: I had already tried pointing the browser at \mybooklive and got error messages (Google Chrome could not connect to …)

The ssh script changes to /etc/init.d no problem but when (on that prompt) I enter “/samba status” (no quotes)  I get "No such file or directory. dir >list

As an extra, just entering “dir” lists 59 files or directories including at least a couple linked to Logitech mediat server but none resembling any of the share names.

Retrying \mybooklive in the Start box now brings up an explorer window listing the shares but any attempt to click on any of them produces the message “Windows cannot access \MYBOOKLIVE\Publlic” or whichever share I try.

thank you for your patience, I’m still hopeful as the data are obviously there.

Without the quotes enter “./samba status”. It must have the period before the /

Also, just to see if your data is most likely still on the drive, run

df -h

post those results.

I am not the best with Linux, but this problem has me curious. Since you have SSH access I know there is some way to retrieve your data. Perhaps a more Linux savy member will hop on this thread. . . if not, we will still work it out :slight_smile:

Just to let you know what I am thinking.

By hopefully we can restart the samba service, if it has failed, and that will give you access.

If not, then I would like to turn the FTP service on so you can access your files through FTP. The problem is that FTP is not enabled by default… and I am not sure how to do it without accessing the dashboard.

I started playing with mine some, but have not figured it out yet.

Thanks: sorry I didn’t spot theperiod before.

So ./samba status gives

nmbd is running.

smbd is running.

df -h gives a directory listing: I’m trying to work out an easy way of posting it. Yes: there’s a “copy all to clipboard” command

Filesystem            Size  Used Avail Use% Mounted on

/dev/md1              1.9G  943M  883M  52%     /

tmpfs                     50M     0         50M      0%    /lib/init/rw

udev                      10M      6.7M  3.4M    67%   /dev

tmpfs                     50M     0         50M      0%    /dev/shm

tmpfs                     50M     4.1M   46M     9%     /tmp

ramlog-tmpfs       20M    4.0M   16M    20%    /var/log

I hope this is meaningful. Incidentally there should be about 500G used of which more than half is Time Machine backups.

Linux, and all forms of Unix, are way beyond my ken. I used to be able to manipulate a DOS command line before Windows deskilled me!

Hope this leads to inspiration.

P.S. I just had a reply from the WD technical support: they suggest I manually map the drives. I had at least tried that before asking for help! But I did turn off all firewalls and security. It seemed to make no difference whatsoever.

This does not look good.

here is what one of mine says:

MyBookLiveU:/etc# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/md1              1.9G  552M  1.3G  31% /
tmpfs                 5.0M     0  5.0M   0% /lib/init/rw
udev                   10M  6.7M  3.4M  67% /dev
tmpfs                 5.0M     0  5.0M   0% /dev/shm
tmpfs                 100M  4.7M   96M   5% /tmp
ramlog-tmpfs           20M  8.0M   12M  40% /var/log
/dev/sda4             2.8T   56G  2.7T   3% /DataVolume

From mine the bottom line is showing my DataVolume. Yours is not showing anything.

Can you try

 cd /shares


If you see TimeMachine, then:

cd TimeMachine


Note: Commands are case sensitive.

1 Like


Yes I see what you  mean. Entering the commands you suggest gives:

MyBookLive:/usr# cd /shares

MyBookLive:/shares# ls


i.e. there doesn’t seem to be very much in shares. dir on shares gives nothing at all. So my question would be: if somehow my shares, and therefore all my data, have been wiped out, why does the list of shares still come up whenever I try to connect to the drive? That was what was giving me  hope.

Anyway, if you - or any other expert - has any more ideas I’ll certainly try them. Failing that, I can always try to follow the ‘unbricking’ routine to see if I can find some data somewhere.

I hope someone else can help you, because I am out of ideas right now.

If anything else comes to mind I will certainly post it.

Oh, fyi, the ls command is the Linux equiv. of dir in Dos. You can navigate through Linux like Dos, just use / instead of .

OK, thanks very much for your help. I’ll repost my problem in a couple of days, using slightly different words, to see if anyone else offers any ideas.

To sum up: we have access to the drive, through ssh as well as recognised by the network. However, I can’t find the location (directory?) that should give access to the shares and therefore the data. When using WD Link or manual mapping with Explorer the share names are listed but then seem to ‘disappear’  when I try to map to them.

On the positive side, as well as the ssh access, my Squeezebox can still both use the NAS as a radio server and get the time (currently the wrong time) from it. More surprisingly, it can recognise all the iTunes songs listed on the MyBook, though not play them. I checked that these are really listed by pointing the squeezebox at the different set of songs on the PC, thus in principle flushing any cache of the MyBook songs, before returning to the MyBook.

This gives me at least hope that the data may still be there if the file names still are. I expect you’re right that ftp might allow me to get into the drive - I’ll look further.

Thanks again for your help and I’ll hope someone else picks up the baton.

Sounds good. Good luck

Try taking a look at this tread. It looks like you have a similar problem and this guy appears to know what he is talking about. 

1 Like

thanks: I did just that and it seems to be working. 


Thanks again for your help and advice.

Awesome! You are welcome