Share is not accessible/visible

Hi all,

I have the problem that one of my shares became “invisible.” It is not accessible through Windows Explorer anymore, and it does not show up in the web interface anymore.
When I SSH into the MyBookDuo and enter the “shares” folder, the share appears to exist, and the files are still there.

Any thoughts no how to repair this?



Have you tried resetting the unit using the physical button on the back of the unit? If stills the same, try creating a new share with the same name.

I did not dare to reset the unit, so I tried option 2.
First I made a backup, but the I simply re-created a share with the same name…and all my stuff was accessible again.
This is really making me doubt that WD drives are a good place to store your data…


Good to hear your data is there.

I am sorry.
I have the same problem, the folder with my files on my MBLD looks empty.
And I dont understand where i should “recreate a shere”. What does it means?
a) I should delete folder using windows and then create a new folder with the same name?
b) I should go to settings menu of the MBLD and delete there my share folder and then create with the same name?