[HELP] Not Able to Map Shares on Win7 Although it's being seeing

Hi,

I have a My Book World Edition II which is not letting me map the drives manually on Win7 x64 or even use the WD Link tool.

Someone Knows how to solve it?

By trying everything I lost ALL my data on the DriveĀ :cry: which I could not recover as it was on RAID 0 (Striped).

Now I have restored it back to Factory set, configured all again, but nothingā€¦ I can see it through FTP, but not by trying to map itā€¦Ā 

If i put on run \NASNAME\ or \IP\ I cannot reach the folders even with admin rights.

Thanks,

Did you make sure the MBW is on the same workgroup name of your computer? ANd have you tried accessing the MBW from another computer to check if your computer is refusing access?

Have you tried to PING it on command prompt to double check the correct IP address?

Hi ThePizzaMatrix,

1-About the workgroup, yes, just set the name of my homegroup which was confirmed by the webconfig of MBW that it was joined successfully.

2-About the PING, yes, when I PING it it responds perfectly. As I said, I can access to the webconfig, also can access through FTP protocol to the folders, but not able to map the drives as common share folders which some time ago it was working without problems.

3-About seeing it on another computer like common shared folder, I have checked it right now, and yes, I see themā€¦

Any other idea?

Thanks!