Can't map drives from some machines Windows 7

Hi all,

New to the forum and to Western Digital products…  I’m having a problem that hopefully someone can help me with.  I bought the WD My Book Live 2TB drive and connected it to my Network.  I can access the drive fine from my laptop, I cna map to specific shares and it’s working exactly as I expect it to.

However, when I go onto either of the other two machines in the house to map the drives it gives an error message that it couldn’t find computer called Mybooklive…  When I go into map network drive and browse to the network I don’t see the drive there at all.  But if I put in the IP address (eg \  it connects fine and lets me map the drive.

Anyone have any ideas of what’s going on?  because the drive and router don’t use static IP addresses, if the address changes then the drives will be dropped.

All 3 machines are laptops, all running Windows 7 and accessing the router wirelessly.  As far as I know they’re all in the same workgroup as well.  I spent hours trying to sort this out last ngiht and I’m really hoping someone can help out.

I tried installing the software that came with drive but that didn’t help and I didn’t need to install anything on my laptop (the one that can access everything fine), so don’t think it’s a software issue.

Hope someone can help.



It sounds like some PCs aren’t working with NetBIOS name resolution.

If you open a CMD window, enter the command

net view

it should list all the servers in your workgroup.   If it does not, then there’s something wrong.

You are not probably on the same workgroup. Check the manual for other options beside using the software that comes with it.

But in a nutshell, try to ping it by IP. If that works, you should be able to go to the computer browser (Not internet browser) and/or run command and type:


\ is NOT the same as http://

1 Like

When I tried net view two nights ago it gave me an error message, I went home last night, booted up one of the laptops that couldn’t connect typed in net view and it worked, dsiplated everything it should have.  I then tried to map the network drive and it worked fine!

Not sure what happened to fix it.  But everything’s now working great.

Thanks for you help guys.



I have a similar problem in that my laptop works and shows MBL as a computor giving me access to all the files via My Comp’. Just as I expected it to.

When I tried net view on my PC it just lists the name of the PC.  When I do it on the (vista) laptop it lists the laptop and MBL.

When i run the command on the laptop it lists the laptop and MBL.  Both lt and pc are on the workgroup “WORKGROUP”.

When I run either  \MyBookLive or \ via the command via start menu an error comes back saying Windows Cannot Acess . . . 

The MBL is visable when I view network map via Network and Sharing however lists the MBL as Storage where as on the LT it is shown as a computr.

Please help


I have the same problem, but noone helped so far…

If you find the solution, please let me know!