Problems mapping network drive

I have been struggling wih this for several days, brief recap, I have 4 “my book live” drives and 1 WD tv live hub, they were all mapped as drives on my windows 7 pro computer and working fine, I was having a problem wih my connection to the internet randomly dropping and reconnecting,  and uninstalled the drivers and reinstalled the network device. some time after I noticed that I could no longer connect to my network drives. the drives no longer appeared under network in explorer, but were listed when I went to network and sharing center and clicked on “see full map”.  WD Quick view also showed the drives and status but when I selected map public share, a window poped open with as a example “\tvshows\public” but when i clicked next it asked for a user and password, none worked, nor did anonamous. I also tried “WD Discovery” which showed the drives but all options were greyed out except for “configure” and “creat desktop shortcut”, I could connect via a browser window using the ip address and I could connect via the site which showed all my drives online and no problems indicated. I connected a laptop to my switch and all drives appeard as normal and were mappable. After searching for days through the forums and having tried every suggesting and checked secruity settings. nothing had worked.

  Finely on a hunch I went into the advanced sharrering options and turned off all the things that were supposed to be on like “network discovery”. after saving I went back in and turned them back on and saved again, then rebooted. upon reboot the drives were all there and mappable once more.  obviously the settings there had not been reflected in the regestry and something was off that was clearly indicated as on. 

  So for now my prolem is solved but thought I’d post incase it can help someone eles.

Great information.

Thanks kirk276