Shared Links Not Opening on iOS devices

Hi there, hopefully someone can help me out a bit here as this has been driving me a bit mad the last days…

It used to be so simple… Log into, select a folder to share, type in some email addresses and boom, grannies, grandads, aunts and friends could look at the contents of the folder.

Latest folder share as usual, however, everyone that was using an iOS device was unable to view the photos in the folder clicking on the link - strangely anyone using a desktop and MacOS was able to see the photos…

Receivers of the link are being directed sign on pages, although previously this shouldn’t have been required as the link authorises it. I have always used the web page to share files as the app never creates a link for me, just get a WDGeneralNetworkError error 500 - has always been the case and always worked through the web application…

This seems to have been a change post firmware 2.30.196 as far as I can tell - has anyone else had this issue?

I have tried system only restoring the My Cloud through the dashboard and also restarted the router (and my laptop).

Look forward to any help the community may be able to offer!

This sounds like network DNS issue with at the share location.
I just tested and have no issue openeing the shared link through the email client of iPhone 8 +.
My Cloud PR2100 is on FW 2.31.149

Have the owner of the mobil device disable WiFI and check the link while on the carrier network

Hi, thanks for the reply. I have checked (myself) on the link on an iPhone on carrier - still asking to log in. Interested in the thoughts on the DNS - after resetting the system I’d have thought that would have cleared that up… I’m not super network knowledgeable (hence why I picked the My Cloud for ease of use ;-)) what should I be looking at here? Is it recommended to set up a static DNS to ease sharing?