Server 2016 Essentials on DS5100

#1

I’ve been working on getting Windows Server 2016 Essentials on my DS5100 systems. We had a purchasing error, and I ended up with 4 - DS5100.

I created a FAT32 8GB USB drive using diskpart, and made it active. Then copied the files from the Server 2016 Essentials iso file to it. I also copied to it GRAMPS Marvel driver, the Aspeed graphics driver, and the WD OEM Tweaks file from GRAMPS.

I boot from the USB drive, begin the server 2016 Essentials load, and have to load the Marvel driver so it can see my 240GB SSD boot drive. Loads fine, I go through the configuration to set domain name, hostname, etc.
I copy a directory from the USB I call DS5100 that has a couple of apps I like (notepad++ for editing, ccleaner, 7zip, and chrome browser) I copy the WD directory from WD OEM TWEAKS to C:. I also have a modified DriveList.xml file that includes my SSD drive and an entry for the 5TB Black drives.
After the reboots, I run (as administrator), or from elevated cmd window,
C:\WD\run_logged_install.bat, C:\WD\WdLcdSetup_PreInstall.bat, then WdInstall.bat.

I have found that after that reboot, the LCD is working, but the DriveList isn’t being used. Although the Dashboard now has the WD things added to it, and it shows software version 2.2.2.10.18, everything isn’t all there. There are several file differences between the WD OEM TWEAKS and the WD zip file. (DriveList.msi being one of them). So I load the manual software update and point it to the Sentinel_firmware_2_2_10_18.zip file. After this update the DriveList.xml path has been added to the registry. I had to run the LCD setup bat file, and the msi file to get that working again. Also had to run the WdStorageSetup.msi to get the DriveList working. Copied in my modified DriveList.xml to C:\Program Files\Western Digital\Western Digital Drive List\DriveList.xml. The I got Green instead of Red for the drives in the Dashboard.

I installed the Windows Updates from Microsoft. Plugged in my 5TB drives. Still am not sure about how Storage Spaces calculates space, but I end up with 12TB for my 4 - 5TB drives. Also trying RAID 5 on another system, but the initialization is taking FOREVER!

Thus far everything is looking good! LCD working, Modified DriveList.xml is working. Still need to try connecting Windows 10 and 7 clients to it.

With Server 2012 R2 installed on 1 boot drive, if I install the “B” OS drive it will create the mirror automatically. On 2016 I can’t seem to get it to mirror the drives. In WD Raid Storage Utility it shows both drives. I tried creating the Raid manually. I can select the drives, and specify RAID 1. But then it gives an error, that one drive is the OS drive and is in use. Any ideas on that one?

#2

Can you get into a raid bios on boot? CTRL i or maybe ctrl M?
May have to create the array before you load the OS.
That said do you see a migrate option instead of create raid

I am not sure how the did the auto maybe a cfg file somewhere?

#3

I can’t seem to find anything that allows creating the boot drive mirror. Ctrl I, or Ctrl M don’t do anything. (I’ve done lots of RIAD installs and am very familiar with these tools)

Bios doesn’t even recognize any disks are connected. It lists all 6 SATA ports, and allows defining the 2 boot disks as SSD or hard drive, but does not show any disks connected. (All bays are full) There are settings to enable RAID 0, 1, 5, 10. All are enabled by default.

Not sure how WD takes over just after the bios. It does display Loading UEFI HDD on the display. Must be some other hot key to access the RAID bios.

#4

Did you ever find a solution to this? I’m wondering if I need to change the SATA setting in the BIOS from AHCI to RAID?

I’m in the same boat - can’t seem to get into the RAID tool from BIOS. But I can’t even get the utility within Windows to create a RAID - it just jumps to the Storage Management section and doesn’t do anything else.

#5

@biohead Can you post a screenshot of what you are clicking to go to storage management?

The DX42000 had an option for RAID or Storage Spaces but not the DS5100. Once selected there was no way to change without a reload.

#6

@Gramps It might not have been clear in my first post, but I was specifically referring to the boot drive mirror. Essentials Dashboard let me choose either RAID or Storage Spaces for the 4 main “storage” bays and the WD utility will show all 4 bays and allow me to make a RAID (albeit not on the boot drives as the OS is currently running. I’ve already configured my storage bays to use Storage Spaces and not RAID, but it was an option before I configured it so.

Screenshots of the Essentials Dashboard and the RAID Utility here: http://imgur.com/a/4hcOJ

Like GWS, I can go into the BIOS and I can see all the SATA ports, but it lists them as empty (all but 1 are full). It appears I don’t have the option of loading the Marvell orom prior to the OS loading. I’m never prompted on the BIOS screen. I have tried Ctrl+M which doesn’t seem to work. I’ve even tried putting a Marvell EFI utility on a USB stick (ui64 - I think it’s designed for 92xx chipsets) which wouldn’t find any hardware.

It’s making me think whether the 5100 ever could use an OS drive RAID1 mirror or if only the 6100 had that capability.

#7

Were you ever able to get the RAID1 issue for the boot drives resolved?

I just took my DS6100 and did a bare metal install of WSE2016. I’ve hobbled my way through it, but I have run into the lack of RAID1 boot drives and a couple of other small issues.

On a related note, I purchased a pair of 500GB Samsung 860 EVO SSDs as the boot drives. One shows up in the dashboard (the other says not present), and it is listed as an incompatible drive. I was going to edit the drivelist.xml file, but what string do I put in the drivelist? I tried Samsung SSD 860 EVO 500GB as listed in the dashboard, but it didn’t fix it. Is there a specific place I should look to cut/paste the drive “model” into the drivelist.xml file?

Thanks for all your help – once I get this figured out, I will post up my experience from beginning to end. Special thanks in advance to Gramps, without whom this would not have been possible…

Ivan

#8

No clue on the raid. It would probably have to be created from Bios before you load windows, that said it was supposed to happen automagicaly if you added a drive later. Perhaps they were built with a broken raid??

Again, no clue but you might load crstaldiskinfo and try the description of the drive there in the whitelist

#9

I guess broken RAID is a good a description as any – I think that we are missing some important information about how to configure the RAID1 before installing the OS.

Now I understand that the main body of the DS6100 that holds the four drives is a backplane run by the Marvel 94xx RAID chipset, as those drivers were provided for in the past. But what RAID chipset governs the two boot drives? Is it the same Marvel chipset or is there another one (perhaps only accessible from the BIOS)? And if so, what is the keystroke combo to access the RAID configuration utility (or is that from the BIOS as well, in which case, which menu item does it fall under)?

Crystaldisk: That’s a great idea! I will try that.

#10

I do not know about the raid. My box has been sick for years, says BIOS degraded. They said it should fix itself on reboots but never does. If I get a chance I will put it on the bench and look at it

#11

I did eventually get RAID1 on the boot drives but it wasn’t quite as straight forward as I’d hoped. It’s not difficult, just rather time consuming. I never got the automatic creating feature working.

The same backplane hosts the boot drives as the data drive - it’s the same controller. I have never been able to get into the BIOS utility, even after specifically trying to load various Marvell EFI OROMS for other Marvell controllers. It makes me think the 94xx doesn’t have such a feature available, and it’s limited to 92xx or 93xx controllers.

What I did was create a Windows-To-Go installation of Server 2012 on a USB3 connected SSD. (You could use any old HDD or flash drive, but it will be much slower).
I booted the clean install from the WTG drive and installed what I could of the WD drivers. It will prompt you to go through the Essentials setup - but it won’t be able to complete. You can just leave this in the background as it doesn’t affect what you need to do.
Once you have the WD parts installed, you should be able to open the Marvell RAID utility and configure the boot drive RAID from there. Shut down your WTG instance, connect your installer and when you get to the drive selection you should see your new RAID1 array.

Coincidentally, I started having issues with the WD-specific version of the RAID utility in that it wouldn’t show me the option to create a new RAID array. In the end I had to find another version of the Marvell utility and drivers and install that on my WTG instance - that worked out fine for me.

My DS5100 (upgraded to 6100 internals) has been happily running ever since with a RAID1 boot drive - although on 2012R2 as I had issues with the fan speeds on 2016 and the TimeMachine support package doesn’t run on 2016 which I do use.

#12

Mercy :slight_smile:

#13

So then, if I’m understanding there is a single Marvell 94xx that controls all six bays (the two controlling the boot drive(s) and the four that comprise the backplane) and that we cannot access a RAID configuration utility as part of the regular BIOS startup (say like hitting f2, Ctrl-M or something easy like that).

So to get around that, we need to create effectively two installations(?) of Windows Server (insert flavor of choice here), one in which we install server, run the Marvell RAID utility under windows to create the RAID1, then back out and install again? I got lost on the second install…

:thinking:

As an aside – in BIOS is it absolutely necessary to set to RAID, or is AHCI preferred?

#14

There may be a way to get to a Marvell prompt prior to loading any OS through means of the BIOS - but so far I have not found out a method to do so.

Correct in that you need two installations of Windows. The key point from this is the first one MUST be a Windows to Go installation (i.e. NOT using a SATA port - it uses USB3). You cannot create a RAID using the Marvell config tool for your current active boot drive.
The USB3 Windows-to-Go installation gets around this issue as the SATA boot drives will not be in use at this time.

The second installation is your normal Windows Server install - hopefully now on a RAID array.

I keep my BIOS setting set to AHCI, not RAID.

#15

Nuts – it would be so much easier if we could just get to a Marvell prompt like most other on-board RAID controllers.

That being said – is there a “how-to” on how to use the WTG and also one for the Marvell config tool (I think I vaguely remember doing a WTG awhile back for a friend’s computer, but I’d appreciate more info on both).

Thanks again – this has been very informative (if not a bit disappointing?), but I think I’m close!
MM

#16

There’s not really that much to say about WTG - it’s a Windows install on a portable device (typically a USB flash drive). There are some quirks to it - but we’re not going to be using it for much longer than an hour.

There’s a piece of software available called Rufus which is a disk formatting tool. It also has the capability to create a WTG directly onto a drive using a Windows Install image (and a large enough flash drive).
From there you just have to boot into it and install the WD components (drivers and RAID utility).
Open the WD RAID utility and it’s fairly straight forward how to create a RAID array, As ever - make sure any data disks as disconnected whilst doing this to ensure no mistakes are made.

#17

@biohead how did you get the raid utility installed?

#18

It’s included in the WD driver pack that was so kindly put together by @Gramps. Just follow that installation process and it’ll be there.

#19

Could you kindly point me to it?

When I upgraded 2012 with 2016, everything slowed to a crawl and I’m getting the same results when I did a fresh install. Do you think following this (your steps above?) process will speed things up? I’m really concerned I screwed something up permanently. Even though things run, my virtual machines are so slow it’s unusable.

#20

Check your thermals - I had huge issues with 2016 getting the fans to react and the CPU would throttle like crazy.
I never found a final solution for it - some times it would work, sometimes it wouldn’t. Clean install or Upgrade had the same issues.

The driver pack can be found in Post 3 of this thread: DS6100 Upgrade Windows (Clean Install), Increase RAM & 3rd Ethernet Port