DS5100 not seeing boot drive after Marvell drivers added

Dear Experts

I came across a related thread but was hoping for a quick answer as we are severely affected. I have a client with the failed DS5100. The driver Gramps referenced (Marvell Raid) worked perfectly for me using a Hitachi / Travelstar as my new boot drive. Unfortunately for me, I went a step further after the O/S was installed and I tried to install a firmware update (sentinel_firmware_2_2_10_18.zip). I thought it was going to add some functionality back after a generic install from USB. I was very wrong and now I am unable to boot the server O/S. I am still able to boot from USB and access BIOS.

After trying unsuccessfully to recover I decided to just reinstall the entire O/S. However now the Marvell drivers are seen as incompatible and I cannot see the drive to install the O/S again.
I contacted support and it is of course out of warranty and they cannot send me a boot drive. The tech repeatedly tells me that IF I purchased a Western Digital AV-25 drive it would be detected as the DS is very hardware specific. I am suspicious and since I must order it online and it will take a week, my customer is getting impatient and wants to buy a new server if I cannot recover.

Feeling incredibly dumb for killing a successful recovery and was hoping I can find a way to either reinstall the firmware update properly?? or roll it back. Support did not fully understand my dilemma and even though I told him I installed it completely with the Marvell drivers the first time he insists that now the firmware won’t accept any other drives.

I would order the AV-25 if I thought it would work but I was wondering if you had any thoughts on his suggestion OR is there possibly another RAID driver that would allow detection of my drive?
Thank you for any input you can provide.

Did you try another drive? Even a 3.5 hanging from the side

I have tried several drives. I purchased (2) new Hitachi’s. I also tried 2 other used drives I have. All the same. The drivers are now seen as incompatible and I must uncheck the box that says hide imcompatible drivers just to have them show up. It did not do that on my initial successful install.

The 3.5 on the side is my boot drive. The (4) RAID drives are all data. No O/S on them and they were showing ok after my initial successful install.

Oh sorry you meant a desktop drive. No, I didn’t see that I could connect it but will try.

should be a 2.5 on the side? I meant any other drive, did not have to be a desktop drive

I am fairly certain the marvel drivers I supplied came with that firmware,

can you send a link to the firmware you applied? What I have/see really is not a firmware update as in BIOS but the WD system/OS

I really think your box broke :frowning:


I was tired. I’m sure I did not apply it correctly. I was trying to add functionality and I believe I ran the WDSUsetup. Yep, you are correct. It is a software upgrade for the server.

I’m afraid if there is no way to reinstall it properly you are probably correct. :disappointed:

I still have the question about whether the tech is correct that a certain model WD drive would be detected or is he just making a questionable assumption?

Thank you

Update: The RESET button on the back seems to have done the trick. After holding it in with power on it booted and allowed me to load the Marvell drivers again! O/S installed and completed basic setup. I think I’m good for now!

Last question: Is there anything I can or should install to this vanilla installation from WD? I guess I could try to apply the same update that messed me up but read the instructions this time?

Any suggestions are appreciated.

Thank you for being there!

I think what people have done in the past with success is to use my WD OEM tweaks from dropbox. I am pretty sure it is how the box is configured out of the box. It as more “stuff” than the firmware update you are trying. It would provide the base platform for you then to apply the newer update.

I do think you need to do this at minimum so the fans do not run on high all the time. That said it will invoke the white list for drives. It should still boot there will just not be any automatic raid of the os drive

The above said I cannot guarantee anything.

Congrats btw on your progress.

PS: When you have the WD tab in the dashboard you upgrade the firmware from there by pointing to the zip file

Is there a particular order that the tweaks be installed in? The contents looks very much like what I messed up with previously so I’m a little hesitant to launch WDSusetup. Thank you again.

I see from another post to run from an elevated prompt: C:\WD\run_logged_install.bat, C:\WD\WdLcdSetup_PreInstall.bat, then WdInstall.bat.

Is that correct?

This is my best educated guess. The tweaks file has 2 folders that the firmware zip does not. Again I think you need to do tweeks first

copy tweeks to c:\wd you may need to create c:\wd
run WDinstall.bat this will wiz and bang reboot then shutdown. You should see info on the LCD as this happens.

What I can’t figure out easily is whether post_oobe.bat should be run first, last, or never

ok I installed Tweaks and it completed successfully. Fans spun down and I have tools to work with. I then restarted even though it did not ask for a reboot. I then launched the Dashboard, Software, Monitor, Software update. I pointed at the ZIP file and it paused for a moment and then closed the dashboard. Nothing seemed to happen. I’m afraid to restart at this point thinking it may not have completed.


It also shows that my Hitachi Travelstar as “INVALID DRIVE”

I also noticed that after the WD software failed the fans are now at full speed again.

Any suggestions?

some dude was having trouble updating the firmware on a DX4000 because all the windows updates had not been installed. Make sure that is done.

Yes hitachi is not on the whitelist, if that bothers you, you can try to edit the whitelist or get the av drive and clone it later

one other idea, when tweeks is finished it is supposed to remove everything from c:\wd except the logs
if files are in there it may be confusing the firmware update

it also attrib +h c:\wd but I do not think that would matter

All updates now applied and tweak files have been removed from drive before attempting the firmware update. It still failed. another issue: Edit: I found where to rebuild the array and add the drive to it. It is rebuilding.

I HAD a degraded array. Could the degraded state prevent the upgrade of the firmware?

The current version of the software showing installed is That is also the version that is in the ZIP file. Is that correct? Are they the same version?

If so, since it was working better with the tweak files than it is now would it hurt to reapply tweak?

tweaks is
took me forever to get mine booted
make sure your wd services are started for the fans
raid would not affect firmware
in the monitor tab for wd hard drives configure should bring up the raid info
I see your edit now LOL

WD Services started: AFP Support, Health Monitor, LCD Support, Software Update.

Should there be any others?

My DS Box is showing the newer version is from the ZIP so it must have loaded some of it? Do you know what will happen if I attempt to install tweak? If I can get the fans to quiet down that’s about all I need. ? :smile:

I am not excited about doing tweeks again. Have you rebooted a couple of times? Recheck for windows updates

Yes updates checked repeatedly. Booted 4-5 times. I’ll check again after the rebuild but that will take 2-3 hours more.

RAID now good. Did a cold shutdown then restarted but the fan still on high. The LCD continues to cycle with “WD SOFTWARE UPDATE FAILED” as one message. I know it’s software since the tweak silenced it immediately.

When I open the Zip, It closes the dashboard as it said it would and starts the update. The LCD says “Updating WD Software” Only to fail in about a minute.

Any other ideas? Returning it tomorrow. Thank you very much for your time and expertise!

This is only a guess but probably will not hurt anything
you could copy PCThermaldriver.msi to c:\wd and run it