Secure WebDAV with WD Cloud Mirror 4TB

Hello Everyone!

I am trying to setup remote access to my WD Cloud Mirror so we can access it outside of the office.

First I looked at WD Cloud Access - but I can only get this to connect in RELAY mode and it is really, really slow. I tried to upload a 130MB file and it stopped twice - uploading at 10kB/s.

I then looked at FTP - but for some reason it wouldn’t  give me a directory list.

In any case, I have some non-technical people in the office (apparently I am one of them) and I really like the idea of Secure WebDAV. My thinking is:

  * Map the network drive on their PC - for use in the office

  * Add a network location to the drive for use out of the office.

  + The icons are different too - which should help them identify which one to use.

I have followed the guides online, and I can get WebDav to work on the Public share only. Obviously anyone can access this, so this is no good.

For the life of me, I cannot get Webdav to work to a share which requires a password. I have even made the registry change (BasicAuthLevel -> 2), as suggested in:  http://community.wd.com/t5/WD-My-Cloud-EX2/Secure-WEBDAV/m-p/766133#M792

When I make the change, and connnect to: “https://<my_external_ip>:4443/Share1” it asks for username / password (which it didn’t do before making the registry change). I put the details in and after 3 attempts it refuses. And yes, I’m putting in the correct account details!

I have done port forwarding on the router for ports 8080 (TCP) and 4443 (TCP) to go to the WD device.

I have done the Port Forwarding for the WebDav service on the device itself (not sure if I need to) but interestingly it says “Failed” for both 8080 and 4443?

Is there something that I am missing? If I cannot get the WebDav to work, is there anyway to improve the speed on the WD Cloud Access?

Thanks

Edit: I managed to get it to work on a Windows XP (32bit) machine, when connecting with: https://<my_external_ip>:8080/Share1. However, the same mechanism doesn’t work on Windows 7 (64bit) - even with the Registry mod. So at least I know I have setup the router / NAS drive correctly.

Hi, 

Are you able to check the firewall settings to see if that is preventing the connection? 

Also, have you tried setting the unit?

Did you tested the access with another device (for exampte an Android phone with the app ES File Explorer)?

To ensure that this is a “windows problem” or rather not a windows problem?