Scheduling in nas to usb drive backup

In the nad to usb backup, there is no option for scheduling /recurrance feature. Also no.option for full or incremental bckup . I really need those for my ex2 4 tb as im using jbod config. Other companies have this optioned enabled for ysb backup. IS THERE ANY CHANCE TO ADD THIS IN NEAR FUTURE?

Welcome to the Community.

Your post sounds more like a good Feature Request; the best place for this, is in the Ideas Exchange section. This way someone from WD will be sure to see it and will allow more users to support your idea.

However, I would first search and make sure that there are no other active Feature Requests suggesting the same or similar improvements. If there is, then you could add your post and vote on it.

Network Product Ideas

Here is how you can do it, provided you are moderately technical. You create the USB->NAS backup job as you normally would using the browser interface. When it runs in Linux (the actual OS for the NAS) the process looks like this:

usb_backup -a BackupJobName -c jobrun

The NAS provides the ability to ssh into it, so you can create a script with that in it and create a cron entry to run it on whatever schedule you like.

My entry is for my job “Full_Backup” is:

0 1 * * 0 /home/root/Full_Backup.sh &

which runs the backup every Sunday at 2am. Good lucjk.

Except backups from NAS to USB don’t work - at least using Copy mode.

They stall consistantly at 113GB (less than an hour into the job) after which the backup job continues to show as running. However all disk activity on the EX2 and USB drive have stopped and both have actually gone to sleep (if the EX2 is configured to sleep). Of course it would be a lot easier to spot that the EX2 itself has gone to sleep if it wasn’t for the utterly bizarre LED behviour in 2.10.302/310 firmware versions.

It doesn’t matter how many hours you wait, once it has stalled at 113GB that’s it.

Not much use trying to backup 335GB of data!

I’ve tried this multiple times with two different USB drives (Toshiba and WD Passport Ultra) using different settings (including full formatting of the Toshiba) recommended by WD support. Still doesn’t work and they have found evidence of a problem in the firmware from the system logs I’ve sent them.

For some strange reason if the backup is done in Synchronise mode (with an empty or non-existant destination folder on the USB drive) it APPEARS to work.

However I’ve now lost all confidence in the EX2.

I did over 500gb to a usb3 drive last night in copy mode…worked fine.
Are you using latest firmware?

Yep running 2.10.310 and it stalls every single time at 113GB. In synchronise mode it seems (appears) to work. How many shares are you backing up? For me a full backup is three shares. It always stalls in the first. (which for some reason is NOT the first alphabetically).

WD have confirmed they have found evidence of a comms issue to the USB drive (I’ve tried it on two different ones) in the system logs.

I might for the hell of it do a System Restore from the Utilities page of Settings. I had to do one both times it upgraded itself, first from the factory shipped F/W to 2.10.302 and again when it went to 2.10.310 (I’ve turned that off now) for it to work properly after the firmware update. But that is a serious pain in the behind as I have to set EVEYTHING back up. WD really need to find a way of doing firmware updates without the unit becomming unstable unless you do a System Restore afterwards. It really is clunky.

Just reread your post…I actually have the mycloud mirror 2 bay…not the
ex2…so I guess firmware would differ.

An interesting question would be, apart from minor tweaking of the user interface, IS there a difference between the My Cloud Mirror and the EX2? All I can see is the case colour and name - the My Cloud Mirror is white and the My Cloud EX2 is dark grey.

What version firmware does your My Cloud Mirror claim to have?

firmware is 2.10.310 on mine. I backup two shares. I have the gen1
mirror (meant to get gen2, oops)…system info is:

root@WDMyCloudMirror /proc # cat cpuinfo
Processor : Marvell PJ4Bv7 Processor rev 1 (v7l)
BogoMIPS : 1196.85
Features : swp half thumb fastmult vfp edsp vfpv3 vfpv3d16 tls
CPU implementer : 0x56
CPU architecture: 7
CPU variant : 0x1
CPU part : 0x581
CPU revision : 1

Hardware : Marvell Armada-370
Revision : 0000
Serial : 0000000000000000

root@WDMyCloudMirror /proc # uname -a
Linux WDMyCloudMirror 3.2.40 #4 Fri Jul 31 16:04:18 CST 2015 armv7l
GNU/Linux

You can see my backup job info here:

http://imgur.com/R8eq5pc

NAS has two 2TB WD red drives…unless your hardware is different (drive,
cpu, etc) it seems odd that yours would misbehave…Id RMA it and try again.

Mine shows exactly the same information, although having to use ssh to find out such basic information just illustrates how dire the “dashboard” user interface is once you actually get past the nice looking “façade”.

Even though the two look identical (apart from the name and case colour), the hardware and Linux distro/build report exactly the same information, there clearly must be differences in the firmware to differentiate the My Cloud Mirror and the EX2:

EX Series: http://www.wdc.com/en/products/nas/expert/

MyCloud: http://www.wdc.com/en/products/personalcloud/consumer/

So either they have the same firmware, but the EX features are disabled on the Mirror, or they are different to provide features like iSCSI, Active Directory integratrion (I’ve no idea if the Mirror has that in network settings), IPv6 (does the Mirror have that) which the EX2 has, installable 3rd party apps for things like DropBox.

I’m not the only EX2 user to hit the USB backup issue with 2.10.302/310

Mine also has two WD Red drives (3TB in my case).

You might find this thread interesting…

https://community.wd.com/t/2-10-302-hoses-nas-to-usb-backups

I also have no issue with dropbox…although the initial sync is absurdly slow I dont think thats WD fault. It uses the dropbox restful api which requires you chunk the files…and each chunk is its own https post…really horrible implementation on the part of dropbox.

just for fun I checked the chunk size…4mb…which explains the ridiculous amount of time per file.

and not to bombard you with posts, but when I did a check for firmware from the console, it actually returned the wrong binary…so make sure you download it from the WD site and install manually.

My issue with the DropBox app on the EX2 is that it has a setting for the local sync folder (default of “/public/dropbox”) which you can change. If you change it it will sync once to the new location. I even uploaded some files by dropping them into the folder I had specified. After that it reverted to using the default location, even though the local sync folder setting still showed the folder I had set, not the default.

I found that by accident. I kept clicking on SYNC and it kept going back to showing PAUSED almost immediately and that it was up to date. Yet when I checked the local sync folder I had specified it was missing recently added files. By pure chance I was browsing the /Public share and spotted that the DropBox folder had re-appeared (I deleted it after I changed the local sync folder). I checked in there and there were all the files INCLUDING the recent ones.

Just out of interest, in your 500GB+ of data that you were able to back up, how many files and folders did that comprise in total?

Thanks I’ll give that a try once it has completed it’s current backup (using sync mode).

File counts in the two shares:

root@WDMyCloudMirror Public # find . -type f | wc -l
30470
root@WDMyCloudMirror Public # cd …/Atazi
root@WDMyCloudMirror Atazi # find . -type f | wc -l
1014

Folder count in the two shares:

root@WDMyCloudMirror Public # find . -type d | wc -l
6033
root@WDMyCloudMirror Public # cd …/Atazi
root@WDMyCloudMirror Atazi # find . -type d | wc -l
186

so grab the mirror firmware and see if that helps…worst case is you have
to revert.

Mirror doesnt have those features…near as I can tell, thats the only
diff…

Your file counts are very interesting. In the other thread I posted a link to “2-10-302 Hoses Nas to USB Backups” Stealth57 mentioned that WD indicated it could be related to the number of files and fodders, rather than the actual total size.

My three shares are (files):

root@flat-nas-01 /shares # cd Inaki
root@flat-nas-01 Inaki # find . -type f|wc -l
35068
root@flat-nas-01 Inaki # cd …/george
root@flat-nas-01 george # find . -type f|wc -l
46393
root@flat-nas-01 george # cd …/Public
root@flat-nas-01 Public # find . -type f|wc -l
100495

and folders:

root@flat-nas-01 Public #
root@flat-nas-01 Public # cd …/Inaki
root@flat-nas-01 Inaki # find . -type d|wc -l
2191
root@flat-nas-01 Inaki # cd …/george
root@flat-nas-01 george # find . -type d|wc -l
3182
root@flat-nas-01 george # cd …/Public
root@flat-nas-01 Public # find . -type d|wc -l
5254

When I try a full backup of all three it stalls backing up the first share, Inaki, after 113GB. That one share has more files (35,068 vs 31,484) and but fewer folders (2,191 vs 6,219) than both of yours combined.

My total backup, while smaller in actual size (335GB vs 500GB+) is far greater in terms of files and folders than yours (181,956 vs 31,484 for files and 10,627 vs 6,219 for folders). This would tend to support Stealth57’s conjecture that the Copy mode backup has problems backing up large numbers of files/folders.

perhaps…nothing about those numbers seems remarkable. The only thing I could imagine with those counts is that they are using a 16 bit counter and you are blowing past the 65535 max…but that is of course pure speculation. Were that the case, someone needs to be flogged.