2.10.302 Hoses NAS to USB Backups

The previous firmware was running great. I did the stupid thing of upgrading (should have learned my lesson from the My Cloud v4.x upgrades).  Now, NAS to USB backups that were taking just a few minute are still running after 18 hours.  I also see that instead of replacing the changed files, it is now leaving two new files appended with _1 and _2.  Does the backup now backup both RAID drives?  Whatever it is doing, it is a major setback.

Are you certain this is related to the firmware update? Have you tried testing other USB drives in order to confirm if it only happens with a particular USB drive?

The only thing that changed was the upgrade.  The backups won’t complete and they will not allow cancellation. I hit the cancel button yesterday and Dashboard still shows them attempting to be stopped.  The My Book was working perfectly and can still be accessed and move files through Windows Explorer.

At this point, I need to reboot the EX2100 and see if that clears up some of the issues, but given other comments on this firmware version, I will likely downgrade to the previous version.

I’m getting problems doing NAS to USB backups as well with F/W 2.10.310.

The external USB drive I’m using is a 1TB Toshiba Canvio Slim. It works fine otherwise when plugged into one of the USB 3.0 ports on the back of my EX2, however when I try to do a NAS to USB backup it just keeps stopping. It appears to go ok for a while then all drive LED activity on the EX2 and the Toshiba just stops. After a while like that the Toshiba goes into power save mode.

No entries in the system log (complete with Mov for Nov spelling mistake) to indicate what is going on. Perhaps WD should redesign the Dashboard to give more useful information on backup job progress and not have it so Micky Mouse.

I must admit after a month or two with the EX2 I’m beging to start thinking of asking WD for a refund. The firmware seems to have more holes than swiss cheese! Perhaps they should just stick to making the drives themselves.

This is now a known problem with “OS3.” I have provided all the data to Level II support and they say engineering is looking into it, but it has been weeks with no reply. WD also changed their web access so it only works if you are on OS3. So, I have the choice of being able to remotely access my files on the EX2100 or being able to back up files to the USB drive (by downgrading the firmware).

The previous firmware was working perfectly in all respects, now WD has figured out a way to screw up the system. Apparently they don’t test their firmware with real users and just dump this junk on their customers hoping they will do the debugging for them.

I don’t bother going via the “support” link in the Dashboard - I’ve never got it to work properly (in terms of uploading system logs etc) anyway… Not surprising… I go to the support section of their website and log issues on there, for all the good it does.

I’ve an EX2 (3TB) at home, an EX2 (2TB) at work for hosting PC backups. Wouldn’t buy another WD NAS. I have just spent £1K on a 16TB 4 bay NAS from QNAP for work (TS-453 pro) and the OS is miles better…

I have had a “personal” Level II tech assigned to me since I was having the exact same issues with the original My Cloud. They upgraded me to a Mirror when they couldn’t fix the issue and then to the EX2100 when the Mirror wouldn’t back up either. Now, they change the firmware and my tech is back to square 1.

Hi Stealth,

Well I thought it worth opening my own support case for this. I also put at the end some scathing comments about OS3 and how 2.10.302 and 2.10.310 are so bug ridden they should never have seen the light of day.

I did get a backup to work eventually by following a suggestion in another thread, by using the “Synchronise” mode instead of copy. That at least finished and appeared to backup all 333GB. I still thought it worth adding some comments on how dire the backup user interface is in terms of backup progress and total lack of apparent backup logs.

I thought it worth finishing off by telling them if they don’t get it fixed rapidly I would like a full refund. The EX2 as is it, contrary to what they have on their website, seems to be little more than a very buggy toy. The litany of issues with the much vaunted OS3 is long - hell they can’t even get the OS and firmware versions to have the same major version number, never mind the LEDs to work sensibly in power save.

Hey Stealth!

Looks like I now also have my own techie, aparently taking on my current three issues… It will be interesting to see what he comes up with now he has the EX2’s logs etc. Meanwhile I’ll get back to doing my Windows SBS 2003 to Server 2012 R2 Hyper-V migration at work (one Hyper-V host running two virtual servers)… LOL…

Do you see any downside to sync vs. copy? I don’t delete anything from the EX2100 so I would think the copy and sync would end up doing the same thing. I don’t use sync between my computer and the EX2100 as I do delete old items from my computer on occasion but want the EX2100 to keep all the archive records.


Hi Stealth,

If you just want the USB drive (or drives) to be a total backup of your EX2100, then I don’t see any downside (apart from the fact plain COPY should work!). I think the key thing is that if the backup destination folder on the USB drive does not exist, then the two should be the same. Sync can be very dangerous, at least I think, if one is not absolutely clear about which is the SOURCE and which is the DESTINATION.

As I understand it the MyCloud backup in COPY mode just copys everything your specify as a source on your MyCloud into the destination on your USB drive. If that destination already exists and contains files then any files of the same name will be over written. Any files in the desitnation on your USB drive which DO NOT exist on your MyCloud will just stay their.

In SYNC mode all source files on your MyCloud which DO NOT exist in the USB destination (because they are new) will be copied across. Any file on your MyCloud which also exists in the USB destination will get copied across overwriting the one on the USB drive IF the MyCloud version has changed (not sure yet just how it determines that - modified date and time plus size possibly). Any files left in the USB destination which DO NOT exist in the source folder(s) on your MyCloud will be deleted from the USB destination.

At least that is how I interpret it :wink:

Keeping the above in mind, if the destination folder on the USB drive doesn’t even exist (which is what I had) then SYNC and COPY do the same thing since everything in the source folder(s) on your MyCloud are new, as they currently don’t exist.

So assuming my interpretation of the MyCloud backup behaviour is correct, backup using the SYNC mode SHOULD make the destination folder(s) on the USB identical to the source folder(s) on the MyCloud, even if that means deleting files from the destination folder on the USB.

How that all pans out the other way round (USB to NAS) I’ve no idea since I’ll only ever be doing NAS to USB. For me the USB drive is my backup of the NAS.

Hi Stealth,

I’ve now done a whole serious of tests for WD support to provide evidence and data for my open support case on this issue. At their recommendation I’ve even done a full (not quick) NTFS format of my Toshiba 1TB USB drive and tried backups using various share and media serving settings.

Backups in Copy mode seem to work for backup jobs of a few 10’s of GB. However in every single test trying to backup the data I want and need to backup it stalls consistantly at 113GB.

I’ve even tried it to a WD 2TB My Passport Ultra (I needed it anyway) to eliminate accusations that it is a problem with the Toshiba drive. Exactly the same results. It stalls at 113GB, 40 or so minutes into the job. Once stalled it doesn’t matter how many hours it is left, it is well and truly dead.

I also found the same thing as you with stopping a stalled job. It just sits there with the “animated barber’s pole” progress bar, saying it is stopping, but several hours later nothing has changed (and the job STILL shows as running) until you delete it.

I’ve now provided WD support with 4 (I think) sets of system logs (they HAVE found an indication of a problem communicating with the USB drive during the backup) and numerous screen shots.

No explanation from them as to why it “appears” to work in Synchronise mode. However I’ve now no confidence in the EX2. To me it is simply not fit for purpose unless they fix (and rapidly):

  1. The backup issue.
  2. The fan control issue
  3. The LED behaviour in power save/sleep. My EX2 was actually going to sleep as well as the USB drive after the backup had stalled, but I hadn’t noticed it before because of the stupid LED behaviour. I want the LEDs ON so I can see it is doing something (like the backup is working!), but I don’t want to have to cover the damned things with tape at night!
  4. The significant bug in the Drop-Box app. You can change the default download/local synchronise folder, but that seems to break syncing. Except it doesn’t! It DOES sync, but still to the default location after doing a half-hearted effort to the one specificed even though the config information STILL shows the location I’ve specified.

3 days ago I asked Level II to verify if your comments regarding sync vs. copy were correct. If so, I can just use sync. They chose not to respond…

By the way, I haven’t looked at how much data comes across in copy mode on my EX2100 before the stall, but I had this same issue with the plain old My Cloud and while it would just quit and not pretend to keep going, it always died at about 210GB. The logs for that showed all the system resources were being consumed and the firmware would see this as a time out error and quit. I suspect that OS3 has hogged all the resources and now has the exact same problem as the under powered My Cloud and My Cloud Mirror.

So far WD are claiming my issue is a comms problem between the EX2 and the USB drive. Part of my reason for buying a WD Passport 2TB! :wink: Just in case they try to blame the Toshiba’s firmware… Now I’ve replicated the problem on the WD Passport they can’t use that excuse… :wink:

I’ve got a nice shiny new QNAP TS-453pro at work to play with for backing up the new server (one Hyper-V host and two virtual servers). Very nice so far - but then it did cost £1K for a 16TB 4-bay unit (4 x 4TB drives configured as RAID 10). Glad it was work paying! LOL

If WD don’t sort this, and some of the other issues out, I’ll be wanting a refund to go and buy a QNAP.

This has nothing to do with the brand of the USB drive. I use a 3TB My Book (reformatted at WD’s request several times). The NAS to USB backups failed on the 3TB My Cloud, 6TB My Cloud Mirror, and, after the OS3 firmware upgrade, the 8TB EX2100. All failures were WD hardware to WD hardware.

Interesting… A user in this thread, https://community.wd.com/t/scheduling-in-nas-to-usb-drive-backup his works fine.

Obviously we have a very different experience.

WD stated that the issues with NAS to USB copy, at least for the My Cloud and My Cloud Mirror were a function of file type and number of files and not total size. A lot of small files will act differently than a few very large files even if the total backup is the same size. What I couldn’t get out of them was what types of files are the issue.

Just out of interest, have you tried running a backup job of the type that normally stalls for you in sychronise mode? It would be interesting to compare results.

We could be on to something there… Take a peek at my post in the thread I quoted earlier. We have a comparison of a claimed 500GB+ working backup verses mine when it stalls after 113GB. The comparison of total files and folders is interesting. It would be great if you were able to add some figures for the number of files and folders involved in your stalled backups.

That would give is some real stuff to compare.

While OS3 will not back up any Shares, the one Share that always had issues with the My Cloud and My Cloud Mirror was one with a mix of Windows and Mac files. That share has 256GB, 66,352 files, and 16,419 folders. It is a mix of documents, mp3, mp4, and jpg files.