USB Backup Failure - settings question

Hey, I appreciate anything anyone can tell me. I’ve got an EX2, and I don’t know enough about how it should be configured to permit this, but I’m simply trying to back up one share to a totally empty USB drive. Yes, I can read, so I can see how to create a job for backing up in a USB drive. The problem seems to be that when I create the job, and set the whole thing up, the job fails, and it tells me to check my settings. No idea what in my settings would be creating the problem. I haven’t done anything weird with my settings. 

My firmware is updated. Beyond that…I’m at a loss. Nothing in the manual, nothing I can find on this board. Can someone show mercy on a newbie? 

Hi and welcome to the WD community.

Try to reset the unit and see if after the reset process you are able to do the backup on the USB drive, you can also try to do a system restore on the unit and see if that also helps.

Here are some links that might help you with the reset process and also the factory restore process:

http://wdc.custhelp.com/app/answers/detail/a_id/10432

http://wdc.custhelp.com/app/answers/detail/a_id/10433

Hope this helps you out.

i have the same problems with my new wdmcex2.

i made a USB backup to a WD Mybook hdd,. 

it was 2.5 Tb and took a very long time! 

at 99% it gave the information ‘backup failed’ 

i tried a synchronization,  but that gave the same results. 

it is a new Wdmcex2 with the latest firmware

i have also a white wdmc single disk with backup problems,  but that was solved by the last firmware. 

why can’t WD make workable software? 

a good working backup is essential for this kind of hardware! 

now i need to backup with CCC on my Mac (which is actually faster that the WD software!) 

does WD really care about this? 

last update didn’t change anything about the backup proces! 

Thank you for the reply! I did the button reset, and the factory restore. Same problems. With the added one that once I reset to factory settings, it then seemed to think I’m time machining a backup, which I am not. 

I’ve switched drives, from a Seagate USB drive to a WD My Passport, just for brand continuity. Made no difference. More ideas? (And thank you)

it has nothing to do with resetting anything! 

it’s the firmware that’s failing! 

i have a brand new wdmcex2.

the question is what is WD going to do about it? 

nothing until now! 

Fun new twist: it backed up one folder, but not another of similar size and provenance.

Exactly the same problem here… new EX2, latest Firmware, I have reset etc but no change.

I can backup NAS -> USB fine with some folders, if I include other folders it fails telling to to check my system settings.  There is nothing special about the folders that fail. I can view them and copy then in explorer no problem.  I have spent 4 days so far trying to identify the problem folders in the shares. 

So…

  • are there better log files hidden on the EX2?  I have ssh enabled and have had a look but don’t see anything.
  • thisdoesn’t seem to be a one-off problem.  Are WD looking at it?

Yes, I have the same problem. For me here is what happened. I started a backup USB to USB, in this case a new WD My Passport 2TB. After about 10 minutes it gave the message that Backup had failed and to check settings, etc. At that point everything seemed to lockup. The Dashboard quite responding and I could not access anything on the My Cloud or the USB drive. The lights on the USB drive continued to flash as if there were activity. Finally after about 30 minutes, I disconnected the USB drive. At that point, I could access the My Cloud again. When I plugged the USB drive into my computer, it wanted to do a scan which I allowed. It reported that it had found and fixed errors. When I looked at the files on the disk it had actually copied quiet a few of them, so it was likely continuing to copy files even after it reported a failure. I certainly agree that this unit is not ready for prime time. Too bad, I had such high hopes. There are some really smart folks out there on this forum, your input would certainly be appreciated. Jim

I stopped using the backup of the wdmcex2.

It’s totally unreliable for its purpose. 

The strange thing is that I had the same problems with my white one disk wdmycloud. 

But these problems were solved with the last firmware. 

The ex2 uses a different back up system,  but from WD no information. 

I now think I better could have bought a Synology NAS. 

It would have been a little bit more expensive,  but more reliable! 

WD doesn’t take their customers very serious,  and doesn’t show much haste to solve anything. 

It’s really a waste of money and time. 

I now use CCC backup on my iMac,  which is actually faster and totally reliable! 

WD should stop making Nas products if they can’t make them reliable. 

I tried backing up another folder using the backup and it worked, but it is awfully hard to trust now. Could it be some error on the section of the disk being backed up. How do you run the equivalent of a chkdsk on the EX2?

Jim

For what it’s worth.  Am having the same issue.  External Hard drive plugged directly into the My Cloud EX2, backup works for some folders/files, but not others.

I tried the same folder that I had a problem with and it worked. Nothing (that I know of) had changed, but now it worked.

Just experienced the same problem. I see most complaints here are a month or two old - and various suggestions does not help !

Why has not WD done anything about it ?

I bought my EX2 just to enjoy the speed of USB3 backup. Major disappointment !

Just registered to post that I’m having the same issue.

I bought the Ex2 to backup somewhat  large volumes of data I have strewn over several external USB drives.

USB backups from an external drive to the NAS fail, without any specific error message other than “check your settings”.

I tried connecting the USBs to my computer and copying the files over the network. It’s unmanageably slow and it also failed while copying.

I’ve tried with several drives that I can read without issues from my computers.

I tried working this out in early January, gave up and waited for a firmware update that would fix this. I’ve just plugged in the Ex2 to try this again, but there are no firmware updates nor any other new resources I could find online to resolve this.

This is ridiculous. It’s a very basic functionality for a NAS that’s broken here. USB 3 BACKUPS IS ALL I BOUGHT IT FOR!

So far, what I’ve gotten out of my purchase is a nice, network-enabled paperweight.

I apologize for the tone of my post, but I’m incredibly frustrated. I certainly wouldn’t have bought the product if I’d known of this issue.

WD: Please look into this!

Thanks.

I have the same issue with not being able to use USB drive for backup.  The Support from WD is terrible, they first just send a link to the manual for how USB is ment to work, then they say install the latest firmware and run a system check (I already have the latest firmware).  They dont seem to want to just admit that the USB backup function does not work for everyone and that they have buggy firmware.  

I run a WD My Book Live DUO and have no problems backing up to a USB drive via safepoints.  They should add safepoints to the EX2 as at least they worked. So far this has been a poor buy and I may have to re-house the RED drive in a differnt NAS box.

I wrote it several times here: one ‘bad’,  or otherwise  not accepted,  file can make a whole backup fail.

Without any information whatsoever. 

Not what,  where,  or why! 

Nothing! 

Last time it took me almost a day to find the ‘bad’  file on a 4Tb hdd,  and after removing the file the backup completed successfully. (99% to 100%)

So the main 2 problems are,  

why isn’t there any information when it failed.? (to know what and why) 

And why can’t you choose more than one folder to backup,  so you can deduct by taking half of all until you find the bad file(s) (to know were) 

Without this,  backing-up is just a gambling game. 

Wow, birdyX - that’s frustrating. 

I’m sorry to hear more people are having the same problem I did (and possibly do). For what it’s worth, I found some luck parsing the USB backup jobs into smaller batches. I’m not sure how much success - which is part of a larger problem. 

To explain: I did obtain USB backups by sectioning the entire project. But I can’t possibly check the work because it’s audio files, and even getting a read of what’s in a hierarchical folder system is **bleep** near impossible. It brings up the beach ball; it crashes the finder. (For what it’s worth, this is work, as well as a personal music library.)

I can connect directly to the router with my mac. But while I haven’t clocked the file transfer speeds, I’m not seeing an appreciable difference in my ability to manage multiple small files on this NAS. Which is stupid and ironic and insulting because this NAS was sold as a place where I could do exactly that. 

For now, I’m stuck with this box. BirdyX just pointed out that it doesn’t communicate very well about the problems in its operation. So what remains is to find the optimal way to operate it when it comes to lots of small files, file transfers and file management. 

That said, I’m still basically an almost-newble who doesn’t know how to troubleshoot or bulletproof my setup. I’ve seen other threads (not about USB backups, but about file transfer problems) in which very experienced folks on this board use words that are way above my head to explain how to set up this system. What that tells me is - I probably need to consult with someone who’s more of an expert, individually, about making this NAS useful and not a destructive force in my life. 

Anyone know anyone who does that? Can you offer a link to a profile, a website, something? 

I have not used the backup feature on the EX2, so I can’t say whether any info surrounding the backup failure is actually available in the logs, but I’d think normally that’s where any failures would be logged, like the log feature of any computer. Have you looked in the logs at all that are available via the dashboard (under Settings tab -> Utilities -> System Diagnostics -> System Logs -> View Logs)?

I purchased my ext2 in the summer of 2014.  I purchased a 2TB WD Elements external USB drive to backup to in the fall of 2014.  As all other posts in this thread, backups from the NAS to the USB drive fails.

When I first started attempting backups, I opened a support case with WD.  I went through the normal trouble shooting steps with the tech.  Reset to factory settings, manually update the firmware to the latest/greatest (even though it was already at the latest version), verify that the WD Elements external USB drive is really accessible by plugging it into a PC, formatting the USB drive.  

The support person finally bumped the case up to engineering.  I was told that they were able to duplicate my issue (and from reading this post, so are many other users).  However, the support person said that engineering would address this in some future release, but didn’t know when and closed my case.  I protested about him closing the case, but I was pretty much told just to deal with it.  If a case is closed, then they’ll forget all about it.  Out of sight, out of mind.

It seems to me that the backup application has an issue with the number of files that it is trying to backup.  I have thousands of images, audio and video files.  I have about 30,000 photos and images,all broken down by year.  If I try to backup the entire public/photos directory, the backup files.  If I backup a single year, the backup works.  However, we are only allowed a maximum of 10 backup jobs.  That will not work.  I would need close to two dozen backup jobs in order to backup all of my contents.

I have additional data that I intend to put out on the NAS, but I can’t until a backup solution is found.  As many of the others in this post, I’m frustrated with support and engineering.  WD customer support leaves a lot to be desired.  

Anyone know of any alternative backup solutions that we can use, and not rely on the internal backup?

Daryl

I am having the same issues backing up to an external USB drive. Backups fail and not complete. Very unreliable. The other issue is that backups to a USB drive can not be scheduled. Currently the only way to backup to a USB drive is to login to the admin page of the drive and manually start the backup. This seems to me like an incomplete product.

This could be a great unit if all these issues are corrected by WD with a new firmware. I think many of us are waiting for these fixes…soon.

Thanks.